dev-python/pylint: bump to version 2.2.2
authorJonas Jelten <jj@sft.mx>
Sat, 26 Jan 2019 23:08:52 +0000 (00:08 +0100)
committerVirgil Dupras <vdupras@gentoo.org>
Fri, 1 Feb 2019 01:10:12 +0000 (20:10 -0500)
Closes: https://bugs.gentoo.org/662406
Signed-off-by: Jonas Jelten <jj@sft.mx>
Signed-off-by: Virgil Dupras <vdupras@gentoo.org>
dev-python/pylint/Manifest
dev-python/pylint/pylint-2.2.2.ebuild [new file with mode: 0644]

index 349ec023c978632285baf257dc7ed715fa7eeac2..90c98c2edd35d8ecb924c8419212a59c52c81ea1 100644 (file)
@@ -3,3 +3,4 @@ DIST pylint-1.7.2.tar.gz 488628 BLAKE2B 6f2902bdd18939f251515d652d2e9df43162c1b0
 DIST pylint-1.7.5.tar.gz 486892 BLAKE2B 0a415045e16aeb6e8543af003cff3061756b01bcbeb9f62de7cf1a63356ff01c3a2fd079e51ee0f8b1b797dd3de29c14d9928c0b4d0214fda82fbc2dc12010c6 SHA512 9f28cc4f88b26d2299ab3ea015935fba8c96f700c7898ad8fbdecfa0902f10a4ca54ad346b18452f8a589f8b63494bc12487dab36d168f336012b259bfa6f3f8
 DIST pylint-1.8.2.tar.gz 510319 BLAKE2B fd2d28d48cc5b7690428baf3e4a4ba56a6c59dd3bae6fac12046f2c087f1f6d033f4c318f2977d3ee3cc6a463a089a02364f0e38859c2eba5a39dbe6350e19ec SHA512 3cec971314bcc9ad7aa32d6641797adb0adc440414cfe982a10777ffeecfc64588f9c1d8c6d8074131b1389fe5ecb2e6aea5c24ba3047f917a60d12808b52d8c
 DIST pylint-1.8.4.tar.gz 512582 BLAKE2B 623e224ec71756cc2528346ac62b8e58ac4d5ef55d9e31e667d5389aa5b2dad712f60c7e90df5c831f57bf28e0ccbd00ddece4ade46410c28b67adb1a041a85f SHA512 07e55ed3f09326e1973215046e3b172f6065a7ed0ae657cba7a6825a26bb103bdbf8b83126bafd99f332fe0eec3547bcd6e618d6e9f612ddcf9c504bb850dcd9
+DIST pylint-2.2.2.tar.gz 568313 BLAKE2B a6a3a48a96820bf9412dbd5f3e643d95fe7c9ead9752920d9979debaf5da53a3b5076c39975dd37420c86b71fd2ed2f513c42663fbaf1e6103a0958271773c58 SHA512 29a9bf39413479cb2996b1a2e0d3aaa1845faf3038b17c30948554c359fe8cc858e9bfc0488ed0af204daea22e0ab36d765c447eae66ac7ac6d60d66d9a33fef
diff --git a/dev-python/pylint/pylint-2.2.2.ebuild b/dev-python/pylint/pylint-2.2.2.ebuild
new file mode 100644 (file)
index 0000000..5a14d9c
--- /dev/null
@@ -0,0 +1,56 @@
+# Copyright 1999-2019 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6,7} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="Python code static checker"
+HOMEPAGE="https://www.logilab.org/project/pylint
+       https://pypi.org/project/pylint/
+       https://github.com/pycqa/pylint"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples test"
+
+RDEPEND="
+       >=dev-python/astroid-2.0.0[${PYTHON_USEDEP}]
+       >=dev-python/isort-4.2.5[${PYTHON_USEDEP}]
+       dev-python/mccabe[${PYTHON_USEDEP}]
+       virtual/python-singledispatch[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+       doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+       test? ( ${RDEPEND}
+               dev-python/pytest[${PYTHON_USEDEP}]
+               dev-python/six[${PYTHON_USEDEP}]
+       )"
+
+python_compile_all() {
+       # selection of straight html triggers a trivial annoying bug, we skirt it
+       use doc && PYTHONPATH="${S}" emake -e -C doc singlehtml
+}
+
+python_test() {
+       ${EPYTHON} -m pytest -v pylint/test/ || die "tests failed"
+}
+
+python_install_all() {
+       doman man/{pylint,pyreverse}.1
+       if use examples ; then
+               docinto examples
+               dodoc -r examples/.
+       fi
+       use doc && local HTML_DOCS=( doc/_build/singlehtml/. )
+       distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+       # Optional dependency on "tk" USE flag would break support for Jython.
+       optfeature "pylint-gui script requires dev-lang/python with \"tk\" USE flag enabled." 'dev-lang/python[tk]'
+}