app-benchmarks/hey: Fix compile with go-1.13
authorZac Medico <zmedico@gentoo.org>
Tue, 17 Sep 2019 23:56:45 +0000 (16:56 -0700)
committerZac Medico <zmedico@gentoo.org>
Tue, 17 Sep 2019 23:56:45 +0000 (16:56 -0700)
Package-Manager: Portage-2.3.76, Repoman-2.3.17
Signed-off-by: Zac Medico <zmedico@gentoo.org>
app-benchmarks/hey/hey-0.1.1_p20181017.ebuild

index 0be025d4eb3e03aa25be84bd514a1e965a7e8a1b..1b73bfe82c498fc40d01da77cde9938ef7e5cb78 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -22,8 +22,8 @@ RDEPEND=""
 S=${WORKDIR}/${P}/src/${EGO_SRC}
 
 src_compile() {
-       GOPATH="${WORKDIR}/${P}" GOBIN="${WORKDIR}/${P}/bin" \
-               go install -v -work -x ${EGO_BUILD_FLAGS} "${EGO_PN}" || die
+       GOPATH="${WORKDIR}/${P}" GOBIN="${WORKDIR}/${P}/bin" GO111MODULE=on \
+               go install -mod=vendor -v -x ${EGO_BUILD_FLAGS} "${EGO_PN}" || die
 }
 
 src_install() {