app-editors/aee: drop old
authorAkinori Hattori <hattya@gentoo.org>
Sun, 10 May 2020 09:41:53 +0000 (18:41 +0900)
committerAkinori Hattori <hattya@gentoo.org>
Sun, 10 May 2020 09:42:46 +0000 (18:42 +0900)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Akinori Hattori <hattya@gentoo.org>
app-editors/aee/Manifest
app-editors/aee/aee-2.2.15b.ebuild [deleted file]
app-editors/aee/files/aee-2.2.15b-ae-location.patch [deleted file]

index 546e1aa98e574a919ae643e52d01da0bf27b29b9..11e79c3f72002099722507ab4f9c35620bb0d104 100644 (file)
@@ -1,2 +1 @@
-DIST aee-2.2.15b.tar.gz 184218 BLAKE2B f249c0974a971aa6a1bb38afb8675a3ace671d244c717add4ea2f724ac1d07bf1c57c5d27fb6f9f40f27b3055ba94cf959dd4b855181a83f4522c44124c0b994 SHA512 2810cd8f5148edb352fdaefbc823d417b9a83c8083644c8729be8595013ca8ba660bd72120db1e15915e454f5185d2d030c2f0c853b37eb83c213c1d581a640f
 DIST aee-2.2.21.tar.gz 186304 BLAKE2B 2d41678e07f6590023f428e042686c92377200826f86ebb28fe93ec1e5f07290de6eef765dbae91efcef01d32896127c044f20c204b50ed50894fd743cb1fc19 SHA512 c052ef97b18fa9900e9bf0c5894e05cbbf775d7de4ad4c14cb9e3e7758983c84e4768995a98398c05e30173464e6f7994e7f476522a314bc25dac5a84831155a
diff --git a/app-editors/aee/aee-2.2.15b.ebuild b/app-editors/aee/aee-2.2.15b.ebuild
deleted file mode 100644 (file)
index 56d7756..0000000
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-
-inherit toolchain-funcs
-
-DESCRIPTION="An easy to use text editor"
-#HOMEPAGE="http://mahon.cwx.net/ http://www.users.uswest.net/~hmahon/"
-HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
-SRC_URI="mirror://gentoo/${P}.tar.gz"
-
-LICENSE="Artistic"
-SLOT="0"
-KEYWORDS="amd64 x86 ~amd64-linux"
-IUSE="X"
-
-RDEPEND="X? ( x11-libs/libX11 )"
-DEPEND="${RDEPEND}"
-
-PATCHES=(
-       "${FILESDIR}"/${P}-ae-location.patch
-       "${FILESDIR}"/${PN}-Wformat-security.patch
-       "${FILESDIR}"/${PN}-gcc-10.patch
-)
-DOCS=( Changes README.${PN} ${PN}.i18n.guide ${PN}.msg )
-
-src_prepare() {
-       sed -i \
-               -e "s/make -/\$(MAKE) -/g" \
-               -e "/^buildaee/s/$/ localaee/" \
-               -e "/^buildxae/s/$/ localxae/" \
-               Makefile
-
-       sed -i \
-               -e "s/\([\t ]\)cc /\1\\\\\$(CC) /" \
-               -e "/CFLAGS =/s/\" >/ \\\\\$(LDFLAGS)\" >/" \
-               -e "/other_cflag/s/ \${strip_option}//" \
-               create.mk.{aee,xae}
-
-       default
-}
-
-src_compile() {
-       local target="aee"
-       use X && target="both"
-
-       emake CC="$(tc-getCC)" ${target}
-}
-
-src_install() {
-       dobin ${PN}
-       dosym ${PN} /usr/bin/rae
-       doman ${PN}.1
-       einstalldocs
-
-       insinto /usr/share/${PN}
-       doins help.ae
-
-       if use X; then
-               dobin xae
-               dosym xae /usr/bin/rxae
-       fi
-}
diff --git a/app-editors/aee/files/aee-2.2.15b-ae-location.patch b/app-editors/aee/files/aee-2.2.15b-ae-location.patch
deleted file mode 100644 (file)
index 4a17642..0000000
+++ /dev/null
@@ -1,89 +0,0 @@
---- a/aee.1
-+++ b/aee.1
-@@ -678,7 +678,7 @@
- .\"
- .SS Initializing aee From A File
- .PP 
--\fIaee\fR checks for a file named \fIinit.ae\fR in \fI/usr/local/lib\fR, 
-+\fIaee\fR checks for a file named \fIinit.ae\fR in \fI/usr/share/aee\fR, 
- .I .init.ae 
- in the user's home directory, then for \fI.init.ae\fR in the 
- current directory.  (This file may be created manually or by using the 
-@@ -960,7 +960,7 @@
- .PP
- On-line help is provided through the 'help' command or menu item.  This 
- command uses a file with help information.  By default the help file is 
--located in \fB/usr/local/lib/help.ae\fR, but this file may be located 
-+located in \fB/usr/share/aee/help.ae\fR, but this file may be located 
- in the user's home directory with the name \fB.help.ae\fR, or in the 
- current directory with the name \fBhelp.ae\fR.
- .\"
-@@ -1017,7 +1017,7 @@
- .\"
- .SH FILES
- .PP
--.I /usr/local/lib/init.ae
-+.I /usr/share/aee/init.ae
- .br
- .I $HOME/.aeeinfo
- .br
---- a/aee.c
-+++ b/aee.c
-@@ -2612,7 +2612,7 @@
- char *init_name[4] = {
-       "/usr/local/aee/init.ae", 
--      "/usr/local/lib/init.ae", 
-+      "/usr/share/aee/init.ae", 
-       NULL, 
-       ".init.ae"
-       };
---- a/aee.msg
-+++ b/aee.msg
-@@ -2,7 +2,7 @@
- $ 
- $set 1
- $quote "
--1 "/usr/local/lib/help.ae"
-+1 "/usr/share/aee/help.ae"
- 2 "main"
- 3 "modes menu"
- 4 "tabs to spaces        " 
---- a/help.ae
-+++ b/help.ae
-@@ -1058,11 +1058,11 @@
-       The file 'init.ae' may be used to set parameters and define keys to 
- perform certain functions within ae.  This file may reside in three 
--locations: /usr/local/lib/init.ae, .init.ae in your home directory, and 
-+locations: /usr/share/aee/init.ae, .init.ae in your home directory, and 
- .init.ae in the current working directory.
-         First, aee checks for a system level initialization file, located in 
--/usr/local/lib.  Next the user's home directory is checked for a file named 
-+/usr/share/aee.  Next the user's home directory is checked for a file named 
- .init.ae, then the current directory.  The settings from each file are read, 
- so that the directives from the most recently read file will take precedence 
- over previously read files.  This allows, for example, the .init.ae file in 
---- a/help.c
-+++ b/help.c
-@@ -12,7 +12,7 @@
- char *help_file_list[4] = {
-       "/usr/local/aee/help.ae", 
--      "/usr/local/lib/help.ae", 
-+      "/usr/share/aee/help.ae", 
-       "~/.help.ae", 
-       "help.ae" 
-       };
---- a/localize.c
-+++ b/localize.c
-@@ -64,7 +64,7 @@
-       catalog = catopen("aee", 0);
- #endif /* NO_CATGETS */
--      ae_help_file = catgetlocal( 1, "/usr/local/lib/help.ae");
-+      ae_help_file = catgetlocal( 1, "/usr/share/aee/help.ae");
-       main_buffer_name = catgetlocal( 2, "main");