net-wireless/iwd: bump to 0.8 with wired & ofono support
authorBen Kohler <bkohler@gentoo.org>
Fri, 21 Sep 2018 12:59:40 +0000 (07:59 -0500)
committerBen Kohler <bkohler@gentoo.org>
Fri, 21 Sep 2018 13:01:25 +0000 (08:01 -0500)
Package-Manager: Portage-2.3.49, Repoman-2.3.10

net-wireless/iwd/Manifest
net-wireless/iwd/iwd-0.8.ebuild [new file with mode: 0644]
net-wireless/iwd/iwd-9999.ebuild
net-wireless/iwd/metadata.xml

index 9120a530a9f4f364687abb4696c4512d28d42947..ed30453ac557c445ed5848753a71aec914caaa54 100644 (file)
@@ -1,3 +1,4 @@
 DIST iwd-0.4.tar.xz 649484 BLAKE2B 7af09a39a6c19b6ebb466d1fba857a6b7acd00d47feefe7e5053ddcdb0a64e74b7bd96a777e46ebd188af7ff5b3c1ed24ff383d11612dcffcef1aa5f210e78f7 SHA512 55c469b4e675f0c47c91bc46f0a93b704d9f2893393262aca8fd983aee16a7a13a112e9df15a31561fe72a806439a9a93fcbe1721648f3eed9ef277f9339b770
 DIST iwd-0.6.tar.xz 654960 BLAKE2B b0617b7e1a0f75de61ecd94baf34bd416b24bbbe6730e52963a705f4f5cdc002fd9dafd6eb60405414e8f05ff249c7ffb0c08c2c2d69f4aa2611d1f61ab5a2fa SHA512 2ab6fe64e7adeb5306aeb28cff850ca65c1a26b71a24042392135e7476c528c528d36d59df6e0d0d42e93b261bdb4eff7ec891c0089914588a7c64b2ed42889e
 DIST iwd-0.7.tar.xz 662984 BLAKE2B e6e7fa323749c8012c4df5f8f02f97523a37bcbb99d2a2f8c7678d4a1a73a3e24fc4321d53fb95f7fa325748f97b96e1a5f0fe0e956314eeb8534a8bc989a13f SHA512 e6029e33f43fda24f3ddb87b1bb878ad8926066380a0e71415e645bc4f8aa1a6aaa43d2482987b1d473c267fef6d5a2a676af80282ba4c77ab64605c348cabb1
+DIST iwd-0.8.tar.xz 670572 BLAKE2B aea20d9d68bb121912ed7a044853188317a1de344ceb09dca4fa1372ed35618b8e63656533329141d0e6f9c6a833238ee02ea807fa53fa19ecf90f8114d7fd69 SHA512 a7707f4c2730eeab0bf65d36c796d5f32b5ccfdb10a199dd2a7263d7297dfd336b8de434c90efb32b6151dfd41911511cd97d1c2ae42012653ee0b44ab709490
diff --git a/net-wireless/iwd/iwd-0.8.ebuild b/net-wireless/iwd/iwd-0.8.ebuild
new file mode 100644 (file)
index 0000000..59cf2d5
--- /dev/null
@@ -0,0 +1,106 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools linux-info systemd
+
+if [[ ${PV} == 9999 ]]; then
+       EGIT_REPO_URI="https://git.kernel.org/pub/scm/network/wireless/iwd.git"
+       inherit git-r3
+else
+       SRC_URI="https://www.kernel.org/pub/linux/network/wireless/${P}.tar.xz"
+       KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Wireless daemon for linux"
+HOMEPAGE="https://git.kernel.org/pub/scm/network/wireless/iwd.git/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+client +monitor ofono wired cpu_flags_x86_aes cpu_flags_x86_ssse3"
+
+RDEPEND="sys-apps/dbus
+       client? ( sys-libs/readline:0= )"
+
+DEPEND="${RDEPEND}
+       virtual/pkgconfig"
+
+pkg_pretend() {
+       CONFIG_CHECK="
+               ~ASYMMETRIC_KEY_TYPE
+               ~ASYMMETRIC_PUBLIC_KEY_SUBTYPE
+               ~CRYPTO_AES
+               ~CRYPTO_ARC4
+               ~CRYPTO_CBC
+               ~CRYPTO_CMAC
+               ~CRYPTO_DES
+               ~CRYPTO_ECB
+               ~CRYPTO_HMAC
+               ~CRYPTO_MD4
+               ~CRYPTO_MD5
+               ~CRYPTO_RSA
+               ~CRYPTO_SHA1
+               ~CRYPTO_SHA256
+               ~CRYPTO_SHA512
+               ~CRYPTO_USER_API_HASH
+               ~CRYPTO_USER_API_SKCIPHER
+               ~KEY_DH_OPERATIONS
+               ~PKCS7_MESSAGE_PARSER
+               ~X509_CERTIFICATE_PARSER
+       "
+       if use amd64;then
+               CONFIG_CHECK="${CONFIG_CHECK} ~CRYPTO_AES_X86_64 ~CRYPTO_DES3_EDE_X86_64"
+               WARNING_CRYPTO_AES_X86_64="CRYPTO_AES_X86_64: enable for increased performance"
+               WARNING_CRYPTO_DES3_EDE_X86_64="CRYPTO_DES3_EDE_X86_64: enable for increased performance"
+       fi
+
+       if use cpu_flags_x86_aes;then
+               CONFIG_CHECK="${CONFIG_CHECK} ~CRYPTO_AES_NI_INTEL"
+               WARNING_CRYPTO_AES_NI_INTEL="CRYPTO_AES_NI_INTEL: enable for increased performance"
+       fi
+
+       if use cpu_flags_x86_ssse3; then
+               CONFIG_CHECK="${CONFIG_CHECK} ~CRYPTO_SHA1_SSSE3 ~CRYPTO_SHA256_SSSE3 ~CRYPTO_SHA512_SSSE3"
+               WARNING_CRYPTO_SHA1_SSSE3="CRYPTO_SHA1_SSSE3: enable for increased performance"
+               WARNING_CRYPTO_SHA256_SSSE3="CRYPTO_SHA256_SSSE3: enable for increased performance"
+               WARNING_CRYPTO_SHA512_SSSE3="CRYPTO_SHA512_SSSE3: enable for increased performance"
+       fi
+
+       check_extra_config
+}
+
+src_unpack() {
+       if [[ ${PV} == "9999" ]] ; then
+               git-r3_src_unpack
+               git clone git://git.kernel.org/pub/scm/libs/ell/ell.git "${WORKDIR}"/ell
+       else
+               default
+       fi
+}
+
+src_prepare() {
+       default
+       eautoreconf
+}
+
+src_configure() {
+       econf --sysconfdir=/etc/iwd --localstatedir=/var \
+               $(use_enable client) \
+               $(use_enable monitor) \
+               $(use_enable ofono) \
+               $(use_enable wired) \
+               --enable-systemd-service \
+               --with-systemd-unitdir="$(systemd_get_systemunitdir)"
+}
+
+src_install() {
+       default
+       keepdir /var/lib/${PN}
+
+       newinitd "${FILESDIR}/iwd.initd" iwd
+
+       if [[ ${PV} == "9999" ]] ; then
+               exeinto /usr/share/iwd/scripts/
+               doexe test/*
+       fi
+}
index fa3d32f34fabd4b416537e25fd74abd7d5cb50ed..59cf2d5b03ad6bdff4396e132426eed67001ddb4 100644 (file)
@@ -17,7 +17,7 @@ HOMEPAGE="https://git.kernel.org/pub/scm/network/wireless/iwd.git/"
 
 LICENSE="GPL-2"
 SLOT="0"
-IUSE="+client +monitor cpu_flags_x86_aes cpu_flags_x86_ssse3"
+IUSE="+client +monitor ofono wired cpu_flags_x86_aes cpu_flags_x86_ssse3"
 
 RDEPEND="sys-apps/dbus
        client? ( sys-libs/readline:0= )"
@@ -87,6 +87,8 @@ src_configure() {
        econf --sysconfdir=/etc/iwd --localstatedir=/var \
                $(use_enable client) \
                $(use_enable monitor) \
+               $(use_enable ofono) \
+               $(use_enable wired) \
                --enable-systemd-service \
                --with-systemd-unitdir="$(systemd_get_systemunitdir)"
 }
index 96b6193f64c1f1eb8b1090e656a5d80706b2da1f..cd5c5ab59023ed0b3bafba11f30914f0ebb92d9d 100644 (file)
@@ -8,5 +8,7 @@
        <use>
                <flag name='client'>Enable iwctl client tool</flag>
                <flag name='monitor'>Enable iwmon monitor tool</flag>
+               <flag name='ofono'>Enable support for oFono SIM authentication</flag>
+               <flag name='wired'>Enable ethernet authentication daemon</flag>
        </use>
 </pkgmetadata>