dev-ruby/aws-sdk-core: bump
authorRobin H. Johnson <robbat2@gentoo.org>
Thu, 16 Apr 2020 22:28:10 +0000 (15:28 -0700)
committerRobin H. Johnson <robbat2@gentoo.org>
Thu, 16 Apr 2020 23:03:44 +0000 (16:03 -0700)
Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
dev-ruby/aws-sdk-core/Manifest
dev-ruby/aws-sdk-core/aws-sdk-core-2.11.488.ebuild [new file with mode: 0644]

index 03ba6e4047e05997bb7b9d786f9828347547e9ff..01433d9ba3adb2567f3d11cdfd506a8e3e9147ff 100644 (file)
@@ -1 +1,2 @@
+DIST aws-sdk-ruby-2.11.488.tar.gz 5997468 BLAKE2B bf374a451d07052676eedf75cac71f57f4557ff3d0970593cd76f057938844e0eca28e63aa983619345a5852542a8b1fe371c1be2c6132146daa9b5c123c7869 SHA512 c2726a9afc38d579fa65977c3c1cd2af5f6b235ac84cf5b4dd8fac6040a01c753d6409fe90e1cf32d500f26366c76a3b2499a0e79ebb005601756dab068fe91f
 DIST aws-sdk-ruby-2.11.79.tar.gz 4068576 BLAKE2B 481852772704dd91afca4511f402e0288aa80523133be2d15f0a3d085efca7c38fce1e7d794ebc9ffca5c4b2b5f69c9366346525f250ab9c2b06aa6c7e9631ee SHA512 dc9076f3658e6d764671a2f661c9c5363977807861bb9a71d287ebb55de02fc80679a209ea00d438d162f4185cf2f8c65800fde8712f143b17c5b60369f7203e
diff --git a/dev-ruby/aws-sdk-core/aws-sdk-core-2.11.488.ebuild b/dev-ruby/aws-sdk-core/aws-sdk-core-2.11.488.ebuild
new file mode 100644 (file)
index 0000000..9db5e58
--- /dev/null
@@ -0,0 +1,41 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby23 ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_DOCDIR="doc"
+
+RUBY_FAKEGEM_EXTRAINSTALL="apis ca-bundle.crt endpoints.json"
+
+GITHUB_USER="aws"
+GITHUB_PROJECT="aws-sdk-ruby"
+RUBY_S="${GITHUB_PROJECT}-${PV}/${PN}"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Official SDK for Amazon Web Services"
+HOMEPAGE="https://aws.amazon.com/sdkforruby"
+SRC_URI="https://github.com/${GITHUB_USER}/${GITHUB_PROJECT}/archive/v${PV}.tar.gz -> ${GITHUB_PROJECT}-${PV}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="2"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend "dev-ruby/aws-sigv4 dev-ruby/jmespath:1"
+
+ruby_add_bdepend "test? ( dev-ruby/webmock )"
+
+all_ruby_prepare() {
+       sed -i -e '/simplecov/I s:^:#:' spec/spec_helper.rb || die
+
+       # Avoid spec that gets confused by our directory names
+       sed -i -e '/requires prefixes from plugin names when loading/,/end/ s:^:#:' \
+               spec/seahorse/client/plugin_list_spec.rb || die
+}