mail-filter: drop old EAPI
authorAaron Bauman <bman@gentoo.org>
Tue, 12 Nov 2019 23:30:22 +0000 (18:30 -0500)
committerAaron Bauman <bman@gentoo.org>
Wed, 13 Nov 2019 01:02:18 +0000 (20:02 -0500)
Signed-off-by: Aaron Bauman <bman@gentoo.org>
mail-filter/bmf/bmf-0.9.4-r2.ebuild [deleted file]

diff --git a/mail-filter/bmf/bmf-0.9.4-r2.ebuild b/mail-filter/bmf/bmf-0.9.4-r2.ebuild
deleted file mode 100644 (file)
index 2f53d94..0000000
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=4
-inherit toolchain-funcs eutils
-
-IUSE="mysql berkdb"
-
-DESCRIPTION="A fast and small Bayesian spam filter"
-HOMEPAGE="http://bmf.sourceforge.net/"
-SRC_URI="mirror://sourceforge/bmf/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ppc x86"
-
-DEPEND="mysql? ( virtual/mysql )
-       berkdb? ( >=sys-libs/db-3.2.9 )"
-RDEPEND="${DEPEND}"
-
-src_prepare() {
-       # respect CFLAGS
-       sed -i -e '/D_LINUX/s/CFLAGS="$CCDBG/CFLAGS+=" $CCDBG/' \
-               "${S}/configure" || die
-
-       # include mysql headers
-       sed -i -e '/HAVE_MYSQL/s/HAVE_MYSQL/HAVE_MYSQL `mysql_config --include`/' \
-               "${S}/configure" || die
-
-       epatch "${FILESDIR}/${P}_QA.patch"
-}
-
-src_configure() {
-       # this is not an autotools script
-       ./configure \
-               $(use_with mysql) \
-               $(use_with berkdb libdb) || die
-}
-
-src_compile() {
-       emake CC="$(tc-getCC)"
-}
-
-src_install() {
-       emake DESTDIR="${D}" install
-       dodoc README AUTHORS ChangeLog
-}
-
-pkg_postinst() {
-       elog
-       elog "Important: Remember to train bmf before you start using it."
-       elog "See the README file for further instructions on training and using bmf"
-       elog "with procmail."
-       elog
-}