dev-libs/icu: Drop 63.1-r1
authorAndreas Sturmlechner <asturm@gentoo.org>
Thu, 27 Jun 2019 09:11:00 +0000 (11:11 +0200)
committerAndreas Sturmlechner <asturm@gentoo.org>
Thu, 27 Jun 2019 10:47:26 +0000 (12:47 +0200)
Package-Manager: Portage-2.3.67, Repoman-2.3.16
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
dev-libs/icu/Manifest
dev-libs/icu/files/icu-63.1-CVE-2018-18928.patch [deleted file]
dev-libs/icu/icu-63.1-r1.ebuild [deleted file]

index 5bd14af28bce0b5a2c9669dfd31fddb9606b0e78..efaf4e9e5150c24c8f4906fd8aefe9350317b647 100644 (file)
@@ -1,3 +1,2 @@
 DIST icu4c-58_2-src.tgz 23369902 BLAKE2B cdd2e02c3aba050f5b7f8b38c5a3731e3e5f1cc1403ef86a50908b95560ea3cf8a2d47119fa60cf34f22a8b65eaa2392fd5bcbd3bc48b3da541fe3d9bd7392c0 SHA512 5c21af748f48b392e6c0412bd0aee92162ea931820dcbfab4ec6e0299868504b303d88f7586cc95de55c777ac0dca3a29d6c8ca0892c646ebc864c8a5b5a162a
-DIST icu4c-63_1-src.tgz 23746939 BLAKE2B 5a665554506ff705c83c7a03a1b5598b1a48afbe1c6caaccd5a2d7d5aae16b3e18d7bc65ed552fc4df86248a2f13962438f19bca6c2a579843204c7dc52e6278 SHA512 9ab407ed840a00cdda7470dcc4c40299a125ad246ae4d019c4b1ede54781157fd63af015a8228cd95dbc47e4d15a0932b2c657489046a19788e5e8266eac079c
 DIST icu4c-64_2-src.tgz 24013250 BLAKE2B 4a286e7a952f5faa74d942f6b6a73147a46aa10fe6d54d024e2d18d1e01056444d56118ded04b4fe084d6a0f9058d7d9e76973960ac8fe5bd9ee105d9e214318 SHA512 5ecb4c230ba45918747a1cf9aef86f555aa07d5b29b1d07ab674e8013f46dfb907a0e9d6945db41155f9dc3012fd94e1152ffc19f61a68b6dfcbabdcb8ae9d78
diff --git a/dev-libs/icu/files/icu-63.1-CVE-2018-18928.patch b/dev-libs/icu/files/icu-63.1-CVE-2018-18928.patch
deleted file mode 100644 (file)
index bbbef9e..0000000
+++ /dev/null
@@ -1,62 +0,0 @@
-From 53d8c8f3d181d87a6aa925b449b51c4a2c922a51 Mon Sep 17 00:00:00 2001
-From: Shane Carr <shane@unicode.org>
-Date: Mon, 29 Oct 2018 23:52:44 -0700
-Subject: [PATCH] ICU-20246 Fixing another integer overflow in number parsing.
-
----
- i18n/fmtable.cpp                          |  2 +-
- i18n/number_decimalquantity.cpp           |  5 ++++-
- test/intltest/numfmtst.cpp                |  8 ++++++++
- .../icu/impl/number/DecimalQuantity_AbstractBCD.java   |  5 ++++-
- .../impl/number/DecimalQuantity_DualStorageBCD.java    | 10 +++++++++-
- .../com/ibm/icu/dev/test/format/NumberFormatTest.java  |  5 +++++
- 6 files changed, 31 insertions(+), 4 deletions(-)
-
-diff --git a/i18n/fmtable.cpp b/i18n/fmtable.cpp
-index 45c7024fc29..8601d95f4a6 100644
---- a/i18n/fmtable.cpp
-+++ b/i18n/fmtable.cpp
-@@ -734,7 +734,7 @@ CharString *Formattable::internalGetCharString(UErrorCode &status) {
-       // not print scientific notation for magnitudes greater than -5 and smaller than some amount (+5?).
-       if (fDecimalQuantity->isZero()) {
-         fDecimalStr->append("0", -1, status);
--      } else if (std::abs(fDecimalQuantity->getMagnitude()) < 5) {
-+      } else if (fDecimalQuantity->getMagnitude() != INT32_MIN && std::abs(fDecimalQuantity->getMagnitude()) < 5) {
-         fDecimalStr->appendInvariantChars(fDecimalQuantity->toPlainString(), status);
-       } else {
-         fDecimalStr->appendInvariantChars(fDecimalQuantity->toScientificString(), status);
-diff --git a/i18n/number_decimalquantity.cpp b/i18n/number_decimalquantity.cpp
-index 47b930a564b..d5dd7ae694c 100644
---- a/i18n/number_decimalquantity.cpp
-+++ b/i18n/number_decimalquantity.cpp
-@@ -898,7 +898,10 @@ UnicodeString DecimalQuantity::toScientificString() const {
-     }
-     result.append(u'E');
-     int32_t _scale = upperPos + scale;
--    if (_scale < 0) {
-+    if (_scale == INT32_MIN) {
-+        result.append({u"-2147483648", -1});
-+        return result;
-+    } else if (_scale < 0) {
-         _scale *= -1;
-         result.append(u'-');
-     } else {
-diff --git a/test/intltest/numfmtst.cpp b/test/intltest/numfmtst.cpp
-index 34355939113..8d52dc122bf 100644
---- a/test/intltest/numfmtst.cpp
-+++ b/test/intltest/numfmtst.cpp
-@@ -9226,6 +9226,14 @@ void NumberFormatTest::Test20037_ScientificIntegerOverflow() {
-     assertEquals(u"Should not overflow and should parse only the first exponent",
-                  u"1E-2147483647",
-                  {sp.data(), sp.length(), US_INV});
-+
-+    // Test edge case overflow of exponent
-+    result = Formattable();
-+    nf->parse(u".0003e-2147483644", result, status);
-+    sp = result.getDecimalNumber(status);
-+    assertEquals(u"Should not overflow",
-+                 u"3E-2147483648",
-+                 {sp.data(), sp.length(), US_INV});
- }
- void NumberFormatTest::Test13840_ParseLongStringCrash() {
diff --git a/dev-libs/icu/icu-63.1-r1.ebuild b/dev-libs/icu/icu-63.1-r1.ebuild
deleted file mode 100644 (file)
index 2023747..0000000
+++ /dev/null
@@ -1,143 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit flag-o-matic toolchain-funcs autotools multilib-minimal
-
-DESCRIPTION="International Components for Unicode"
-HOMEPAGE="http://www.icu-project.org/"
-SRC_URI="http://download.icu-project.org/files/icu4c/${PV/_/}/icu4c-${PV//./_}-src.tgz"
-
-LICENSE="BSD"
-
-SLOT="0/${PV}"
-
-KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 s390 ~sh sparc x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
-IUSE="debug doc examples static-libs"
-
-DEPEND="
-       doc? ( app-doc/doxygen[dot] )
-"
-BDEPEND="
-       virtual/pkgconfig
-"
-
-S="${WORKDIR}/${PN}/source"
-
-MULTILIB_CHOST_TOOLS=(
-       /usr/bin/icu-config
-)
-
-PATCHES=(
-       "${FILESDIR}/${PN}-58.1-remove-bashisms.patch"
-       "${FILESDIR}/${PN}-58.2-darwin.patch"
-       "${FILESDIR}/${P}-CVE-2018-18928.patch"
-)
-
-src_prepare() {
-       default
-
-       local variable
-
-       # Disable renaming as it is stupid thing to do
-       sed -i \
-               -e "s/#define U_DISABLE_RENAMING 0/#define U_DISABLE_RENAMING 1/" \
-               common/unicode/uconfig.h || die
-
-       # Fix linking of icudata
-       sed -i \
-               -e "s:LDFLAGSICUDT=-nodefaultlibs -nostdlib:LDFLAGSICUDT=:" \
-               config/mh-linux || die
-
-       # Append doxygen configuration to configure
-       sed -i \
-               -e 's:icudefs.mk:icudefs.mk Doxyfile:' \
-               configure.ac || die
-
-       eautoreconf
-}
-
-src_configure() {
-       append-cxxflags -std=c++14
-
-       if tc-is-cross-compiler; then
-               mkdir "${WORKDIR}"/host || die
-               pushd "${WORKDIR}"/host >/dev/null || die
-
-               CFLAGS="" CXXFLAGS="" ASFLAGS="" LDFLAGS="" \
-               CC="$(tc-getBUILD_CC)" CXX="$(tc-getBUILD_CXX)" AR="$(tc-getBUILD_AR)" \
-               RANLIB="$(tc-getBUILD_RANLIB)" LD="$(tc-getBUILD_LD)" \
-               "${S}"/configure --disable-renaming --disable-debug \
-                       --disable-samples --enable-static || die
-               emake
-
-               popd >/dev/null || die
-       fi
-
-       multilib-minimal_src_configure
-}
-
-multilib_src_configure() {
-       local myeconfargs=(
-               --disable-renaming
-               --disable-samples
-               --disable-layoutex
-               $(use_enable debug)
-               $(use_enable static-libs static)
-               $(multilib_native_use_enable examples samples)
-       )
-
-       tc-is-cross-compiler && myeconfargs+=(
-               --with-cross-build="${WORKDIR}"/host
-       )
-
-       # icu tries to use clang by default
-       tc-export CC CXX
-
-       # make sure we configure with the same shell as we run icu-config
-       # with, or ECHO_N, ECHO_T and ECHO_C will be wrongly defined
-       export CONFIG_SHELL="${EPREFIX}/bin/sh"
-       # probably have no /bin/sh in prefix-chain
-       [[ -x ${CONFIG_SHELL} ]] || CONFIG_SHELL="${BASH}"
-
-       ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
-}
-
-multilib_src_compile() {
-       default
-
-       if multilib_is_native_abi && use doc; then
-               doxygen -u Doxyfile || die
-               doxygen Doxyfile || die
-       fi
-}
-
-multilib_src_test() {
-       # INTLTEST_OPTS: intltest options
-       #   -e: Exhaustive testing
-       #   -l: Reporting of memory leaks
-       #   -v: Increased verbosity
-       # IOTEST_OPTS: iotest options
-       #   -e: Exhaustive testing
-       #   -v: Increased verbosity
-       # CINTLTST_OPTS: cintltst options
-       #   -e: Exhaustive testing
-       #   -v: Increased verbosity
-       emake -j1 VERBOSE="1" check
-}
-
-multilib_src_install() {
-       default
-
-       if multilib_is_native_abi && use doc; then
-               docinto html
-               dodoc -r doc/html/*
-       fi
-}
-
-multilib_src_install_all() {
-       einstalldocs
-       docinto html
-       dodoc ../readme.html
-}