dev-python/keyring: Bump to 21.2.1
authorMichał Górny <mgorny@gentoo.org>
Wed, 27 May 2020 06:50:39 +0000 (08:50 +0200)
committerMichał Górny <mgorny@gentoo.org>
Wed, 27 May 2020 07:03:16 +0000 (09:03 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/keyring/Manifest
dev-python/keyring/keyring-21.2.1.ebuild [new file with mode: 0644]

index ddf875dc99e0df66b67ed801d92495049aeed463..3ff4aab4a973c5c6b59cae8649b56757272b1994 100644 (file)
@@ -1 +1,2 @@
 DIST keyring-19.3.0.tar.gz 43587 BLAKE2B a1003aa55ac48f39e84431c50fe3e24e1da76a0db177eed08bd2c2110b78d10cbfcf7188519435732be68452a0318119cca1563168410b16fc529a3a7e98125c SHA512 b1d26f665203b11712ef91057ecd78cce58b35038b259605c42997283f6c41449baf242ecf43510b29598559b8aecf733eb66be6e0c439564256f40eb0f6982c
+DIST keyring-21.2.1.tar.gz 45535 BLAKE2B b276f5b973c418794561e0d0872761847d4cb81531dde61b75439c73039f49ffc8abf679d622a9381bc6663ffc452c8b6aabc0a4c8e4cfe5ad1c63566b78082d SHA512 35869e37b234d15799907f0efd0193ab3eb9c0799a6da2d843fdad24212b4ab983658b32bd8b09b658174dcb1ddb6d70a85d0af95730d34d8c571f2ecc9a7c8b
diff --git a/dev-python/keyring/keyring-21.2.1.ebuild b/dev-python/keyring/keyring-21.2.1.ebuild
new file mode 100644 (file)
index 0000000..1e3cfa4
--- /dev/null
@@ -0,0 +1,54 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( pypy3 python3_{6,7,8,9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Provides access to the system keyring service"
+HOMEPAGE="https://github.com/jaraco/keyring"
+SRC_URI="https://github.com/jaraco/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="PSF-2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~x86"
+IUSE="doc"
+
+RDEPEND="
+       dev-python/secretstorage[${PYTHON_USEDEP}]
+       dev-python/entrypoints[${PYTHON_USEDEP}]
+       dev-python/jeepney[${PYTHON_USEDEP}]
+       $(python_gen_cond_dep '
+               dev-python/importlib_metadata[${PYTHON_USEDEP}]
+       ' pypy3 python3_{5,6,7})
+"
+BDEPEND="
+       dev-python/setuptools_scm[${PYTHON_USEDEP}]
+"
+
+PATCHES=(
+#      "${FILESDIR}/keyring-19.1.0-tests.patch"
+       # https://github.com/jaraco/keyring/commit/411204df606bdf02c99f3360ec033e3c235d5f67
+#      "${FILESDIR}/keyring-19.3.0-tests.patch"
+)
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+       dev-python/jaraco-packaging \
+       dev-python/rst-linker
+
+python_prepare_all() {
+       sed -i -e 's:--flake8 --black --cov::' pytest.ini || die
+       # relies on cpython's gc behavior
+       sed -i -e 's:test_traceback_not_referenced:_&:' \
+               tests/test_errors.py || die
+
+       rm tests/backends/test_kwallet.py || die
+
+       distutils-r1_python_prepare_all
+
+       export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+}