sys-libs/glibc: disable stripping for cross-glibc
authorSergei Trofimovich <slyfox@gentoo.org>
Mon, 14 Oct 2019 06:57:44 +0000 (07:57 +0100)
committerSergei Trofimovich <slyfox@gentoo.org>
Mon, 14 Oct 2019 06:58:05 +0000 (07:58 +0100)
commit e14229b10b513a164f8379ff14cc8c644c071f27 dropped
special stripping and relied on standard ${CHOST}-strip.

Unfortunately one special case wa missing:
cross-*/glibc ebuilds use ${CTARGET} as a target and are
installed into the host. That causes ${CHOST}-strip to be
called on ${CTARGET} binaries. If multitarget is not enabled
strip either breaks such bianries or makes them untouched.

Disable tripping until we migrated off off cross-*/glibc ebuilds.

Reported-by: Johannes Geiss
Closes: https://bugs.gentoo.org/697428
Package-Manager: Portage-2.3.76, Repoman-2.3.17
Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
12 files changed:
sys-libs/glibc/glibc-2.19-r2.ebuild
sys-libs/glibc/glibc-2.24-r4.ebuild
sys-libs/glibc/glibc-2.25-r11.ebuild
sys-libs/glibc/glibc-2.26-r7.ebuild
sys-libs/glibc/glibc-2.27-r6.ebuild
sys-libs/glibc/glibc-2.28-r6.ebuild
sys-libs/glibc/glibc-2.29-r2.ebuild
sys-libs/glibc/glibc-2.29-r4.ebuild
sys-libs/glibc/glibc-2.29-r5.ebuild
sys-libs/glibc/glibc-2.30-r1.ebuild
sys-libs/glibc/glibc-2.30.ebuild
sys-libs/glibc/glibc-9999.ebuild

index 0fedbb8e9409f671e20c5c9300421f84727bda55..20b236f90376c66f0ad9e9a881cefdf827c0ca89 100644 (file)
@@ -56,6 +56,9 @@ export CTARGET=${CTARGET:-${CHOST}}
 if [[ ${CTARGET} == ${CHOST} ]] ; then
        if [[ ${CATEGORY} == cross-* ]] ; then
                export CTARGET=${CATEGORY#cross-}
+               # portage's attempt to strip breaks non-native bianries
+               # at least on arm: bug #697428
+               RESTRICT=strip
        fi
 fi
 
index b808611bd319f1c3faeca0a47a8a1d9da3e3c614..4c86249885535ddad372702bbe4be473cfd70b54 100644 (file)
@@ -49,6 +49,9 @@ export CTARGET=${CTARGET:-${CHOST}}
 if [[ ${CTARGET} == ${CHOST} ]] ; then
        if [[ ${CATEGORY} == cross-* ]] ; then
                export CTARGET=${CATEGORY#cross-}
+               # portage's attempt to strip breaks non-native bianries
+               # at least on arm: bug #697428
+               RESTRICT=strip
        fi
 fi
 
index e2a0f9131bbc9d4b7fa268c2e832584b48fd8dab..4b3ac83a890b356c615e9b43fbec61288b2e16f9 100644 (file)
@@ -51,6 +51,9 @@ export CTARGET=${CTARGET:-${CHOST}}
 if [[ ${CTARGET} == ${CHOST} ]] ; then
        if [[ ${CATEGORY} == cross-* ]] ; then
                export CTARGET=${CATEGORY#cross-}
+               # portage's attempt to strip breaks non-native bianries
+               # at least on arm: bug #697428
+               RESTRICT=strip
        fi
 fi
 
index 34d8fb8a7ac910da8ecd25ae7efa4cf0253b45d2..80530db6e4533070b0ddc2d6c156b00f4ad46ac8 100644 (file)
@@ -55,6 +55,9 @@ export CTARGET=${CTARGET:-${CHOST}}
 if [[ ${CTARGET} == ${CHOST} ]] ; then
        if [[ ${CATEGORY} == cross-* ]] ; then
                export CTARGET=${CATEGORY#cross-}
+               # portage's attempt to strip breaks non-native bianries
+               # at least on arm: bug #697428
+               RESTRICT=strip
        fi
 fi
 
index f1409e36cf34c9f019301c7606107c2a1e7305b0..2b333181bf71d6b7473a0e5b520a5ef882fb76b0 100644 (file)
@@ -55,6 +55,9 @@ export CTARGET=${CTARGET:-${CHOST}}
 if [[ ${CTARGET} == ${CHOST} ]] ; then
        if [[ ${CATEGORY} == cross-* ]] ; then
                export CTARGET=${CATEGORY#cross-}
+               # portage's attempt to strip breaks non-native bianries
+               # at least on arm: bug #697428
+               RESTRICT=strip
        fi
 fi
 
index aa318b7e0f1b496c76369cb4fe15dd69b7f9eb40..2a512a62aeceff688a8035ff10b269abc00f40d0 100644 (file)
@@ -55,6 +55,9 @@ export CTARGET=${CTARGET:-${CHOST}}
 if [[ ${CTARGET} == ${CHOST} ]] ; then
        if [[ ${CATEGORY} == cross-* ]] ; then
                export CTARGET=${CATEGORY#cross-}
+               # portage's attempt to strip breaks non-native bianries
+               # at least on arm: bug #697428
+               RESTRICT=strip
        fi
 fi
 
index b80ddd00814478355b9407f444f28d7f4bf181bc..bd08c9a208a8d7a88f5bf6bd465aa8dc5964281f 100644 (file)
@@ -57,6 +57,9 @@ export CTARGET=${CTARGET:-${CHOST}}
 if [[ ${CTARGET} == ${CHOST} ]] ; then
        if [[ ${CATEGORY} == cross-* ]] ; then
                export CTARGET=${CATEGORY#cross-}
+               # portage's attempt to strip breaks non-native bianries
+               # at least on arm: bug #697428
+               RESTRICT=strip
        fi
 fi
 
index 7282d89d8eee7bf7b7975723c5fa9b32b5f615af..0f388a106c6e74100c0024a08b621a7d3032706d 100644 (file)
@@ -57,6 +57,9 @@ export CTARGET=${CTARGET:-${CHOST}}
 if [[ ${CTARGET} == ${CHOST} ]] ; then
        if [[ ${CATEGORY} == cross-* ]] ; then
                export CTARGET=${CATEGORY#cross-}
+               # portage's attempt to strip breaks non-native bianries
+               # at least on arm: bug #697428
+               RESTRICT=strip
        fi
 fi
 
index 1c3f4a15dde737d79698ce65586824bfaef48277..6ac0497d07cd1167db2a3130a51fa2d429428d41 100644 (file)
@@ -57,6 +57,9 @@ export CTARGET=${CTARGET:-${CHOST}}
 if [[ ${CTARGET} == ${CHOST} ]] ; then
        if [[ ${CATEGORY} == cross-* ]] ; then
                export CTARGET=${CATEGORY#cross-}
+               # portage's attempt to strip breaks non-native bianries
+               # at least on arm: bug #697428
+               RESTRICT=strip
        fi
 fi
 
index b3da5c0345ed93c12bc549815f4931ec37896615..51bf1cbd9f3299081192759739853e8aa9e82e34 100644 (file)
@@ -58,6 +58,9 @@ export CTARGET=${CTARGET:-${CHOST}}
 if [[ ${CTARGET} == ${CHOST} ]] ; then
        if [[ ${CATEGORY} == cross-* ]] ; then
                export CTARGET=${CATEGORY#cross-}
+               # portage's attempt to strip breaks non-native bianries
+               # at least on arm: bug #697428
+               RESTRICT=strip
        fi
 fi
 
index 5a8933d5d964c23b8a6f993640b6cb21498234b3..544eec7b687495f30c4ba6a7ffec76196d6f6c92 100644 (file)
@@ -58,6 +58,9 @@ export CTARGET=${CTARGET:-${CHOST}}
 if [[ ${CTARGET} == ${CHOST} ]] ; then
        if [[ ${CATEGORY} == cross-* ]] ; then
                export CTARGET=${CATEGORY#cross-}
+               # portage's attempt to strip breaks non-native bianries
+               # at least on arm: bug #697428
+               RESTRICT=strip
        fi
 fi
 
index d529e346178ef245104d88f9f4f8aa4edd2cff57..6894e04b79656785af34f39562a7675a7f110a34 100644 (file)
@@ -58,6 +58,9 @@ export CTARGET=${CTARGET:-${CHOST}}
 if [[ ${CTARGET} == ${CHOST} ]] ; then
        if [[ ${CATEGORY} == cross-* ]] ; then
                export CTARGET=${CATEGORY#cross-}
+               # portage's attempt to strip breaks non-native bianries
+               # at least on arm: bug #697428
+               RESTRICT=strip
        fi
 fi