dev-python/jupyter_core: Version bump 4.6.1
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>
Mon, 16 Dec 2019 08:39:11 +0000 (09:39 +0100)
committerBenda Xu <heroxbd@gentoo.org>
Mon, 23 Dec 2019 11:53:23 +0000 (19:53 +0800)
  Employ `distutils_enable_tests pytest`.

Bug: https://bugs.gentoo.org/702458
Bug: https://github.com/gentoo/gentoo/pull/13988
Closes: https://github.com/gentoo/gentoo/pull/14003
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net>
Signed-off-by: Benda Xu <heroxbd@gentoo.org>
Package-Manager: Portage-2.3.81, Repoman-2.3.20

dev-python/jupyter_core/Manifest
dev-python/jupyter_core/jupyter_core-4.6.1.ebuild [new file with mode: 0644]

index 56de66d86bb80fd3540bc37f3448ddf06de2c8d8..18b384b704664b851003d4c9df7c57cf9fe42cba 100644 (file)
@@ -1 +1,2 @@
 DIST jupyter_core-4.4.0.tar.gz 63613 BLAKE2B 90b5d6c855786beff0ab780e7a894e1b24f6d6d1c26be6ae8da73e82a87f966f1155498c581314d37db845e293be7bc4d085e03991cdc7adfbba36409541cd5b SHA512 387f7f98f640b85ff0a24f11e1beae5a851d7eb3ba4a423be028940cb018c0d0ddf42ae8a1c397e3e4cafa560d3a5385b39bb8794448c7c010be7f0ddcba8a9e
+DIST jupyter_core-4.6.1.tar.gz 66693 BLAKE2B f4338a015ac4b3e0a7cd2497a660bfca0deb96ffa2371fa9c72656f8a68b6f80fe5d494be79c8fdccbcb51f3d9122fd7d4b3e36864d38e7da1c5029c6b1aa24d SHA512 baf0c5db4f78a3cee83940ace80b48ba308c47eeafcf584120b8ba82768c15448fb789ec5b9ac8d541cbd1bfdd47a988f79130675c5943a67d3135d428b43cbe
diff --git a/dev-python/jupyter_core/jupyter_core-4.6.1.ebuild b/dev-python/jupyter_core/jupyter_core-4.6.1.ebuild
new file mode 100644 (file)
index 0000000..ce54335
--- /dev/null
@@ -0,0 +1,48 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Core common functionality of Jupyter projects"
+HOMEPAGE="https://jupyter.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="doc test"
+
+RDEPEND="dev-python/traitlets[${PYTHON_USEDEP}]"
+
+DEPEND="${RDEPEND}
+       doc? ( dev-python/sphinx[${PYTHON_USEDEP}]
+               dev-python/sphinxcontrib-github-alt[${PYTHON_USEDEP}] )
+       test? ( >=dev-python/ipython-4.0.1[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+       # Prevent un-needed download during build
+       if use doc; then
+               sed -e "/^    'sphinx.ext.intersphinx',/d" -i docs/conf.py || die
+       fi
+
+       distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+       if use doc; then
+               emake -C docs html
+               HTML_DOCS=( docs/_build/html/. )
+       fi
+}
+
+python_test() {
+       distutils_install_for_testing
+       cd "${TEST_DIR}"/lib || die
+       py.test jupyter_core || die
+}