dev-libs/libintl: Bump to version 0.20.1
authorLars Wendler <polynomial-c@gentoo.org>
Tue, 14 May 2019 11:14:55 +0000 (13:14 +0200)
committerLars Wendler <polynomial-c@gentoo.org>
Tue, 14 May 2019 11:24:54 +0000 (13:24 +0200)
Package-Manager: Portage-2.3.66, Repoman-2.3.12
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
dev-libs/libintl/Manifest
dev-libs/libintl/libintl-0.20.1.ebuild [new file with mode: 0644]

index 015ea61aeed53985495b5d1c2b47d2b5555cc6cb..6c9982618981df9888879b37f7e187562b3055a8 100644 (file)
@@ -1,3 +1,4 @@
 DIST gettext-0.19.6.tar.gz 18619659 BLAKE2B fb5e518cef2048c89d2c637d3551d6d7debff2fcdeb35b60f0ae9943733bf5cd8ec46f0a4cccd9f1806a6af4b16eef372a0621af611d3706356af6ae82d0d5bf SHA512 46adfd4a6d0038aba999658bebe51117e3ab3dc149a9054c1087d3e79ec7ba3371a7e78a8ca30a8872d162c2dc44aba6e67e4d64808c4f92e1e2bd674174f1db
 DIST gettext-0.19.7.tar.gz 19235781 BLAKE2B 4c2cfcb0b21a66a9f8d2d57de7420e624a1235f97180ad5ac194a5eb629760a9cacc7f3966cdf893d7af86c1740d8bb2266c639ebe2664ea44f2c47a962a841a SHA512 7ba89074d3eddd0b4a5e2980e1ec74b53c49b7a04a1fa91c70c4bc11ce9c30415e4df9d79698148eaaed325fb4feb25a340a2e8e01fbe86b1a66b1376a4c9e3d
 DIST gettext-0.19.8.1.tar.gz 19704011 BLAKE2B 17dc7aad338a26d71b818fea51e46a47dccf14744ee575ce86b591becaea402e36d64dc018e1a84113c356122ffef367cf2fa424e51ebc9720350040b4960091 SHA512 073042fa2dc48804c58e76f036130a669e19612c25427b0ab14d0b366b549a63751bf3af03bfd0745d7c4f72497a4b2aab26a3cc6de83189ce111679073878e1
+DIST gettext-0.20.1.tar.gz 23267473 BLAKE2B 34e776b985c7db105f8029e0f3400aa645ff6843cd35f778d48450368a31218ddcf590fbc7fd2d10f716b63094d6a15bf40b358e8a6f498d450d2420e7e7a5f2 SHA512 af6d74986da285df0bdd59524bdf01bb12db448e5ea659dda3b60b660c4a9063c80e8c74cc8751334e065e98348ee0db0079e43c67d485a15e86ae236115fe06
diff --git a/dev-libs/libintl/libintl-0.20.1.ebuild b/dev-libs/libintl/libintl-0.20.1.ebuild
new file mode 100644 (file)
index 0000000..da2640b
--- /dev/null
@@ -0,0 +1,80 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# Note: Keep version bumps in sync with sys-devel/gettext.
+
+EAPI=7
+
+MY_P="gettext-${PV}"
+
+inherit multilib-minimal toolchain-funcs libtool
+
+DESCRIPTION="the GNU international library (split out of gettext)"
+HOMEPAGE="https://www.gnu.org/software/gettext/"
+SRC_URI="mirror://gnu/gettext/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
+IUSE="static-libs +threads"
+
+DEPEND=">=virtual/libiconv-0-r1[${MULTILIB_USEDEP}]"
+# Block C libraries known to provide libintl.
+RDEPEND="${DEPEND}
+       !sys-libs/glibc
+       !sys-libs/musl
+       !<sys-devel/gettext-0.19.6-r1"
+
+S="${WORKDIR}/${MY_P}/gettext-runtime"
+
+src_prepare() {
+       default
+
+       # The libtool files are stored higher up, so make sure we run in the
+       # whole tree and not just the subdir we build.
+       elibtoolize "${WORKDIR}"
+}
+
+multilib_src_configure() {
+       local myconf=(
+               # Emacs support is now in a separate package.
+               --without-emacs
+               --without-lispdir
+               # Normally this controls nls behavior in general, but the libintl
+               # subdir is skipped unless this is explicitly set.  ugh.
+               --enable-nls
+               # This magic flag enables libintl.
+               --with-included-gettext
+               # The gettext package provides this library.
+               --disable-c++
+               --disable-libasprintf
+               # No java until someone cares.
+               --disable-java
+
+               $(use_enable static-libs static)
+               $(use_enable threads)
+       )
+       ECONF_SOURCE="${S}" econf "${myconf[@]}"
+}
+
+multilib_src_compile() {
+       # We only need things in the intl/ subdir.
+       emake -C intl
+}
+
+multilib_src_install() {
+       # We only need things in the intl/ subdir.
+       emake DESTDIR="${D}" install -C intl
+
+       gen_usr_ldscript -a intl
+}
+
+multilib_src_install_all() {
+       if ! use static-libs ; then
+               find "${ED}" -type f -name "*.la" -delete || die
+       fi
+
+       rm -r "${ED}"/usr/share/locale || die
+
+       dodoc AUTHORS ChangeLog NEWS README
+}