games-roguelike/FTL-gog: fix shell script perms.
authorRob Levitsky <kitsunenokenja@protonmail.ch>
Sun, 24 Jun 2018 15:36:34 +0000 (11:36 -0400)
committerPatrice Clement <monsieurp@gentoo.org>
Mon, 9 Jul 2018 22:01:52 +0000 (00:01 +0200)
Fixed the permissions on one of the shell scripts called by the start
script and stripped useless chmod calls from that start script.

Package-Manager: Portage-2.3.40, Repoman-2.3.9
Closes: https://github.com/gentoo/gentoo/pull/9089

games-roguelike/FTL-gog/FTL-gog-1.6.7.18662-r1.ebuild [moved from games-roguelike/FTL-gog/FTL-gog-1.6.7.18662.ebuild with 93% similarity]

similarity index 93%
rename from games-roguelike/FTL-gog/FTL-gog-1.6.7.18662.ebuild
rename to games-roguelike/FTL-gog/FTL-gog-1.6.7.18662-r1.ebuild
index 513747171d91d5ababf9732767bfebe40fdc1059..c606b4d683d1d7f5cd641cc4a56978455c7765b1 100644 (file)
@@ -42,12 +42,14 @@ src_prepare() {
        if ! use amd64; then
                rm game/data/FTL.amd64 || die
        fi
+
+       sed -i start.sh -e '/chmod/d'
 }
 
 src_install() {
        insinto /opt/gog/FTL
        doins -r .
-       fperms +x /opt/gog/FTL/{start.sh,game/FTL}
+       fperms +x /opt/gog/FTL/{start.sh,game/FTL,game/data/FTL}
 
        if use x86; then
                fperms +x /opt/gog/FTL/game/data/FTL.x86