sys-devel/clang: Do not install clang-tidy-headers after all
authorMichał Górny <mgorny@gentoo.org>
Wed, 6 May 2020 06:20:14 +0000 (08:20 +0200)
committerMichał Górny <mgorny@gentoo.org>
Wed, 6 May 2020 06:20:14 +0000 (08:20 +0200)
Stop installing clang-tidy-headers since no libraries are installed
corresponding to these headers.

Closes: https://bugs.gentoo.org/720774
Signed-off-by: Michał Górny <mgorny@gentoo.org>
sys-devel/clang/clang-11.0.0.9999.ebuild

index 2f9362c815a1e1a7c9262ce9e316923dce198c8e..ff2421448499fb70e89dbaed0e6bd0450768faae 100644 (file)
@@ -107,6 +107,10 @@ check_distribution_components() {
                                        clang*|findAllSymbols)
                                                continue
                                                ;;
+                                       # headers for clang-tidy static library
+                                       clang-tidy-headers)
+                                               continue
+                                               ;;
                                esac
 
                                all_targets+=( "${l}" )
@@ -181,7 +185,6 @@ get_distribution_components() {
                        clang-query
                        clang-reorder-fields
                        clang-tidy
-                       clang-tidy-headers
                        clangd
                        find-all-symbols
                        modularize