dev-python/ushlex: new package.
authorPatrice Clement <monsieurp@gentoo.org>
Mon, 10 Sep 2018 21:20:16 +0000 (23:20 +0200)
committerPatrice Clement <monsieurp@gentoo.org>
Mon, 10 Sep 2018 21:54:09 +0000 (23:54 +0200)
ushlex is a replacement for shlex (that works with unicode) for Python 2.X.

Package-Manager: Portage-2.3.40, Repoman-2.3.9

dev-python/ushlex/Manifest [new file with mode: 0644]
dev-python/ushlex/metadata.xml [new file with mode: 0644]
dev-python/ushlex/ushlex-0.99.1.ebuild [new file with mode: 0644]

diff --git a/dev-python/ushlex/Manifest b/dev-python/ushlex/Manifest
new file mode 100644 (file)
index 0000000..810b90e
--- /dev/null
@@ -0,0 +1 @@
+DIST ushlex-0.99.1.tar.gz 4712 BLAKE2B e38a61465cc93f8e7a50a314e3832baf67ab5141213ffa94255f0092fe533da96723c313a2458cf9075a263582d1fc0fce9361c074d71d2387351639205d5645 SHA512 6ae138a9159886e47d7464bad170cb5abae15c67341280a60613fa0c81407ac8b84b4078bca8b3b60e9731cc6b168a3364c9122c9f0cd39c8354caefd32303d1
diff --git a/dev-python/ushlex/metadata.xml b/dev-python/ushlex/metadata.xml
new file mode 100644 (file)
index 0000000..b1cc92c
--- /dev/null
@@ -0,0 +1,11 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="project">
+               <email>python@gentoo.org</email>
+               <name>Python</name>
+       </maintainer>
+       <upstream>
+               <remote-id type="pypi">ushlex</remote-id>
+       </upstream>
+</pkgmetadata>
diff --git a/dev-python/ushlex/ushlex-0.99.1.ebuild b/dev-python/ushlex/ushlex-0.99.1.ebuild
new file mode 100644 (file)
index 0000000..0e0ffb3
--- /dev/null
@@ -0,0 +1,18 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Replacement for shlex for Python 2.X"
+HOMEPAGE="https://pypi.org/project/ushlex"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"