dev-python/breathe: initial import
authorSébastien Fabbro <bicatali@gentoo.org>
Sun, 26 Feb 2017 16:43:38 +0000 (16:43 +0000)
committerSébastien Fabbro <bicatali@gentoo.org>
Sun, 26 Feb 2017 18:02:05 +0000 (18:02 +0000)
Package-Manager: Portage-2.3.3, Repoman-2.3.1

dev-python/breathe/Manifest [new file with mode: 0644]
dev-python/breathe/breathe-4.6.0.ebuild [new file with mode: 0644]
dev-python/breathe/metadata.xml [new file with mode: 0644]

diff --git a/dev-python/breathe/Manifest b/dev-python/breathe/Manifest
new file mode 100644 (file)
index 0000000..4ee2d52
--- /dev/null
@@ -0,0 +1 @@
+DIST breathe-4.6.0.tar.gz 67655 SHA256 9db2ba770f824da323b9ea3db0b98d613a4e0af094c82ccb0a82991da81b736a SHA512 8e26a102c38a916818ecf1a5d6a0f6f01de4285a98dce7abda6f2a401f8e5db380150b24bd2bf6f430a53324be5f1da28d084d8d4ae3969ec03914b88bc3908f WHIRLPOOL 7db736ed8f9219595c9a75977c6f019c335c26f91684a787cb296ecbeb2e6d5f02ab64966df1085758a5301ea05a034e25bf4003db6146c3beac3781a92e70e2
diff --git a/dev-python/breathe/breathe-4.6.0.ebuild b/dev-python/breathe/breathe-4.6.0.ebuild
new file mode 100644 (file)
index 0000000..06f8813
--- /dev/null
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Sphinx Doxygen renderer"
+HOMEPAGE="http://breathe.readthedocs.io/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+       app-doc/doxygen[latex]
+       dev-python/docutils[${PYTHON_USEDEP}]
+       dev-python/sphinx[${PYTHON_USEDEP}]
+       dev-python/six[${PYTHON_USEDEP}]
+"
+DEPEND="
+       dev-python/setuptools[${PYTHON_USEDEP}]
+"
diff --git a/dev-python/breathe/metadata.xml b/dev-python/breathe/metadata.xml
new file mode 100644 (file)
index 0000000..c4975d2
--- /dev/null
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+  <maintainer type="project">
+    <email>python@gentoo.org</email>
+    <name>Python</name>
+  </maintainer>
+  <longdescription>
+    Breathe provides a bridge between the Sphinx and Doxygen
+    documentation systems. 
+    It is an easy way to include Doxygen information in a set of
+    documentation generated by Sphinx. The aim is to produce an autodoc
+    like support for people who enjoy using Sphinx but work with languages
+    other than Python. The system relies on the Doxygen’s xml output.
+  </longdescription>
+  <upstream>
+    <remote-id type="pypi">breathe</remote-id>
+    <remote-id type="github">michaeljones/breathe</remote-id>
+  </upstream>
+</pkgmetadata>