dev-ml/typerep: convert to opam.eclass
authorAlexis Ballier <aballier@gentoo.org>
Sun, 6 Aug 2017 12:06:12 +0000 (14:06 +0200)
committerAlexis Ballier <aballier@gentoo.org>
Sun, 6 Aug 2017 12:30:27 +0000 (14:30 +0200)
Package-Manager: Portage-2.3.6, Repoman-2.3.3

dev-ml/typerep/typerep-0.9.0.ebuild

index 7359a76a68aee7c6011f8040aa089025f400afe5..2940a4604344ff7046d985e4eb486e4473d9fa12 100644 (file)
@@ -3,6 +3,8 @@
 
 EAPI=6
 
+inherit opam
+
 DESCRIPTION="Library for creating runtime representation of OCaml types"
 HOMEPAGE="https://github.com/janestreet/typerep"
 SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
@@ -12,18 +14,6 @@ SLOT="0/${PV}"
 KEYWORDS="~amd64"
 IUSE=""
 
-DEPEND="
-       dev-lang/ocaml:=
-       dev-ml/base:=
-"
-
+DEPEND="dev-ml/base:="
 RDEPEND="${DEPEND}"
-DEPEND="${DEPEND} dev-ml/opam dev-ml/jbuilder"
-
-src_install() {
-       opam-installer -i \
-               --prefix="${ED}/usr" \
-               --libdir="${D}/$(ocamlc -where)" \
-               --docdir="${ED}/usr/share/doc/${PF}" \
-               ${PN}.install || die
-}
+DEPEND="${DEPEND} dev-ml/jbuilder"