added hipe USE flag to give users control about that feature
authorChristian Faulhammer <fauli@gentoo.org>
Tue, 12 Dec 2006 07:54:53 +0000 (07:54 +0000)
committerChristian Faulhammer <fauli@gentoo.org>
Tue, 12 Dec 2006 07:54:53 +0000 (07:54 +0000)
Package-Manager: portage-2.1.1-r2

dev-lang/erlang/ChangeLog
dev-lang/erlang/erlang-11.2.2-r1.ebuild [new file with mode: 0644]
dev-lang/erlang/files/digest-erlang-11.2.2-r1 [new file with mode: 0644]

index f390806f3e41c2fbf71095a5e2d49c7afbcf7f71..19cf87fb912c568a6675f5df3e9d7783a0e46443 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for dev-lang/erlang
 # Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/erlang/ChangeLog,v 1.47 2006/12/06 16:44:08 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/erlang/ChangeLog,v 1.48 2006/12/12 07:54:53 opfer Exp $
+
+*erlang-11.2.2-r1 (12 Dec 2006)
+
+  12 Dec 2006; Christian Faulhammer <opfer@gentoo.org>
+  -erlang-11.2.2.ebuild, +erlang-11.2.2-r1.ebuild:
+  added hipe USE flag to give users control about that feature
 
   06 Dec 2006; Christian Faulhammer <opfer@gentoo.org> erlang-11.2.2.ebuild:
   repaired the ebuild
diff --git a/dev-lang/erlang/erlang-11.2.2-r1.ebuild b/dev-lang/erlang/erlang-11.2.2-r1.ebuild
new file mode 100644 (file)
index 0000000..e05251f
--- /dev/null
@@ -0,0 +1,162 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/erlang/erlang-11.2.2-r1.ebuild,v 1.1 2006/12/12 07:54:53 opfer Exp $
+
+inherit eutils multilib flag-o-matic elisp-common versionator
+
+# NOTE: When bumping you need to adjust the *_VER strings in
+#  src_install() to honour newer versions in the package (they
+#  are maintained separately upstream).
+#  As High Performance Erlang (HiPE) messes around a lot with
+#  assembler, it breaks hardened and some normal systems, so it has
+#  been disabled.  Try with newer versions though.
+#  If you need symlinks for binaries please tell maintainers or open up a bug
+#  to let it be created.
+
+# erlang uses a really weird versioning scheme which caused quite a few problems
+# already. Thus we do a slight modification converting all letters to digits to
+# make it more sane (see e.g. #26420)
+
+# the next line selects the right source.
+MY_PV="R$(get_major_version)B-$(get_version_component_range 3)"
+
+# ATTN!! Take care when processing the C, etc version!
+MY_P=otp_src_${MY_PV}
+
+DESCRIPTION="Erlang programming language, runtime environment, and large collection of libraries"
+HOMEPAGE="http://www.erlang.org/"
+SRC_URI="http://www.erlang.org/download/${MY_P}.tar.gz
+       doc? ( http://erlang.org/download/otp_doc_man_${MY_PV}.tar.gz
+               http://erlang.org/download/otp_doc_html_${MY_PV}.tar.gz )"
+# Not yet available for 11.2.1
+#      http://developer.sipphone.com/ejabberd/erlang_epoll_patch/otp_src_${MY_PV}_epoll.patch"
+
+LICENSE="EPL"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE="doc emacs hipe java odbc ssl tk"
+
+RDEPEND=">=dev-lang/perl-5.6.1
+       ssl? ( >=dev-libs/openssl-0.9.7d )
+       emacs? ( virtual/emacs )
+       java? ( >=virtual/jdk-1.2 )
+       odbc? ( dev-db/unixODBC )"
+DEPEND="${RDEPEND}
+       tk? ( dev-lang/tk )"
+
+S=${WORKDIR}/${MY_P}
+
+SITEFILE=50erlang-gentoo.el
+
+src_unpack() {
+       ## fix compilation on hardened systems, see bug #154338
+       filter-flags "-fstack-protector"
+       filter-flags "-fstack-protector-all"
+
+       unpack ${A}
+       cd "${S}"
+       epatch "${FILESDIR}/${PN}-10.2.6-export-TARGET.patch"
+       epatch "${FILESDIR}/10.2.6-manpage-emacs-gentoo.patch"
+       use odbc || sed -i 's: odbc : :' lib/Makefile
+#      epatch "${DISTDIR}"/otp_src_${MY_PV}_epoll.patch
+
+       if use hipe; then
+               # Fix for bug #151612
+               sed -i "s/__GLIBC_MINOR__\ ==\ 3/__GLIBC_MINOR__\ \>=\ 3/g" \
+                       ${S}/erts/emulator/hipe/hipe_x86_signal.c
+               ewarn
+               ewarn "You enabled High performance Erlang. Be aware that this extension"
+               ewarn "can break the compilation in many ways, especially on hardened systems."
+               ewarn "Don't cry, don't file bugs, just disable it!"
+               ewarn
+       fi
+}
+
+src_compile() {
+       use java || export JAVAC=false
+       # disable High Performance Erlang (HiPE) to avoid a lot of
+       # problems on hardened, bug #154338
+       # Test every new version on hardened!
+       econf \
+               --enable-threads \
+               $(use_enable hipe) \
+               $(use_with ssl) \
+               || die "econf failed"
+       make || die "emake failed"
+
+       if use emacs ; then
+               pushd lib/tools/emacs
+               elisp-compile *.el
+               popd
+       fi
+}
+
+extract_version() {
+       sed -n -e "/^$2 = \(.*\)$/s::\1:p" "${S}/$1/vsn.mk"
+}
+
+src_install() {
+       local ERL_LIBDIR=/usr/$(get_libdir)/erlang
+       local ERL_INTERFACE_VER=$(extract_version lib/erl_interface EI_VSN)
+       local ERL_ERTS_VER=$(extract_version erts VSN)
+
+       make INSTALL_PREFIX="${D}" install || die
+       dodoc AUTHORS EPLICENCE README
+
+       dosym ${ERL_LIBDIR}/bin/erl /usr/bin/erl
+       dosym ${ERL_LIBDIR}/bin/erlc /usr/bin/erlc
+       dosym ${ERL_LIBDIR}/bin/ecc /usr/bin/ecc
+       dosym ${ERL_LIBDIR}/bin/elink /usr/bin/elink
+       dosym ${ERL_LIBDIR}/bin/ear /usr/bin/ear
+       dosym ${ERL_LIBDIR}/bin/escript /usr/bin/escript
+       dosym \
+               ${ERL_LIBDIR}/lib/erl_interface-${ERL_INTERFACE_VER}/bin/erl_call \
+               /usr/bin/erl_call
+       dosym ${ERL_LIBDIR}/erts-${ERL_ERTS_VER}/bin/beam /usr/bin/beam
+
+       ## Remove ${D} from the following files
+       dosed ${ERL_LIBDIR}/bin/erl
+       dosed ${ERL_LIBDIR}/bin/start
+       cd ${ERL_LIBDIR}/erts-${ERL_ERTS_VER}
+       grep -rle "${D}" "${D}"/${ERL_LIBDIR}/erts-${ERL_ERTS_VER} | xargs sed -i -e "s:${D}::g"
+
+       ## Clean up the no longer needed files
+       rm "${D}"/${ERL_LIBDIR}/Install
+
+       if use doc ; then
+               for i in "${WORKDIR}"/man/man* ; do
+                       dodir /usr/share/${i##${WORKDIR}}erl
+               done
+               for file in "${WORKDIR}"/man/man*/*.[1-9]; do
+                       # Avoid namespace collisions
+                       local newfile=${file}erl
+                       cp ${file} ${newfile}
+                       # Man page processing tools expect a capitalized "SEE ALSO" section
+                       # header
+                       sed -i -e 's,\.SH See Also,\.SH SEE ALSO,g' ${newfile}
+                       # doman sucks so we can't use it
+                       cp ${newfile} "${D}"/usr/share/man/man${newfile##*.}/
+               done
+               dohtml -A README,erl,hrl,c,h,kwc,info -r \
+                       "${WORKDIR}"/doc "${WORKDIR}"/lib "${WORKDIR}"/erts-*
+       fi
+
+       if use emacs ; then
+               pushd "${S}"
+               elisp-install erlang lib/tools/emacs/*.{el,elc}
+               elisp-site-file-install "${FILESDIR}"/${SITEFILE}
+               popd
+       fi
+}
+
+pkg_postinst() {
+       use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+       use emacs && elisp-site-regen
+       einfo
+       einfo "If you need a symlink to one of erlang's binaries,"
+       einfo "please open a bug and tell the maintainers."
+       einfo
+}
diff --git a/dev-lang/erlang/files/digest-erlang-11.2.2-r1 b/dev-lang/erlang/files/digest-erlang-11.2.2-r1
new file mode 100644 (file)
index 0000000..85d6be9
--- /dev/null
@@ -0,0 +1,9 @@
+MD5 e2c45ced77ec63b9b1dd95c8f5396f7d otp_doc_html_R11B-2.tar.gz 4739895
+RMD160 82a4ab769566705333e059d920861d05be31754b otp_doc_html_R11B-2.tar.gz 4739895
+SHA256 588514c6b96b33dbaffd40aa5b51b9c0be65d02b6e81644c53b4c705a866db47 otp_doc_html_R11B-2.tar.gz 4739895
+MD5 c81023f591c1bace836de3aa874f3c2a otp_doc_man_R11B-2.tar.gz 632153
+RMD160 90b37a71ed29f14ec0d14a520aef47ed7b7ccad0 otp_doc_man_R11B-2.tar.gz 632153
+SHA256 643fb8210a2059b2c283c17601a0d5893f5cf409f05ed4852fbf2b0607693ac9 otp_doc_man_R11B-2.tar.gz 632153
+MD5 7d7cca1d2f392a8a317cb4c0bd904726 otp_src_R11B-2.tar.gz 11244153
+RMD160 989bab054992ba23666756379950082cd41adb00 otp_src_R11B-2.tar.gz 11244153
+SHA256 3dd483ee568c31655361474aa54a28cf11575c3b1b984f0b7a6980e083a8e44b otp_src_R11B-2.tar.gz 11244153