app-crypt/libu2f-host: Version bump
authorManuel Rüger <mrueg@gentoo.org>
Sun, 13 Sep 2015 14:44:12 +0000 (16:44 +0200)
committerManuel Rüger <mrueg@gentoo.org>
Sun, 13 Sep 2015 14:44:12 +0000 (16:44 +0200)
Gentoo-Bugs: #559036

Package-Manager: portage-2.2.20.1

app-crypt/libu2f-host/Manifest
app-crypt/libu2f-host/libu2f-host-1.0.0.ebuild [new file with mode: 0644]

index 7ac29be5677378abdc7673c1e073384522448bb2..dd95ae66c2cf138344218724e43494eab0071a18 100644 (file)
@@ -1,2 +1,3 @@
 DIST libu2f-host-0.0.2.tar.xz 444176 SHA256 c9e5478f5d139c30603afe65ea7ef52b0b18c93df60103b1dafeb7f3d17acbd8 SHA512 1b10a5c8d3d071b0d5576a2247b2cc40327fe6fe7370a7680cede7ebda72bd7f0edfa1661b78074a85654a5d979f757c64c090360c69feddb9c3212dc0438deb WHIRLPOOL f8cc5d7524c8ed7943945af44e5b93b43463118b06b186460090df3c69871319e0a347c94a28467b782eb09e2653ef72ab98478d8acf720b86b807223b1ee0b1
 DIST libu2f-host-0.0.4.tar.xz 446604 SHA256 852231611bd5c526406b984ae3c92ce3423ffc7a0ef01f6a060a43b64725ead6 SHA512 09406f45bea4cbca2fd26a4ad546b2233f56e1df098976cbd24dcab08e27bf9131fdc52557b4c701b8ce27b0ece7b405e8cda889591a5e3dc9420611336d1060 WHIRLPOOL 84ac2c5e4170ff45ecb9595c73dabd6a34f79bdcf4ef9bf3ceb32c481febe0537e3ab129fcd7a63c73389b3dbc0742834574b739ed36c419b6bc84b5c01a4d5b
+DIST libu2f-host-1.0.0.tar.xz 454376 SHA256 18c56b9b5cfea2566925bba45b25a4e20b3ef8696905d8f2a06116316e164374 SHA512 ef953ffd8179e5ed4bcd1e02ccc82e671a7979b03a61ac73098be6509ab9d6badd6bb4e3e805de4ddbddbae3e8be71b091344f4230657464f6ba4ac3af171387 WHIRLPOOL cc76b778bcf20ef696900dd0ea65c0925052360a22e505a34ecb8738289d7bbaa88b31f2b25b91b6a1a22a240d01784bc6ef1cb9774c818fa0570328e9f13183
diff --git a/app-crypt/libu2f-host/libu2f-host-1.0.0.ebuild b/app-crypt/libu2f-host/libu2f-host-1.0.0.ebuild
new file mode 100644 (file)
index 0000000..f1d8211
--- /dev/null
@@ -0,0 +1,49 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools-utils linux-info udev
+
+DESCRIPTION="Yubico Universal 2nd Factor (U2F) Host C Library"
+HOMEPAGE="https://developers.yubico.com/libu2f-host/"
+SRC_URI="https://developers.yubico.com/${PN}/Releases/${P}.tar.xz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="kernel_linux static-libs systemd"
+
+RDEPEND="
+       dev-libs/hidapi
+       dev-libs/json-c"
+DEPEND="${RDEPEND}
+       virtual/pkgconfig"
+RDEPEND="${RDEPEND}
+       systemd? ( sys-apps/systemd[acl] )"
+
+CONFIG_CHECK="~HIDRAW"
+
+src_prepare() {
+       autotools-utils_src_prepare
+
+       sed -e 's:TAG+="uaccess":MODE="0664", GROUP="plugdev":g' \
+               70-u2f.rules > 70-u2f-udev.rules || die
+}
+
+src_configure() {
+       autotools-utils_src_configure
+}
+
+src_install() {
+       autotools-utils_src_install
+
+       if use kernel_linux; then
+               if use systemd; then
+                       udev_dorules 70-u2f.rules
+               else
+                       udev_newrules 70-u2f-udev.rules 70-u2f.rules
+               fi
+       fi
+}