dev-util/lldb: Switch live to monorepo
authorMichał Górny <mgorny@gentoo.org>
Fri, 1 Nov 2019 08:34:38 +0000 (09:34 +0100)
committerMichał Górny <mgorny@gentoo.org>
Fri, 1 Nov 2019 13:15:45 +0000 (14:15 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-util/lldb/lldb-10.0.0.9999.ebuild
dev-util/lldb/lldb-9.0.1.9999.ebuild

index 81f32e23229dc4ae19b084dba805cf2dfb5e2c2d..63bc879c8b920525bd2f56a26fbd6584ee74b91b 100644 (file)
@@ -14,8 +14,8 @@ inherit cmake-utils git-r3 llvm multiprocessing python-single-r1 \
 DESCRIPTION="The LLVM debugger"
 HOMEPAGE="https://llvm.org/"
 SRC_URI=""
-EGIT_REPO_URI="https://git.llvm.org/git/lldb.git
-       https://github.com/llvm-mirror/lldb.git"
+EGIT_REPO_URI="https://github.com/llvm/llvm-project.git"
+S=${WORKDIR}/${P}/lldb
 
 LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
 SLOT="0"
@@ -49,18 +49,10 @@ pkg_setup() {
 }
 
 src_unpack() {
-       if use test; then
-               # needed for patched gtest
-               git-r3_fetch "https://git.llvm.org/git/llvm.git
-                       https://github.com/llvm-mirror/llvm.git"
-       fi
+       local dirs=( lldb )
+       use test && dirs+=( llvm/lib/Testing/Support llvm/utils/unittest )
        git-r3_fetch
-
-       if use test; then
-               git-r3_checkout https://llvm.org/git/llvm.git \
-                       "${WORKDIR}"/llvm '' lib/Testing/Support utils/unittest
-       fi
-       git-r3_checkout
+       git-r3_checkout '' '' '' "${dirs[@]}"
 }
 
 src_configure() {
@@ -90,7 +82,7 @@ src_configure() {
                -DLLDB_TEST_C_COMPILER="$(type -P clang)"
                -DLLDB_TEST_CXX_COMPILER="$(type -P clang++)"
 
-               -DLLVM_MAIN_SRC_DIR="${WORKDIR}/llvm"
+               -DLLVM_MAIN_SRC_DIR="${WORKDIR}/${P}/llvm"
                -DLLVM_EXTERNAL_LIT="${EPREFIX}/usr/bin/lit"
                -DLLVM_LIT_ARGS="-vv;-j;${LIT_JOBS:-$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")}"
        )
index 9389776f49b54722316b3abca724c20238f31710..2b8872f4261c1b0ce42b48adcbb36c409305f975 100644 (file)
@@ -14,9 +14,9 @@ inherit cmake-utils git-r3 llvm multiprocessing python-single-r1 \
 DESCRIPTION="The LLVM debugger"
 HOMEPAGE="https://llvm.org/"
 SRC_URI=""
-EGIT_REPO_URI="https://git.llvm.org/git/lldb.git
-       https://github.com/llvm-mirror/lldb.git"
-EGIT_BRANCH="release_90"
+EGIT_REPO_URI="https://github.com/llvm/llvm-project.git"
+EGIT_BRANCH="release/9.x"
+S=${WORKDIR}/${P}/lldb
 
 LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
 SLOT="0"
@@ -50,18 +50,10 @@ pkg_setup() {
 }
 
 src_unpack() {
-       if use test; then
-               # needed for patched gtest
-               git-r3_fetch "https://git.llvm.org/git/llvm.git
-                       https://github.com/llvm-mirror/llvm.git"
-       fi
+       local dirs=( lldb )
+       use test && dirs+=( llvm/lib/Testing/Support llvm/utils/unittest )
        git-r3_fetch
-
-       if use test; then
-               git-r3_checkout https://llvm.org/git/llvm.git \
-                       "${WORKDIR}"/llvm '' lib/Testing/Support utils/unittest
-       fi
-       git-r3_checkout
+       git-r3_checkout '' '' '' "${dirs[@]}"
 }
 
 src_configure() {
@@ -90,7 +82,7 @@ src_configure() {
                -DLLDB_TEST_C_COMPILER="$(type -P clang)"
                -DLLDB_TEST_CXX_COMPILER="$(type -P clang++)"
 
-               -DLLVM_MAIN_SRC_DIR="${WORKDIR}/llvm"
+               -DLLVM_MAIN_SRC_DIR="${WORKDIR}/${P}/llvm"
                -DLLVM_EXTERNAL_LIT="${EPREFIX}/usr/bin/lit"
                -DLLVM_LIT_ARGS="-vv;-j;${LIT_JOBS:-$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")}"
        )