dev-util/lldb: Add USE=lzma to 10.*
authorMichał Górny <mgorny@gentoo.org>
Sun, 3 Nov 2019 09:58:02 +0000 (10:58 +0100)
committerMichał Górny <mgorny@gentoo.org>
Sun, 3 Nov 2019 10:00:28 +0000 (11:00 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-util/lldb/lldb-10.0.0.9999.ebuild

index 2834cd907b5fcd02c920e20dc252cac2abe2a01b..4534586ab24993557a803feff54c83f0eed085aa 100644 (file)
@@ -16,12 +16,13 @@ S=${WORKDIR}/${P}/lldb
 LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
 SLOT="0"
 KEYWORDS=""
-IUSE="libedit ncurses +python test"
+IUSE="libedit lzma ncurses +python test"
 REQUIRED_USE=${PYTHON_REQUIRED_USE}
 RESTRICT="!test? ( test )"
 
 RDEPEND="
        libedit? ( dev-libs/libedit:0= )
+       lzma? ( app-arch/xz-utils:= )
        ncurses? ( >=sys-libs/ncurses-5.9-r3:0= )
        python? ( dev-python/six[${PYTHON_USEDEP}]
                ${PYTHON_DEPS} )
@@ -56,6 +57,7 @@ src_configure() {
                -DLLDB_DISABLE_CURSES=$(usex !ncurses)
                -DLLDB_DISABLE_LIBEDIT=$(usex !libedit)
                -DLLDB_DISABLE_PYTHON=$(usex !python)
+               -DLLDB_ENABLE_LZMA=$(usex lzma)
                -DLLDB_USE_SYSTEM_SIX=1
                -DLLVM_ENABLE_TERMINFO=$(usex ncurses)