bump; add pypy support
authorIan Delaney <idella4@gentoo.org>
Tue, 11 Aug 2015 06:59:14 +0000 (14:59 +0800)
committerIan Delaney <idella4@gentoo.org>
Tue, 11 Aug 2015 07:01:57 +0000 (15:01 +0800)
Package-Manager: portage-2.2.20

dev-python/pretty-yaml/Manifest
dev-python/pretty-yaml/pretty-yaml-15.6.3.ebuild [new file with mode: 0644]

index a924d8fc34bd74e1fe4b9649172e7bbb03e31e3f..e566af2f03e433b0100ff0a5122137e5c56a39ce 100644 (file)
@@ -1,2 +1,3 @@
 DIST pyaml-14.05.7.tar.gz 7401 SHA256 8c1edf635edc0658d9f6cd222f175e35aecaaef1cad432b188206b71a9cdbd30 SHA512 4a977de705a85341ff817b51e29facea6029c0082cdc0d9b212748d6992a1be3c461d59a5a41f131a14c0cfc0b6db3aad9091e0ff86c05da70974fd3651eaea9 WHIRLPOOL ed5fe07b7dd686a8d460841bfcbbb326d833124f0078a7aa70a80ddd3c85fcc245d9808a2aa19676636fea3d299be986fefead3022d96f846e6a9571ae67024f
 DIST pyaml-15.5.7.tar.gz 14374 SHA256 85c44970d9bca68742faef77cb10a16d4a81be81281541c8d39c10f504042bc6 SHA512 c92250bba3bfded1a4d047940098b532989f9fe020d1e7ccdd45779260e1114c8720d9ef4d98de0abfa699807d9377e29e9ad9c979dd086456eade0fecf6f0ae WHIRLPOOL e7cb76e586f32eebb8cb56af949925030dabc81e5f2f7b1a575980b49ab020968c393739deb6b69afb98f2c4b3ef21601a43166b7ce092c1e88aa3e2e95758cf
+DIST pyaml-15.6.3.tar.gz 14459 SHA256 2df761472d0974205b779dab469903cc9ddf257dcd126acc4a97b9d4c970e662 SHA512 9d0789342f59adfc415bef54cdc52b75cbcf1fa71940e1b9534ea0c141c5737449104e45fb0feea968e58d0886a74d9a5bbec0ba05b7d72cf5d93d3a674b5868 WHIRLPOOL 7c2e06dedf40c7c13474824090bf1f5a0453d2d955d446053479be93388c55b30480dc41eaec32a31a2303ae1971de5902922776a48c6d54cdb107a2356a1786
diff --git a/dev-python/pretty-yaml/pretty-yaml-15.6.3.ebuild b/dev-python/pretty-yaml/pretty-yaml-15.6.3.ebuild
new file mode 100644 (file)
index 0000000..c2c09c8
--- /dev/null
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_{3,4}} pypy )
+
+inherit distutils-r1
+
+MY_PN="${PN//retty-}"
+DESCRIPTION="PyYAML-based module to produce pretty and readable YAML-serialized data"
+HOMEPAGE="https://github.com/mk-fg/pretty-yaml"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="WTFPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+       test? ( dev-python/unidecode[${PYTHON_USEDEP}] )"
+RDEPEND="dev-python/pyyaml[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+python_test() {
+       "${PYTHON}" pyaml/tests/dump.py || die "tests failed under ${EPYTHON}"
+}