projects
/
gentoo.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
2789272
)
libav: Filter -marm
author
Luca Barbato
<lu_zero@gentoo.org>
Tue, 15 Sep 2015 13:21:25 +0000
(15:21 +0200)
committer
Luca Barbato
<lu_zero@gentoo.org>
Fri, 25 Sep 2015 10:08:27 +0000
(12:08 +0200)
It is know to cause horrible problems.
media-video/libav/libav-9999.ebuild
patch
|
blob
|
history
diff --git
a/media-video/libav/libav-9999.ebuild
b/media-video/libav/libav-9999.ebuild
index 503d6e6a4707f505bc86bda21159940f6c12a48e..09447dad547f067718eda3c8ecbec582082a5ac3 100644
(file)
--- a/
media-video/libav/libav-9999.ebuild
+++ b/
media-video/libav/libav-9999.ebuild
@@
-276,6
+276,11
@@
multilib_src_configure() {
# Misc stuff
use hardcoded-tables && myconf+=( --enable-hardcoded-tables )
+ # Forcing arm would make the compiler break left and right
+ if [[ ${ABI} == arm ]]; then
+ filter-flags -marm
+ fi
+
# Specific workarounds for too-few-registers arch...
if [[ ${ABI} == x86 ]]; then
local CFLAGS=${CFLAGS} CXXFLAGS=${CXXFLAGS}