use games_get_libdir
authorTristan Heaven <tristan@gentoo.org>
Fri, 6 Apr 2007 05:47:54 +0000 (05:47 +0000)
committerTristan Heaven <tristan@gentoo.org>
Fri, 6 Apr 2007 05:47:54 +0000 (05:47 +0000)
Package-Manager: portage-2.1.2.3

games-emulation/mupen64-glide64/mupen64-glide64-0.7.ebuild
games-emulation/mupen64-riceplugin/mupen64-riceplugin-5.1.0.ebuild
games-emulation/pcsx/pcsx-1.5-r1.ebuild

index 3294d0aa5e0dcbd2dc2a4111c0e250651a08c06c..28400e0f50a92286d77deb9a958f950263c80e4a 100644 (file)
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64-glide64/mupen64-glide64-0.7.ebuild,v 1.9 2007/02/22 05:23:18 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64-glide64/mupen64-glide64-0.7.ebuild,v 1.10 2007/04/06 05:42:40 nyhm Exp $
 
 inherit flag-o-matic eutils games
 
@@ -25,11 +25,12 @@ src_unpack() {
        unpack ${A}
        cd "${S}"
 
-       epatch "${FILESDIR}/${P}-compile.patch" \
-               "${FILESDIR}/${P}-inifix.patch" \
-               "${FILESDIR}/${P}-gtk2.patch"
+       epatch \
+               "${FILESDIR}"/${P}-compile.patch \
+               "${FILESDIR}"/${P}-inifix.patch \
+               "${FILESDIR}"/${P}-gtk2.patch
 
-       make clean || die "couldn't clean"
+       emake -j1 clean
 
        # gcc 3.4 at least has a problem with -O3 and inline asm
        replace-flags -O3 -O2
@@ -38,7 +39,7 @@ src_unpack() {
        sed -i \
                -e "s:CFLAGS.*=\(.*\):CFLAGS=\1 ${CFLAGS}:" \
                Makefile \
-               ||  die "sed failed"
+               || die "sed failed"
 }
 
 src_compile() {
@@ -46,9 +47,9 @@ src_compile() {
 }
 
 src_install() {
-       exeinto "${GAMES_LIBDIR}/mupen64/plugins"
+       exeinto "$(games_get_libdir)"/mupen64/plugins
        doexe Glide64.so || die "doexe failed"
-       insinto "${GAMES_LIBDIR}/mupen64/plugins"
-       doins Glide64.ini
+       insinto "$(games_get_libdir)"/mupen64/plugins
+       doins Glide64.ini || die "doins failed"
        prepgamesdirs
 }
index d86d38245798798541cbf1a9c7b01fa57c70c598..284fbdceeb42b6a2ffeff97a5414301a6736862a 100644 (file)
@@ -1,8 +1,8 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64-riceplugin/mupen64-riceplugin-5.1.0.ebuild,v 1.10 2006/06/01 18:51:02 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64-riceplugin/mupen64-riceplugin-5.1.0.ebuild,v 1.11 2007/04/06 05:46:11 nyhm Exp $
 
-inherit toolchain-funcs eutils libtool flag-o-matic games
+inherit toolchain-funcs eutils flag-o-matic games
 
 DESCRIPTION="an graphics plugin for mupen64"
 SRC_URI="http://mupen64.emulation64.com/files/0.4/riceplugin.tar.bz2"
@@ -18,17 +18,16 @@ RDEPEND="sys-libs/zlib
        media-libs/libsdl
        virtual/glu
        virtual/opengl"
-
 DEPEND="${RDEPEND}
        dev-lang/nasm"
 
-S="${WORKDIR}/riceplugin"
+S=${WORKDIR}/riceplugin
 
 src_unpack() {
        unpack ${A}
        cd "${S}"
-
-       epatch "${FILESDIR}"/${PN}-makefile.patch \
+       epatch \
+               "${FILESDIR}"/${PN}-makefile.patch \
                "${FILESDIR}"/${PN}-gtk2.patch \
                "${FILESDIR}"/${PN}-compile.patch \
                "${FILESDIR}"/${PN}-gcc4.patch
@@ -40,9 +39,9 @@ src_compile() {
 }
 
 src_install() {
-       exeinto "${GAMES_LIBDIR}"/mupen64/plugins
-       doexe *.so
-       insinto "${GAMES_LIBDIR}"/mupen64/plugins
-       doins *.ini
+       exeinto "$(games_get_libdir)"/mupen64/plugins
+       doexe *.so || die "doexe failed"
+       insinto "$(games_get_libdir)"/mupen64/plugins
+       doins *.ini || die "doins failed"
        prepgamesdirs
 }
index 9e3fdfc637b8ed03e8bdf5a1cd716c010303e23c..2e0fbf6490d8b1cfa8f260501c544dd5acd8072b 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/pcsx/pcsx-1.5-r1.ebuild,v 1.10 2007/02/24 00:53:40 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/pcsx/pcsx-1.5-r1.ebuild,v 1.11 2007/04/06 05:47:54 nyhm Exp $
 
 inherit eutils games
 
@@ -36,14 +36,14 @@ src_unpack() {
                "${FILESDIR}"/${PV}-gentoo.patch \
                "${FILESDIR}"/${P}-gcc41.patch
        sed -i \
-               -e "s:Plugin/:${GAMES_LIBDIR}/psemu/plugins/:" \
-               -e "s:Bios/:${GAMES_LIBDIR}/psemu/bios/:" \
+               -e "s:Plugin/:$(games_get_libdir)/psemu/plugins/:" \
+               -e "s:Bios/:$(games_get_libdir)/psemu/bios/:" \
                -e 's:Pcsx.cfg:~/.pcsx/config:' \
                Linux/LnxMain.c \
                || die "sed LnxMain.c failed"
        sed \
                -e "s:GAMES_DATADIR:${GAMES_DATADIR}:" \
-               -e "s:GAMES_LIBDIR:${GAMES_LIBDIR}:" \
+               -e "s:GAMES_LIBDIR:$(games_get_libdir):" \
                -e "s:GAMES_BINDIR:${GAMES_BINDIR}:" \
                "${FILESDIR}"/pcsx > "${T}"/pcsx \
                || die "sed failed"