dev-python/python-fastimport: Drop old
authorPacho Ramos <pacho@gentoo.org>
Sun, 15 Dec 2019 14:22:55 +0000 (15:22 +0100)
committerPacho Ramos <pacho@gentoo.org>
Sun, 15 Dec 2019 14:22:55 +0000 (15:22 +0100)
Package-Manager: Portage-2.3.81, Repoman-2.3.19
Signed-off-by: Pacho Ramos <pacho@gentoo.org>
dev-python/python-fastimport/Manifest
dev-python/python-fastimport/python-fastimport-0.9.2-r1.ebuild [deleted file]
dev-python/python-fastimport/python-fastimport-0.9.6.ebuild [deleted file]

index 00372e23b44bb547daaea4e84ef96abb1883d996..ec268fd1126c509f7030a389f9f0efcd4349573a 100644 (file)
@@ -1,3 +1 @@
-DIST fastimport-0.9.6.tar.gz 33333 BLAKE2B 46e654c26bd388a61ae0717b66294dbc1261aca9a2b6e1823e6d8afad014fd21d0ea54e70e018ba79cc45dc6111ccf84a4eb68e053c0812773a4c25cb32e0569 SHA512 cc38c1218d65ef4a9e3a68d8af3fadf98c7cc0dcd8075b338b8f492d25765bc2fe2247000868fd3c95e1f7f4c2b9a05964ef7b4f9196c2777f6a7941f127f416
 DIST fastimport-0.9.8.tar.gz 39512 BLAKE2B 484ba865e749cca33df73417285e51a9117e7c905ab2922588d6eef9a64ea6b3d72de285a2affbe7d4a770ead9ece30f6242777087af1c469d59c8f2a4e1b008 SHA512 5d195b641cf6138fdbc6c75781a4a6d3699e3ada9743bbe4c4264879b2da2f8a2e995e7cc3955a5241e9c7a7f24f8114474a0a30907f86e2e335e2be4669f588
-DIST python-fastimport-0.9.2.tar.gz 30762 BLAKE2B 2484e02077017c5534afafcc17627bef8875379bd8e66b5610408b5b11feb6db32cd9e97905a9ff3bc23cc58f6e01255bb3e18ea6fa66e0d077a42504e0def39 SHA512 8fd9f89267ca88edff94cea7537740431d02680a1eebd085ee376954b47bf5222e7575750895d0d2da246694cdac7a5afe50d857b87c0f36e04eb3511bcbe472
diff --git a/dev-python/python-fastimport/python-fastimport-0.9.2-r1.ebuild b/dev-python/python-fastimport/python-fastimport-0.9.2-r1.ebuild
deleted file mode 100644 (file)
index bbff297..0000000
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 pypy )
-
-inherit distutils-r1
-
-DESCRIPTION="Library for parsing the fastimport VCS serialization format"
-HOMEPAGE="https://github.com/jelmer/python-fastimport"
-SRC_URI="https://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.gz"
-
-LICENSE="GPL-2+"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND=""
-DEPEND="
-       test? (
-               dev-python/testtools[${PYTHON_USEDEP}]
-       )"
-
-python_test() {
-       local test_runner=( "${PYTHON}" -m unittest )
-
-       if [[ ${EPYTHON} == python2.6 ]]; then
-               test_runner=( unit2 )
-       fi
-
-       "${test_runner[@]}" fastimport.tests.test_suite \
-               || die "Tests fail with ${EPYTHON}"
-}
diff --git a/dev-python/python-fastimport/python-fastimport-0.9.6.ebuild b/dev-python/python-fastimport/python-fastimport-0.9.6.ebuild
deleted file mode 100644 (file)
index 17053b7..0000000
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python{2_7,3_5,3_6} pypy )
-
-inherit distutils-r1
-
-MY_PN="${PN#python-}"
-MY_P="${MY_PN}-${PV}"
-DESCRIPTION="Library for parsing the fastimport VCS serialization format"
-HOMEPAGE="https://github.com/jelmer/python-fastimport"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="GPL-2+"
-SLOT="0"
-KEYWORDS="amd64 arm64 ppc ~ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-
-S="${WORKDIR}/${MY_P}"
-
-python_test() {
-       "${PYTHON}" -m unittest fastimport.tests.test_suite \
-               || die "Tests fail with ${EPYTHON}"
-}