media-libs/aubio: Security cleanup
authorAndreas Sturmlechner <asturm@gentoo.org>
Sat, 6 Oct 2018 19:33:01 +0000 (21:33 +0200)
committerAndreas Sturmlechner <asturm@gentoo.org>
Sat, 6 Oct 2018 19:45:14 +0000 (21:45 +0200)
Bug: https://bugs.gentoo.org/667510
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Package-Manager: Portage-2.3.50, Repoman-2.3.11

media-libs/aubio/Manifest
media-libs/aubio/aubio-0.4.1-r1.ebuild [deleted file]
media-libs/aubio/aubio-0.4.2-r1.ebuild [deleted file]
media-libs/aubio/aubio-0.4.6.ebuild [deleted file]
media-libs/aubio/files/aubio-0.4.1-ffmpeg29.patch [deleted file]
media-libs/aubio/files/aubio-0.4.6-ffmpeg4.patch [deleted file]

index 6a455a6bc03abb9a8506444019d0245f66089d55..b4ed4a63e48c6ab7a54c2909a06fce37c4e27d56 100644 (file)
@@ -1,4 +1 @@
-DIST aubio-0.4.1.tar.bz2 288136 BLAKE2B ba7368fab21fec73dc555ea0d7291eea010a415d8bc77601337cf311277f3c82564c2f021b971a4117a3f99ab69e7a61e55b8ee488ca24b9b5319ab4a00a3a6b SHA512 f36800f1a0cbe72509e05d15d79759ed25975e92701804597ed4c9d93e27d5e7b908e0aa65819ce763882945123ea174a0825c7aacf9f9494f56d72de5b8308c
-DIST aubio-0.4.2.tar.bz2 304216 BLAKE2B aab7e55d580105e6180503503ae2970d150d86e445d5c1b10d3f39c8cdf7496d0c280a57a2fc7ad3ea5142996d56c53cd2e1c6f736fb1a98b9b142438c919e04 SHA512 b57b6d147b305a264f0055726f76a8452f784b556a7fda911f056adbedd2855048e93c0e21b9f359e3f442f1542189aff0c214dd85141e2e06048a07f47703ff
-DIST aubio-0.4.6.tar.bz2 363016 BLAKE2B 3847ed02b7d64d9796bd1f5a06044d945f5859ab87a762978bf2b0b6650cc0e19c9b8eec99a793e14dd25c06f66d2bffd453ecca824fbc5f47700fda7f78854b SHA512 0e5cab0c88d51f2fb70c0d85e1c067a7b3758fbffdbd5026686726379aa36203adb63ed3f8e40c83ea02930e0ffc4e6c246803f1d518d448d47a01984678e77d
 DIST aubio-0.4.7.tar.bz2 372173 BLAKE2B 544239b215dd87d4cf4a6ed6b5dd856411d0a3f1c3242e3e1077fa0780160785a9934884a1f0d0dc80fe21b1d417bc3800db59842ec300a4c29d75b7942cba05 SHA512 30c614f2b502b993df28d4746a99421fe0aada33c98c42ea19c271554b29b360cb4d4f6650c1b1da508da4bc341348c5944cb452f69b2bf354ca6348f84de260
diff --git a/media-libs/aubio/aubio-0.4.1-r1.ebuild b/media-libs/aubio/aubio-0.4.1-r1.ebuild
deleted file mode 100644 (file)
index 59a6487..0000000
+++ /dev/null
@@ -1,104 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-DISTUTILS_OPTIONAL=1
-PYTHON_COMPAT=( python2_7 )
-PYTHON_REQ_USE='threads(+)'
-
-inherit distutils-r1 waf-utils multilib eutils
-
-DESCRIPTION="Library for audio labelling"
-HOMEPAGE="https://aubio.org/"
-SRC_URI="https://aubio.org/pub/${P}.tar.bz2"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="amd64 ~ppc ppc64 sparc x86"
-IUSE="doc double-precision examples ffmpeg fftw jack libsamplerate sndfile python"
-
-RDEPEND="
-       ffmpeg? ( virtual/ffmpeg )
-       fftw? ( sci-libs/fftw:3.0 )
-       jack? ( virtual/jack )
-       libsamplerate? ( media-libs/libsamplerate )
-       python? ( dev-python/numpy[${PYTHON_USEDEP}] ${PYTHON_DEPS} )
-       sndfile? ( media-libs/libsndfile )"
-DEPEND="${RDEPEND}
-       ${PYTHON_DEPS}
-       virtual/pkgconfig
-       app-text/txt2man
-       doc? ( app-doc/doxygen )"
-REQUIRED_USE=${PYTHON_REQUIRED_USE}
-
-DOCS=( AUTHORS ChangeLog README.md )
-PYTHON_SRC_DIR="${S}/python"
-
-src_prepare() {
-       sed -i -e "s:\/lib:\/$(get_libdir):" src/wscript_build || die
-       sed -i -e "s:doxygen:doxygen_disabled:" wscript || die
-       has_version '>=media-video/ffmpeg-2.8' && epatch "${FILESDIR}/${PN}-0.4.1-ffmpeg29.patch"
-}
-
-src_configure() {
-       python_setup
-       waf-utils_src_configure \
-               --enable-complex \
-               --docdir="${EPREFIX}"/usr/share/doc/${PF} \
-               $(use_enable double-precision double) \
-               $(use_enable fftw fftw3f) \
-               $(use_enable fftw fftw3) \
-               $(use_enable ffmpeg avcodec) \
-               $(use_enable jack) \
-               $(use_enable libsamplerate samplerate) \
-               $(use_enable sndfile)
-
-       if use python ; then
-               cd "${PYTHON_SRC_DIR}" || die
-               distutils-r1_src_configure
-       fi
-}
-
-src_compile() {
-       waf-utils_src_compile --notests
-
-       if use doc; then
-               cd "${S}"/doc || die
-               doxygen full.cfg || die
-       fi
-
-       if use python ; then
-               cd "${PYTHON_SRC_DIR}" || die
-               distutils-r1_src_compile
-       fi
-}
-
-src_test() {
-       waf-utils_src_compile --alltests
-
-       if use python ; then
-               cd "${PYTHON_SRC_DIR}" || die
-               distutils-r1_src_test
-       fi
-}
-
-src_install() {
-       waf-utils_src_install
-
-       if use python ; then
-               cd "${PYTHON_SRC_DIR}" || die
-               DOCS="" distutils-r1_src_install
-               newdoc README README.python
-       fi
-
-       if use doc; then
-               dohtml -r doc/full/html/.
-               dodoc doc/*.txt
-       fi
-
-       if use examples; then
-               # install dist_noinst_SCRIPTS from Makefile.am
-               dodoc -r examples
-       fi
-}
diff --git a/media-libs/aubio/aubio-0.4.2-r1.ebuild b/media-libs/aubio/aubio-0.4.2-r1.ebuild
deleted file mode 100644 (file)
index 47feb82..0000000
+++ /dev/null
@@ -1,105 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-DISTUTILS_OPTIONAL=1
-PYTHON_COMPAT=( python2_7 )
-PYTHON_REQ_USE='threads(+)'
-
-inherit distutils-r1 waf-utils multilib eutils
-
-DESCRIPTION="Library for audio labelling"
-HOMEPAGE="https://aubio.org/"
-SRC_URI="https://aubio.org/pub/${P}.tar.bz2"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="doc double-precision examples ffmpeg fftw jack libav libsamplerate sndfile python"
-
-RDEPEND="
-       ffmpeg? (
-               !libav? ( >=media-video/ffmpeg-2.6:0= )
-               libav? ( >=media-video/libav-9:0= )
-       )
-       fftw? ( sci-libs/fftw:3.0 )
-       jack? ( virtual/jack )
-       libsamplerate? ( media-libs/libsamplerate )
-       python? ( dev-python/numpy[${PYTHON_USEDEP}] ${PYTHON_DEPS} )
-       sndfile? ( media-libs/libsndfile )"
-DEPEND="${RDEPEND}
-       ${PYTHON_DEPS}
-       virtual/pkgconfig
-       app-text/txt2man
-       doc? ( app-doc/doxygen )"
-REQUIRED_USE=${PYTHON_REQUIRED_USE}
-
-DOCS=( AUTHORS ChangeLog README.md )
-PYTHON_SRC_DIR="${S}/python"
-
-src_prepare() {
-       sed -i -e "s:doxygen:doxygen_disabled:" wscript || die
-}
-
-src_configure() {
-       python_setup
-       waf-utils_src_configure \
-               --enable-complex \
-               --docdir="${EPREFIX}"/usr/share/doc/${PF} \
-               $(use_enable double-precision double) \
-               $(use_enable fftw fftw3f) \
-               $(use_enable fftw fftw3) \
-               $(use_enable ffmpeg avcodec) \
-               $(use_enable jack) \
-               $(use_enable libsamplerate samplerate) \
-               $(use_enable sndfile)
-
-       if use python ; then
-               cd "${PYTHON_SRC_DIR}" || die
-               distutils-r1_src_configure
-       fi
-}
-
-src_compile() {
-       waf-utils_src_compile --notests
-
-       if use doc; then
-               cd "${S}"/doc || die
-               doxygen full.cfg || die
-       fi
-
-       if use python ; then
-               cd "${PYTHON_SRC_DIR}" || die
-               distutils-r1_src_compile
-       fi
-}
-
-src_test() {
-       waf-utils_src_compile --alltests
-
-       if use python ; then
-               cd "${PYTHON_SRC_DIR}" || die
-               distutils-r1_src_test
-       fi
-}
-
-src_install() {
-       waf-utils_src_install
-
-       if use doc; then
-               dohtml -r doc/full/html/.
-               dodoc doc/*.txt
-       fi
-
-       if use examples; then
-               # install dist_noinst_SCRIPTS from Makefile.am
-               dodoc -r examples
-       fi
-
-       if use python ; then
-               cd "${PYTHON_SRC_DIR}" || die
-               DOCS="" distutils-r1_src_install
-               newdoc README README.python
-       fi
-}
diff --git a/media-libs/aubio/aubio-0.4.6.ebuild b/media-libs/aubio/aubio-0.4.6.ebuild
deleted file mode 100644 (file)
index 9c6af65..0000000
+++ /dev/null
@@ -1,111 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-DISTUTILS_OPTIONAL=1
-PYTHON_COMPAT=( python2_7 )
-PYTHON_REQ_USE='threads(+)'
-
-inherit distutils-r1 waf-utils multilib eutils
-
-DESCRIPTION="Library for audio labelling"
-HOMEPAGE="https://aubio.org/"
-SRC_URI="https://aubio.org/pub/${P}.tar.bz2"
-
-LICENSE="GPL-3"
-SLOT="0/5"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="doc double-precision examples ffmpeg fftw jack libav libsamplerate sndfile python"
-
-RDEPEND="
-       ffmpeg? (
-               !libav? ( >=media-video/ffmpeg-2.6:0= )
-               libav? ( >=media-video/libav-9:0= )
-       )
-       fftw? ( sci-libs/fftw:3.0 )
-       jack? ( virtual/jack )
-       libsamplerate? ( media-libs/libsamplerate )
-       python? ( dev-python/numpy[${PYTHON_USEDEP}] ${PYTHON_DEPS} )
-       sndfile? ( media-libs/libsndfile )
-"
-DEPEND="
-       ${RDEPEND}
-       ${PYTHON_DEPS}
-       app-text/txt2man
-       virtual/pkgconfig
-       doc? ( app-doc/doxygen )
-"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-DOCS=( AUTHORS ChangeLog README.md )
-PYTHON_SRC_DIR="${S}"
-PATCHES=( "${FILESDIR}/${PN}-0.4.6-ffmpeg4.patch" )
-
-src_prepare() {
-       default
-       sed -i -e "s:doxygen:doxygen_disabled:" wscript || die
-}
-
-src_configure() {
-       python_setup
-       waf-utils_src_configure \
-               --enable-complex \
-               --docdir="${EPREFIX}"/usr/share/doc/${PF} \
-               $(use_enable double-precision double) \
-               $(use_enable fftw fftw3f) \
-               $(use_enable fftw fftw3) \
-               $(use_enable ffmpeg avcodec) \
-               $(use_enable jack) \
-               $(use_enable libsamplerate samplerate) \
-               $(use_enable sndfile)
-
-       if use python ; then
-               cd "${PYTHON_SRC_DIR}" || die
-               distutils-r1_src_configure
-       fi
-}
-
-src_compile() {
-       waf-utils_src_compile --notests
-
-       if use doc; then
-               cd "${S}"/doc || die
-               emake dirhtml
-       fi
-
-       if use python ; then
-               cd "${PYTHON_SRC_DIR}" || die
-               distutils-r1_src_compile
-       fi
-}
-
-src_test() {
-       waf-utils_src_compile --alltests
-
-       if use python ; then
-               cd "${PYTHON_SRC_DIR}" || die
-               distutils-r1_src_test
-       fi
-}
-
-src_install() {
-       waf-utils_src_install
-
-       if use examples; then
-               # install dist_noinst_SCRIPTS from Makefile.am
-               dodoc -r examples
-       fi
-
-       if use python ; then
-               cd "${PYTHON_SRC_DIR}" || die
-               DOCS="" distutils-r1_src_install
-               newdoc python/README.md README.python
-       fi
-
-       if use doc; then
-               dodoc doc/*.txt
-               docinto html
-               dodoc -r doc/_build/dirhtml/.
-       fi
-}
diff --git a/media-libs/aubio/files/aubio-0.4.1-ffmpeg29.patch b/media-libs/aubio/files/aubio-0.4.1-ffmpeg29.patch
deleted file mode 100644 (file)
index 8656271..0000000
+++ /dev/null
@@ -1,22 +0,0 @@
-Index: aubio-0.4.1/src/io/source_avcodec.c
-===================================================================
---- aubio-0.4.1.orig/src/io/source_avcodec.c
-+++ aubio-0.4.1/src/io/source_avcodec.c
-@@ -167,7 +167,7 @@ aubio_source_avcodec_t * new_aubio_sourc
-   }
-   AVFrame *avFrame = s->avFrame;
--  avFrame = avcodec_alloc_frame();
-+  avFrame = av_frame_alloc();
-   if (!avFrame) {
-     AUBIO_ERR("source_avcodec: Could not allocate frame for (%s)\n", s->path);
-   }
-@@ -415,7 +415,7 @@ void del_aubio_source_avcodec(aubio_sour
-   }
-   s->output = NULL;
-   if (s->avFrame != NULL) {
--    avcodec_free_frame( &(s->avFrame) );
-+    av_frame_free( &(s->avFrame) );
-   }
-   s->avFrame = NULL;
-   AUBIO_FREE(s);
diff --git a/media-libs/aubio/files/aubio-0.4.6-ffmpeg4.patch b/media-libs/aubio/files/aubio-0.4.6-ffmpeg4.patch
deleted file mode 100644 (file)
index 7df4665..0000000
+++ /dev/null
@@ -1,13 +0,0 @@
-Index: aubio-0.4.6/src/io/source_avcodec.c
-===================================================================
---- aubio-0.4.6.orig/src/io/source_avcodec.c
-+++ aubio-0.4.6/src/io/source_avcodec.c
-@@ -58,7 +58,7 @@
- #include "fmat.h"
- #include "source_avcodec.h"
--#define AUBIO_AVCODEC_MAX_BUFFER_SIZE FF_MIN_BUFFER_SIZE
-+#define AUBIO_AVCODEC_MAX_BUFFER_SIZE AV_INPUT_BUFFER_MIN_SIZE
- struct _aubio_source_avcodec_t {
-   uint_t hop_size;