Cleanup.
authorLuca Longinotti <chtekk@gentoo.org>
Sun, 14 Jan 2007 18:15:40 +0000 (18:15 +0000)
committerLuca Longinotti <chtekk@gentoo.org>
Sun, 14 Jan 2007 18:15:40 +0000 (18:15 +0000)
Package-Manager: portage-2.1.2_rc4-r8

net-www/mod_mp3/ChangeLog
net-www/mod_mp3/mod_mp3-0.40-r1.ebuild

index f1dd74d55f8af57ee7f6180bc0005a3184ac6e96..dea0658a66d75c4e7f9cc0590f6dd9fc3516c04b 100644 (file)
@@ -1,6 +1,10 @@
 # ChangeLog for net-www/mod_mp3
-# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mod_mp3/ChangeLog,v 1.28 2006/11/23 16:15:38 vivo Exp $
+# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_mp3/ChangeLog,v 1.29 2007/01/14 18:15:40 chtekk Exp $
+
+  14 Jan 2007; Luca Longinotti <chtekk@gentoo.org> -files/mod_mp3.conf,
+  mod_mp3-0.40-r1.ebuild:
+  Cleanup.
 
   23 Nov 2006; Francesco Riosa <vivo@gentoo.org> mod_mp3-0.40-r1.ebuild:
   dev-db/mysql => virtual/mysql
index 31b053ba577584fc67d30e831f5368a6f6360b18..fe1d7bc6583b7ce1afcc03e5b7275e4fb4fda080 100644 (file)
@@ -1,40 +1,37 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mod_mp3/mod_mp3-0.40-r1.ebuild,v 1.8 2006/11/23 16:15:38 vivo Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_mp3/mod_mp3-0.40-r1.ebuild,v 1.9 2007/01/14 18:15:40 chtekk Exp $
 
 inherit apache-module
 
-# test target in Makefile isn't sane
-RESTRICT="test"
-
-IUSE="mysql postgres"
+KEYWORDS="ppc x86"
 
-DESCRIPTION="Module for turning Apache into an MP3 or Ogg streaming server"
+DESCRIPTION="Module for turning Apache1 into an MP3 or Ogg streaming server."
 HOMEPAGE="http://software.tangent.org/"
-KEYWORDS="ppc -sparc x86"
-
 SRC_URI="http://download.tangent.org/${P}.tar.gz"
+LICENSE="as-is"
+SLOT="0"
+IUSE="mysql postgres"
 
 DEPEND="dev-lang/perl
-       mysql? ( virtual/mysql )
-       postgres? ( dev-db/postgresql )"
+               mysql? ( virtual/mysql )
+               postgres? ( dev-db/postgresql )"
 RDEPEND="${DEPEND}"
 
-LICENSE="as-is"
-SLOT="0"
+# Test target in Makefile isn't sane
+RESTRICT="test"
 
 APACHE1_MOD_CONF="50_mod_mp3"
 APACHE1_MOD_DEFINE="MP3"
 
-DOCFILES="CONTRIBUTORS ChangeLog LICENSE README TODO faq.html support/*"
+DOCFILES="CONTRIBUTORS ChangeLog LICENSE README faq.html support/*"
 
 need_apache1
 
 src_compile() {
-       local myconf
-
-       myconf="$(use_with mysql)"
+       local myconf="--with-playlist"
+       myconf="${myconf} $(use_with mysql)"
        myconf="${myconf} $(use_with postgres)"
-       ./configure ${myconf} --with-playlist || die "configure failed"
-       make || die "make failed"
+       econf ${myconf} || die "econf failed"
+       emake || die "emake failed"
 }