app-misc/gramps: Bump to version 4.2.8.
authorHerb Miller Jr <herb@hlmjr.com>
Sat, 3 Mar 2018 23:40:40 +0000 (18:40 -0500)
committerMichał Górny <mgorny@gentoo.org>
Sat, 24 Mar 2018 19:39:42 +0000 (20:39 +0100)
Package-Manager: Portage-2.3.19, Repoman-2.3.6

app-misc/gramps/Manifest
app-misc/gramps/gramps-4.2.8.ebuild [new file with mode: 0644]
app-misc/gramps/metadata.xml

index d2f65c0919c73b60d6afe88403fc1532750da335..6c36a45d9951bf441be3b68dd7ad2bcd3a075f5a 100644 (file)
@@ -1 +1,2 @@
 DIST gramps-4.2.5.tar.gz 18694912 BLAKE2B f91bc665ab4a970e7de193ba3bea4250e99b692cb92e76fae4a37cfa2c46280e6a45ff6712c7a68213735b6e7016f2caa3180971976c92aaa7e61d73ad2e3d5a SHA512 20a8ebff7ea2e3a80248830e55d58ebe0b5a350e1ac31efb3f2b900af38c134037bae91a58fb441be54f9fac8226555a3f5771cc358d3a4a92e89af911433b9c
+DIST gramps-4.2.8.tar.gz 18704769 BLAKE2B 795febcc2c93a0c9b72aceeba1ac4c4f10953c2bf3b23dd8d38f662a231e21967e6f263e14d2344ef2f422e170617b7b80be4fafc2cb20c4a659366836b0e641 SHA512 c814914eb3a650dd5753d83e492d91d5db11b55321f63bd460e4eb8d80a36dd727a3792a203e3061dfaa89fd13549f51809bb83cc65b2a494c1fb8f42dcb4b8f
diff --git a/app-misc/gramps/gramps-4.2.8.ebuild b/app-misc/gramps/gramps-4.2.8.ebuild
new file mode 100644 (file)
index 0000000..98ff2a5
--- /dev/null
@@ -0,0 +1,45 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python3_{4,5} )
+
+DISTUTILS_SINGLE_IMPL=1
+inherit distutils-r1
+
+DESCRIPTION="Genealogical Research and Analysis Management Programming System"
+HOMEPAGE="https://gramps-project.org/"
+SRC_URI="https://github.com/gramps-project/${PN}/archive/v${PV}.tar.gz
+       -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+reports exif geo spell"
+
+RDEPEND="
+       dev-python/bsddb3[${PYTHON_USEDEP}]
+       dev-python/pycairo[${PYTHON_USEDEP}]
+       >=dev-python/pygobject-3.12:3[cairo,${PYTHON_USEDEP}]
+       dev-python/pyicu[${PYTHON_USEDEP}]
+       gnome-base/librsvg:2
+       >x11-libs/gtk+-3.14.8:3[introspection]
+       x11-libs/pango[introspection]
+       x11-misc/xdg-utils
+       reports? ( media-gfx/graphviz )
+       exif? ( >=media-libs/gexiv2-0.5[${PYTHON_USEDEP},introspection] )
+       geo? ( >=sci-geosciences/osm-gps-map-1.1.0 )
+       spell? ( app-text/gtkspell:3[introspection] )
+"
+
+python_configure_all() {
+       mydistutilsargs=( --resourcepath=/usr/share )
+}
+
+python_prepare_all() {
+       # Install documentation to the proper location. This can't be done
+       # easily with a patch because we substitute in the $PF variable,
+       # and that changes with every revision.
+       sed -i "s:share/doc/gramps:share/doc/${PF}:g" setup.py || die
+       distutils-r1_python_prepare_all
+}
index 38431e0f96741cc0e6df15ee39db6ba075e038d4..a3c05404a8010152b7f6d4d5f798781dcf61b4c6 100644 (file)
@@ -1,7 +1,14 @@
 <?xml version="1.0" encoding="UTF-8"?>
 <!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
 <pkgmetadata>
-       <!-- maintainer-needed -->
+       <maintainer type="person">
+               <email>herb@hlmjr.com</email>
+               <name>Herb Miller Jr. (herbmillerjr)</name>
+       </maintainer>
+       <maintainer type="project">
+               <email>proxy-maint@gentoo.org</email>
+               <name>Proxy Maintainers</name>
+       </maintainer>
        <longdescription lang="en">
                GRAMPS helps you track your family tree. It allows you to store, edit,
                and research genealogical data. GRAMPS attempts to provide all of the