dev-python/rospkg: remove old
authorAlexis Ballier <aballier@gentoo.org>
Tue, 28 Feb 2017 11:04:20 +0000 (12:04 +0100)
committerAlexis Ballier <aballier@gentoo.org>
Tue, 28 Feb 2017 11:26:51 +0000 (12:26 +0100)
Package-Manager: Portage-2.3.3, Repoman-2.3.1

dev-python/rospkg/rospkg-1.1.0.ebuild [deleted file]

diff --git a/dev-python/rospkg/rospkg-1.1.0.ebuild b/dev-python/rospkg/rospkg-1.1.0.ebuild
deleted file mode 100644 (file)
index 5690870..0000000
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
-
-SCM=""
-if [ "${PV#9999}" != "${PV}" ] ; then
-       SCM="git-r3"
-       EGIT_REPO_URI="https://github.com/ros-infrastructure/rospkg"
-fi
-
-inherit ${SCM} distutils-r1
-
-DESCRIPTION="Standalone Python library for the ROS package system"
-HOMEPAGE="http://wiki.ros.org/rospkg"
-if [ "${PV#9999}" != "${PV}" ] ; then
-       SRC_URI=""
-       KEYWORDS=""
-       # Needed for tests
-       S="${WORKDIR}/${PN}"
-       EGIT_CHECKOUT_DIR="${S}"
-else
-       SRC_URI="https://github.com/ros-infrastructure/rospkg/archive/${PV}.tar.gz -> ${P}.tar.gz"
-       KEYWORDS="~amd64 ~arm"
-fi
-
-LICENSE="BSD"
-SLOT="0"
-IUSE="test"
-
-RDEPEND="dev-python/pyyaml[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
-       test? (
-               dev-python/nose[${PYTHON_USEDEP}]
-               dev-python/coverage[${PYTHON_USEDEP}]
-       )
-"
-
-python_test() {
-       nosetests --with-coverage --cover-package=rospkg --with-xunit test || die
-}