use games_get_libdir
authorTristan Heaven <tristan@gentoo.org>
Fri, 6 Apr 2007 04:39:38 +0000 (04:39 +0000)
committerTristan Heaven <tristan@gentoo.org>
Fri, 6 Apr 2007 04:39:38 +0000 (04:39 +0000)
Package-Manager: portage-2.1.2.3

games-emulation/epsxe/epsxe-1.6.0-r3.ebuild
games-emulation/mupen64-alsasnd/mupen64-alsasnd-0.4-r1.ebuild

index 86a9ecc2cdbbf914fc0dfb2ef8fda1bf9d69c8f4..6547d7e09bc409ac2fac67af4a9d4a2cb4678941 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/epsxe/epsxe-1.6.0-r3.ebuild,v 1.10 2007/02/24 00:16:13 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/epsxe/epsxe-1.6.0-r3.ebuild,v 1.11 2007/04/06 04:38:00 nyhm Exp $
 
 inherit games
 
@@ -30,14 +30,14 @@ src_install() {
        dogamesbin "${FILESDIR}"/epsxe
        sed -i \
                -e "s:GAMES_PREFIX_OPT:${GAMES_PREFIX_OPT}:" \
-               -e "s:GAMES_LIBDIR:${GAMES_LIBDIR}:" \
+               -e "s:GAMES_LIBDIR:$(games_get_libdir):" \
                "${D}${GAMES_BINDIR}"/epsxe \
                || die "sed failed"
        exeinto "${dir}"
        doexe epsxe || die "doexe failed"
        insinto "${dir}"
        doins keycodes.lst || die "doins failed"
-       insinto "${GAMES_LIBDIR}"/psemu/cheats
+       insinto "$(games_get_libdir)"/psemu/cheats
        doins cheats/* || die "doins failed"
        dodoc docs/*
        prepgamesdirs
index dec0c05cc1f9ccff57abcb6e1062b8d71b279f83..9f320211c357a82cfdce42f16efdff87483ce354 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64-alsasnd/mupen64-alsasnd-0.4-r1.ebuild,v 1.1 2007/02/15 09:58:09 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64-alsasnd/mupen64-alsasnd-0.4-r1.ebuild,v 1.2 2007/04/06 04:39:38 nyhm Exp $
 
 inherit eutils qt3 games
 
@@ -38,7 +38,7 @@ src_compile() {
 }
 
 src_install() {
-       exeinto "${GAMES_LIBDIR}"/mupen64/plugins
+       exeinto "$(games_get_libdir)"/mupen64/plugins
        doexe mupen64_alsasnd-${PV}.so || die "doexe failed"
        dodoc README
        prepgamesdirs