games-engines/openmw: Drop old
authorAndreas Sturmlechner <asturm@gentoo.org>
Mon, 27 Feb 2017 00:52:46 +0000 (01:52 +0100)
committerAndreas Sturmlechner <asturm@gentoo.org>
Thu, 2 Mar 2017 19:39:14 +0000 (20:39 +0100)
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Closes: https://github.com/gentoo/gentoo/pull/4099

games-engines/openmw/Manifest
games-engines/openmw/openmw-0.39.0-r1.ebuild [deleted file]

index 35e3e6a2e0dae4080039b9fd5ac028de67b37e1a..a9dff4705996e1c5ba7f166a610c3c811ccf5ba1 100644 (file)
@@ -1,2 +1 @@
-DIST openmw-0.39.0.tar.gz 4764754 SHA256 b0d294b0814099bd93326f7b86dd84fb727d38dd536bf104272112e6d70ae720 SHA512 05b9ed89d04f55fad4358a9920af1d702a1957f54233e613737126278318e7c64cacfc557c6ba43d2282454a825b1c9e225e9429d11ba0f03c5c6dd93124d91a WHIRLPOOL bb3744e1fdf4e63c02c055237eb3a749ded32da097259f6f065d331681b214be932eeb4b654c91747fb5356dbb0e88f603e0f1a4113bb3f791f9e1b3d7e6b53f
 DIST openmw-0.41.0.tar.gz 4884093 SHA256 a3e1c7d060dc461b9b63ceb5d9ec56b90c1bdcbfd37f0c7c7310c38ec7e3e21d SHA512 a47a7af3c6d3252e22206eb776069ef87f698acbe133b0e0294db307486c28cb300085fcf45b436af541dbb22f6d45f2ee3998e50a1c711f667f8a738813255d WHIRLPOOL 1e20820a0c5ee0ab2b3f57b881e39dc9ebf42e5e1674badce363ea654ac38f40146f8f8b86d7535a7cd5ce4c63f46cc322c482ad5c354ae6ad14dd11ee134d32
diff --git a/games-engines/openmw/openmw-0.39.0-r1.ebuild b/games-engines/openmw/openmw-0.39.0-r1.ebuild
deleted file mode 100644 (file)
index d3b2e35..0000000
+++ /dev/null
@@ -1,96 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit eutils gnome2-utils cmake-utils
-
-DESCRIPTION="An open source reimplementation of TES III: Morrowind"
-HOMEPAGE="http://openmw.org/"
-SRC_URI="https://github.com/OpenMW/openmw/archive/${P}.tar.gz"
-
-LICENSE="GPL-3 MIT BitstreamVera OFL-1.1"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc devtools"
-
-RDEPEND="
-       app-arch/unshield
-       >=dev-games/mygui-3.2.2
-       >=dev-games/openscenegraph-3.3.4[ffmpeg,jpeg,png,qt5,sdl,svg,truetype,zlib]
-       >=dev-libs/boost-1.56.0-r1
-       dev-libs/tinyxml
-       dev-qt/qtcore:5
-       dev-qt/qtgui:5
-       media-libs/freetype:2
-       media-libs/libsdl2[joystick,opengl,X,video]
-       || ( media-libs/libtxc_dxtn x11-drivers/ati-drivers x11-drivers/nvidia-drivers )
-       media-libs/openal
-       >=sci-physics/bullet-2.80
-       virtual/ffmpeg
-       virtual/opengl
-       devtools? ( dev-qt/qtxmlpatterns:5 )"
-DEPEND="${RDEPEND}
-       virtual/pkgconfig
-       doc? ( app-doc/doxygen media-gfx/graphviz )"
-
-S=${WORKDIR}/${PN}-${P}
-
-src_configure() {
-       local mycmakeargs=(
-               -DBINDIR="/usr/bin"
-               -DBUILD_BSATOOL="$(usex devtools)"
-               -DBUILD_ESMTOOL="$(usex devtools)"
-               -DBUILD_OPENCS="$(usex devtools)"
-               -DBUILD_UNITTESTS=OFF
-               -DDATADIR="/usr/share/${PN}"
-               -DICONDIR="/usr/share/icons/hicolor/256x256/apps"
-               -DLIBDIR="/usr/$(get_libdir)"
-               -DMORROWIND_DATA_FILES="/usr/share/morrowind-data"
-               -DOPENMW_RESOURCE_FILES="/usr/share/${PN}/resources"
-               -DGLOBAL_CONFIG_PATH="/etc"
-               -DUSE_SYSTEM_TINYXML=ON
-               -DDESIRED_QT_VERSION=5
-       )
-
-       cmake-utils_src_configure
-}
-
-src_compile() {
-       cmake-utils_src_compile
-
-       if use doc ; then
-               emake -C "${CMAKE_BUILD_DIR}" doc
-               find "${CMAKE_BUILD_DIR}"/docs/Doxygen/html \
-                       -name '*.md5' -type f -delete || die
-       fi
-}
-
-src_install() {
-       cmake-utils_src_install
-       dodoc README.md
-
-       # about 47k files, dodoc seems to have trouble
-       if use doc ; then
-               dodir "/usr/share/doc/${PF}"
-               mv "${CMAKE_BUILD_DIR}"/docs/Doxygen/html \
-                       "${D}/usr/share/doc/${PF}/" || die
-       fi
-}
-
-pkg_preinst() {
-       gnome2_icon_savelist
-}
-
-pkg_postinst() {
-       gnome2_icon_cache_update
-
-       elog "You need the original Morrowind Data files. If you haven't"
-       elog "installed them yet, you can install them straight via the"
-       elog "installation wizard which is the officially"
-       elog "supported method (either by using the launcher or by calling"
-       elog "'openmw-wizard' directly)."
-}
-
-pkg_postrm() {
-       gnome2_icon_cache_update
-}