dev-libs/libsecp256k1: Drop 9999
authorLuke Dashjr <luke-jr+git@utopios.org>
Mon, 30 Sep 2019 04:32:35 +0000 (04:32 +0000)
committerJoonas Niilola <juippis@gentoo.org>
Sun, 13 Oct 2019 11:21:57 +0000 (14:21 +0300)
Signed-off-by: Luke Dashjr <luke-jr+git@utopios.org>
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
dev-libs/libsecp256k1/libsecp256k1-9999.ebuild [deleted file]

diff --git a/dev-libs/libsecp256k1/libsecp256k1-9999.ebuild b/dev-libs/libsecp256k1/libsecp256k1-9999.ebuild
deleted file mode 100644 (file)
index f1a5daa..0000000
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-EGIT_REPO_URI="https://github.com/bitcoin/secp256k1.git"
-inherit git-2 autotools eutils
-
-MyPN=secp256k1
-DESCRIPTION="Optimized C library for EC operations on curve secp256k1"
-HOMEPAGE="https://github.com/bitcoin/${MyPN}"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS=""
-IUSE="+asm ecdh endomorphism experimental gmp java +recovery test test_openssl"
-
-REQUIRED_USE="
-       asm? ( || ( amd64 arm ) arm? ( experimental ) )
-       ecdh? ( experimental )
-       java? ( ecdh )
-       test_openssl? ( test )
-"
-RDEPEND="
-       gmp? ( dev-libs/gmp:0= )
-"
-DEPEND="${RDEPEND}
-       virtual/pkgconfig
-       java? ( virtual/jdk )
-       test_openssl? ( dev-libs/openssl:0 )
-"
-
-src_prepare() {
-       eautoreconf
-}
-
-src_configure() {
-       local asm_opt
-       if use asm; then
-               if use arm; then
-                       asm_opt=arm
-               else
-                       asm_opt=auto
-               fi
-       else
-               asm_opt=no
-       fi
-       econf \
-               --disable-benchmark \
-               $(use_enable experimental) \
-               $(use_enable java jni) \
-               $(use_enable test tests) \
-               $(use_enable test_openssl openssl-tests) \
-               $(use_enable ecdh module-ecdh) \
-               $(use_enable endomorphism)  \
-               --with-asm=$asm_opt \
-               --with-bignum=$(usex gmp gmp no) \
-               $(use_enable recovery module-recovery) \
-               --disable-static
-}
-
-src_install() {
-       dodoc README.md
-       emake DESTDIR="${D}" install
-       prune_libtool_files
-}