sys-devel/libtool: sync changes into live ebuild
authorMike Frysinger <vapier@gentoo.org>
Tue, 21 Feb 2017 22:37:48 +0000 (17:37 -0500)
committerMike Frysinger <vapier@gentoo.org>
Tue, 21 Feb 2017 22:45:17 +0000 (17:45 -0500)
sys-devel/libtool/libtool-9999.ebuild

index e46a9feace7d397f6db68c20f83155f047a4c601..22a5d3c10437cb1b72be1123cb5da5a8030b65d7 100644 (file)
@@ -1,8 +1,7 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Id$
 
-EAPI=5
+EAPI="5"
 
 LIBTOOLIZE="true" #225559
 WANT_LIBTOOL="none"
@@ -27,7 +26,8 @@ IUSE="vanilla"
 # Pull in libltdl directly until we convert packages to the new dep.
 RDEPEND="sys-devel/gnuconfig
        >=sys-devel/autoconf-2.69
-       >=sys-devel/automake-1.13"
+       >=sys-devel/automake-1.13
+       dev-libs/libltdl:0"
 DEPEND="${RDEPEND}
        app-arch/xz-utils"
 [[ ${PV} == "9999" ]] && DEPEND+=" sys-apps/help2man"
@@ -65,6 +65,10 @@ src_configure() {
        # cause problems for people who switch /bin/sh on the fly to other
        # shells, so just force libtool to use /bin/bash all the time.
        export CONFIG_SHELL=/bin/bash
+
+       # Do not bother hardcoding the full path to sed.  Just rely on $PATH. #574550
+       export ac_cv_path_SED=$(basename "$(type -P sed)")
+
        ECONF_SOURCE=${S} econf --disable-ltdl-install
 }