net-dns/dnscrypt-proxy: version bump to 2.0.12
authorGeorgy Yakovlev <ya@sysdump.net>
Fri, 11 May 2018 02:38:11 +0000 (19:38 -0700)
committerMichał Górny <mgorny@gentoo.org>
Fri, 11 May 2018 09:24:46 +0000 (11:24 +0200)
Package-Manager: Portage-2.3.36, Repoman-2.3.9

net-dns/dnscrypt-proxy/Manifest
net-dns/dnscrypt-proxy/dnscrypt-proxy-2.0.12.ebuild [new file with mode: 0644]
net-dns/dnscrypt-proxy/files/dnscrypt-proxy-2.confd [new file with mode: 0644]
net-dns/dnscrypt-proxy/files/dnscrypt-proxy-2.initd [new file with mode: 0644]
net-dns/dnscrypt-proxy/files/dnscrypt-proxy-2.service [new file with mode: 0644]
net-dns/dnscrypt-proxy/files/dnscrypt-proxy-2.socket [new file with mode: 0644]

index 21c7549a544f3da567a82b3c573aa462fc0e207c..fca34637fe1ea0d03251c55607ec1400bf4e3d11 100644 (file)
@@ -1,2 +1,3 @@
 DIST dnscrypt-proxy-1.9.5.tar.bz2 1290573 BLAKE2B 8f16fdb58012e00a8b58d36364377c3bc25158b9484a8df2bd6bc98d1c9cbf5ac758997e31f95ecaeb9da2f6b7272316c5a4a1c069a39549fbc1c1b136857da0 SHA512 84c0f7587521b3a198292cf20dd71cb592ccf8a9e003abbc62c5ca112f6c5ed27c49b1642cf91f403d52b4147e25f24af540b65cecfcf93814338329097df836
 DIST dnscrypt-proxy-2.0.11.tar.gz 2774458 BLAKE2B 36c9109a682a0d70c32910a44a64f49ebf0a958660154c10bf3687da3fdaa405e8add43717267f30a79d96941160cda5994704060a78e2ee6bbeddc55ff87766 SHA512 5e306c3bff65d0375b650666e2191c6f54e72bb0d2d2f6f8f7b941ffc063eb7eb244a52eb69b0b008dc566e9a6ce8a8f75929edb6762fad4751d966aa2da98a0
+DIST dnscrypt-proxy-2.0.12.tar.gz 2775112 BLAKE2B c3a1085c7c4d005d323d2d3e803b7bce447b86a8f2e9bff0eb7e5e145d275dd19fe6913c805be9469ba0a492f7a479a146af56a769432d8120790375628bb936 SHA512 757a7a88e8f6ed61462736184f0ca8426c40f800f54727881412de44c527e4334a6b42aa6906c19ecf9287d462a1ec7bd55cb471781bd94c2a0faa8ad7055137
diff --git a/net-dns/dnscrypt-proxy/dnscrypt-proxy-2.0.12.ebuild b/net-dns/dnscrypt-proxy/dnscrypt-proxy-2.0.12.ebuild
new file mode 100644 (file)
index 0000000..0b64d8b
--- /dev/null
@@ -0,0 +1,97 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+EGO_PN="github.com/jedisct1/${PN}"
+
+inherit fcaps golang-build systemd user
+
+DESCRIPTION="A flexible DNS proxy, with support for encrypted DNS protocols"
+HOMEPAGE="https://github.com/jedisct1/dnscrypt-proxy"
+SRC_URI="https://${EGO_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+
+FILECAPS=( cap_net_bind_service+ep usr/bin/dnscrypt-proxy )
+PATCHES=( "${FILESDIR}"/config-full-paths-r10.patch )
+
+pkg_setup() {
+       enewgroup dnscrypt-proxy
+       enewuser dnscrypt-proxy -1 -1 /var/empty dnscrypt-proxy
+}
+
+src_prepare() {
+       default
+       # Create directory structure suitable for building
+       mkdir -p "src/${EGO_PN%/*}" || die
+       mv "${PN}" "src/${EGO_PN}" || die
+       mv "vendor" "src/" || die
+}
+
+src_install() {
+       dobin dnscrypt-proxy
+
+       insinto /etc/dnscrypt-proxy
+       newins "src/${EGO_PN}"/example-dnscrypt-proxy.toml dnscrypt-proxy.toml
+       doins "src/${EGO_PN}"/example-{blacklist.txt,whitelist.txt}
+       doins "src/${EGO_PN}"/example-{cloaking-rules.txt,forwarding-rules.txt}
+
+       insinto "/usr/share/dnscrypt-proxy"
+       doins -r "utils/generate-domains-blacklists/."
+
+       newinitd "${FILESDIR}"/dnscrypt-proxy-2.initd dnscrypt-proxy
+       newconfd "${FILESDIR}"/dnscrypt-proxy-2.confd dnscrypt-proxy
+       systemd_newunit "${FILESDIR}"/dnscrypt-proxy-2.service dnscrypt-proxy.service
+       systemd_newunit "${FILESDIR}"/dnscrypt-proxy-2.socket dnscrypt-proxy.socket
+
+       einstalldocs
+}
+
+pkg_postinst() {
+       fcaps_pkg_postinst
+
+       if ! use filecaps; then
+               ewarn "'filecaps' USE flag is disabled"
+               ewarn "${PN} will fail to listen on port 53"
+               ewarn "please do one the following:"
+               ewarn "1) re-enable 'filecaps'"
+               ewarn "2) change port to > 1024"
+               ewarn "3) configure to run ${PN} as root (not recommended)"
+               ewarn
+       fi
+
+       local v
+       for v in ${REPLACING_VERSIONS}; do
+               if [[ ${v} == 1.* ]] ; then
+                       elog "Version 2 is a complete rewrite of ${PN}"
+                       elog "please clean up old config/log files"
+                       elog
+               fi
+               if [[ ${v} == 2.* ]] ; then
+                       elog "As of version 2.0.12 of ${PN} runs as an 'dnscrypt-proxy' user/group"
+                       elog "you can remove obsolete 'dnscrypt' accounts from the system"
+                       elog
+               fi
+       done
+
+       if systemd_is_booted || has_version sys-apps/systemd; then
+               elog "Using systemd socket activation may cause issues with speed"
+               elog "latency and reliability of ${PN} and is discouraged by upstream"
+               elog "Existing installations advised to disable 'dnscrypt-proxy.socket'"
+               elog "It is disabled by default for new installations"
+               elog "check "$(systemd_get_systemunitdir)/${PN}.service" for details"
+               elog
+
+       fi
+
+       elog "After starting the service you will need to update your"
+       elog "/etc/resolv.conf and replace your current set of resolvers"
+       elog "with:"
+       elog
+       elog "nameserver 127.0.0.1"
+       elog
+       elog "Also see https://github.com/jedisct1/${PN}/wiki"
+}
diff --git a/net-dns/dnscrypt-proxy/files/dnscrypt-proxy-2.confd b/net-dns/dnscrypt-proxy/files/dnscrypt-proxy-2.confd
new file mode 100644 (file)
index 0000000..fb40827
--- /dev/null
@@ -0,0 +1,3 @@
+#DNSCRYPT_PROXY_OPTS="--config /etc/dnscrypt-proxy/dnscrypt-proxy.toml"
+#DNSCRYPT_PROXY_USER="dnscrypt-proxy"
+#DNSCRYPT_PROXY_GROUP="dnscrypt-proxy"
diff --git a/net-dns/dnscrypt-proxy/files/dnscrypt-proxy-2.initd b/net-dns/dnscrypt-proxy/files/dnscrypt-proxy-2.initd
new file mode 100644 (file)
index 0000000..74c2dad
--- /dev/null
@@ -0,0 +1,19 @@
+#!/sbin/openrc-run
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+command="/usr/bin/dnscrypt-proxy"
+command_args="${DNSCRYPT_PROXY_OPTS:--config /etc/dnscrypt-proxy/dnscrypt-proxy.toml}"
+command_user="${DNSCRYPT_PROXY_USER:-dnscrypt-proxy}:${DNSCRYPT_PROXY_GROUP:-dnscrypt-proxy}"
+pidfile="/run/${RC_SVCNAME}.pid"
+start_stop_daemon_args="--background --make-pidfile"
+
+depend() {
+       use net logger
+       provide dns
+}
+
+start_pre() {
+        checkpath -q -d -m 0775 -o "${command_user}" /var/cache/"${SVCNAME}"
+        checkpath -q -d -m 0775 -o "${command_user}" /var/log/"${SVCNAME}"
+}
diff --git a/net-dns/dnscrypt-proxy/files/dnscrypt-proxy-2.service b/net-dns/dnscrypt-proxy/files/dnscrypt-proxy-2.service
new file mode 100644 (file)
index 0000000..ed02955
--- /dev/null
@@ -0,0 +1,39 @@
+[Unit]
+Description=DNSCrypt-proxy client
+Documentation=https://github.com/jedisct1/dnscrypt-proxy/wiki
+
+## systemd sockets - Do not enable unless you are very familiar with the systemd socket activation mechanism.
+## Always try without systemd sockets before reporting any issues related to speed, latency or reliability.
+## If you enable this, the `listen_addresses` list in the main configuration file can be empty.
+## Or, at least, the addresses it contains should not overlap with the systemd socket addresses.
+
+# Requires=dnscrypt-proxy.socket
+
+After=network.target
+Wants=network.target
+Before=nss-lookup.target
+Wants=nss-lookup.target
+
+[Service]
+ExecStart=/usr/bin/dnscrypt-proxy --config /etc/dnscrypt-proxy/dnscrypt-proxy.toml
+NonBlocking=true
+
+DynamicUser=yes
+
+ProtectControlGroups=yes
+ProtectKernelModules=yes
+ProtectKernelTunables=yes
+
+CacheDirectory=dnscrypt-proxy
+ConfigurationDirectory=dnscrypt-proxy
+LogsDirectory=dnscrypt-proxy
+RuntimeDirectory=dnscrypt-proxy
+
+## Allow binding to 127.0.0.1:53 as non-root user
+## without the .socket unit
+CapabilityBoundingSet=CAP_NET_BIND_SERVICE
+AmbientCapabilities=CAP_NET_BIND_SERVICE
+
+[Install]
+Also=dnscrypt-proxy.socket
+WantedBy=multi-user.target
diff --git a/net-dns/dnscrypt-proxy/files/dnscrypt-proxy-2.socket b/net-dns/dnscrypt-proxy/files/dnscrypt-proxy-2.socket
new file mode 100644 (file)
index 0000000..ea38c90
--- /dev/null
@@ -0,0 +1,21 @@
+[Unit]
+Description=DNSCrypt-proxy socket
+Documentation=https://github.com/jedisct1/dnscrypt-proxy/wiki
+
+[Socket]
+## Listen on TCP socket.
+ListenStream=127.0.0.1:53
+
+## Listen on UDP socket.
+ListenDatagram=127.0.0.1:53
+
+## Below options are valid only for TCP socket.
+## Applying them to UDP socket will result in warnings:
+## TCP_NODELAY failed: Protocol not available
+## TCP_DEFER_ACCEPT failed: Protocol not available
+## Those can be safely ignored.
+NoDelay=true
+DeferAcceptSec=1
+
+[Install]
+WantedBy=sockets.target