media-libs/sratom: bump 0.6.4
authorMiroslav Šulc <fordfrog@gentoo.org>
Thu, 19 Dec 2019 17:34:23 +0000 (18:34 +0100)
committerMiroslav Šulc <fordfrog@gentoo.org>
Thu, 19 Dec 2019 17:34:47 +0000 (18:34 +0100)
1) dropped python 2_7 and 3_5, added 3_{6,7,8}
2) updated deps

Package-Manager: Portage-2.3.82, Repoman-2.3.20
Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
media-libs/sratom/Manifest
media-libs/sratom/sratom-0.6.4.ebuild [new file with mode: 0644]

index 571e6b71fe3f89f5b39a7e428d8ebb627850f4f6..071ebd28db82b585eca3c8f1240242b3686e8e77 100644 (file)
@@ -1 +1,2 @@
 DIST sratom-0.6.0.tar.bz2 149340 BLAKE2B c661e0c4fba0cdf6cfb8a7dba90ff92135422557a0721bc394c7500853aeb9370554df8a02b7faea2fa222b96db36b20b265cc1fa50e6e06655946dbe992f815 SHA512 899bb01896e2b65b69482041c7e06edc9e45e9a3466392c82a58f16dfc71462a6c3e3e16a5aa50a6347c8366ea72898468910a59a084762f75eb8c7031ceacf8
+DIST sratom-0.6.4.tar.bz2 339707 BLAKE2B acf29c7dd3c4e23bf20ef2811706abdd3543d0fc380183f7f419932c3178ff5e2f6d95c57bad2ef991dbc1e32c6e8a3645238c7b42dfd204942dbc4c05270652 SHA512 6462d8d33ed7ddaa2aea267fab14c9a15bfc077a4f8d26eb493be4c48c95d8dcec614f540bd82fe22aecca641771326a44d175c3991cd473ae371062c78aaac3
diff --git a/media-libs/sratom/sratom-0.6.4.ebuild b/media-libs/sratom/sratom-0.6.4.ebuild
new file mode 100644 (file)
index 0000000..53a13bb
--- /dev/null
@@ -0,0 +1,56 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_REQ_USE='threads(+)'
+inherit python-any-r1 waf-utils multilib-build multilib-minimal
+
+DESCRIPTION="Library for serialising LV2 atoms to/from RDF, particularly the Turtle syntax"
+HOMEPAGE="http://drobilla.net/software/sratom/"
+SRC_URI="http://download.drobilla.net/${P}.tar.bz2"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc static-libs test"
+RESTRICT="!test? ( test )"
+
+RDEPEND=">=media-libs/lv2-1.16.0
+       >=dev-libs/serd-0.30.0
+       >=dev-libs/sord-0.14.0"
+DEPEND="${RDEPEND}
+       ${PYTHON_DEPS}
+       doc? ( app-doc/doxygen )
+       virtual/pkgconfig"
+
+DOCS=( "NEWS" "README.md" )
+
+src_prepare() {
+       sed -i -e 's/^.*run_ldconfig/#\0/' wscript || die
+       default
+       multilib_copy_sources
+}
+
+multilib_src_configure() {
+       waf-utils_src_configure \
+               --docdir=/usr/share/doc/${PF} \
+               $(multilib_native_usex doc --docs "") \
+               $(usex test --test "") \
+               $(usex static-libs --static "")
+}
+
+multilib_src_test() {
+       ./waf test || die
+}
+
+multilib_src_compile() {
+       waf-utils_src_compile
+       default
+}
+
+multilib_src_install() {
+       waf-utils_src_install
+       default
+}