net-misc/teamviewer: Version bump (v14.5.5819)
authorMikle Kolyada <zlogene@gentoo.org>
Sun, 15 Sep 2019 20:38:53 +0000 (23:38 +0300)
committerMikle Kolyada <zlogene@gentoo.org>
Sun, 15 Sep 2019 20:39:25 +0000 (23:39 +0300)
Package-Manager: Portage-2.3.69, Repoman-2.3.16
Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
net-misc/teamviewer/Manifest
net-misc/teamviewer/teamviewer-14.5.5819.ebuild [new file with mode: 0644]

index fdc9a4233b2b9f89a4cd786dbf98d523e6c2de29..11ec80da059d4cbec804b9b9bea3b773e759ccee 100644 (file)
@@ -4,3 +4,5 @@ DIST teamviewer_14.2.8352_amd64.tar.xz 12000972 BLAKE2B 29c0222f940eea66a7dbcf38
 DIST teamviewer_14.2.8352_i386.tar.xz 12469004 BLAKE2B 3aee7371b200ca1e599c7981b4ca725a9376b90bfb60ec66e7d93c658d5e69e77aab72d81f12d063c5b75a626c9fd7e8d9d1a9582b5fe19e86f769efb557bb0a SHA512 e391b7f8d9168dcf29146f6466693baa81b5e7956cc515e2d0301ced9055bfc67dc16b2d011ea3824fcc548d0d625a1cab574fafdae5ac61c9a37982be29d03b
 DIST teamviewer_14.4.2669_amd64.tar.xz 12237660 BLAKE2B d3c1638645720748fed6f8e588e59211e54625548b0c0a45316f2c51bf7560d6853fdfd86fdb1468a33ef75e1454c24c0afa2eccbec5a7a7848071edaa6b27ee SHA512 3a371538aaeb128156542b00a051e0db9ea20830a5dd666b7b2f5d239529d639407dbd520828b27d37f80d8fa06a9d09cfc1738357ac86df1e8f9fe7188dfd6a
 DIST teamviewer_14.4.2669_i386.tar.xz 12726704 BLAKE2B e8ab743646448488fc39ea9979e52a49c42e941cb173e89257dfcd3544dc2709a763d6c552c269c1559b3a7ccdf83265e30e06d06cebe8dcfca6dfe8a591791c SHA512 bbd6d48d1c70941d468c793bdede3b0a1aebbc7fd433c55be327f56cfd53435ffaebdd845ee595820dcce41d94f8a3fe9de00d2908901c4501ff61e34ad9349c
+DIST teamviewer_14.5.5819_amd64.tar.xz 12386480 BLAKE2B 2d5c11c811f10f3fd4a55e5ecbb010964b6317f9a813f73e543bf7c5be7cbd5b9c1e89a5f5ab1865a2e25eadc3e15c80485b725315019831b76ace3340df8dec SHA512 28a2733f8131fd9943ddc78166058939cf9a8682053153c3f7ccd64ff39feed8c9199adf93f5b96432d6e87f13067fdd649cce2a0af383d87f2adc0e223e20cb
+DIST teamviewer_14.5.5819_i386.tar.xz 12883512 BLAKE2B d7f5749a5e53ec3f6921c55c3d4256f00e9f8b67fddbae6d08fffc1f364850274c80df7578a90444cea092d553f535491a02d82fc21adaa850700ec2d60b2d70 SHA512 ed7e4be50c32fae14845317f59465c5052693e49cd32ed60f7106b718a3ab05df2a8a040d2daccffed45e05cf7f61553a9767e478b826f3e2895e8236f20d938
diff --git a/net-misc/teamviewer/teamviewer-14.5.5819.ebuild b/net-misc/teamviewer/teamviewer-14.5.5819.ebuild
new file mode 100644 (file)
index 0000000..6650185
--- /dev/null
@@ -0,0 +1,136 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_PN=${PN}${PV/\.*}
+inherit desktop gnome2-utils systemd
+
+DESCRIPTION="All-In-One Solution for Remote Access and Support over the Internet"
+HOMEPAGE="https://www.teamviewer.com"
+SRC_URI="amd64? ( https://dl.tvcdn.de/download/linux/version_${PV/\.*}x/${PN}_${PV}_amd64.tar.xz )
+               x86? ( https://dl.tvcdn.de/download/linux/version_${PV/\.*}x/${PN}_${PV}_i386.tar.xz )"
+
+LICENSE="TeamViewer MIT"
+SLOT="${PV/\.*}"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+
+DEPEND="sys-apps/sed"
+RDEPEND="
+       dev-qt/qtcore:5
+       dev-qt/qtdbus:5
+       dev-qt/qtdeclarative:5
+       dev-qt/qtgui:5
+       dev-qt/qtnetwork:5
+       dev-qt/qtquickcontrols:5
+       dev-qt/qtwebkit:5
+       dev-qt/qtwidgets:5
+       dev-qt/qtx11extras:5
+       sys-apps/dbus
+       !sys-auth/consolekit
+"
+
+# For consolekit incompatibility see https://forums.gentoo.org/viewtopic-p-8332956.html?sid=3cc21e5a27935e38975ee85bf03317ae#8332956
+
+RESTRICT="bindist mirror"
+
+# Silence QA messages
+QA_PREBUILT="opt/${MY_PN}/*"
+
+S="${WORKDIR}"/teamviewer
+
+src_prepare() {
+       default
+
+       # Switch operation mode from 'portable' to 'installed'
+       sed -e "s/TAR_NI/TAR_IN/g" -i tv_bin/script/tvw_config || die
+
+       sed -e "/^ExecStart/s/${PN}/${MY_PN}/" \
+               -i tv_bin/script/teamviewerd.service || die
+}
+
+src_install() {
+       local dst="/opt/${MY_PN}" # install destination
+
+       # Quirk:
+       # Remove Intel 80386 32-bit ELF binary 'libdepend' present in all
+       # archives. It will trip the 'emerge @preserved-libs' logic on amd64
+       # when changing the ABI of one of its dependencies. According to the
+       # TeamViewer devs, this binary is an unused remnant of previous Wine-
+       # based builds and will be removed in future releases anyway
+       rm tv_bin/script/libdepend
+
+       insinto ${dst}
+       doins -r tv_bin
+
+       # Set permissions for executables and libraries
+       for exe in $(find tv_bin -type f -executable -or -name '*.so'); do
+               fperms 755 ${dst}/${exe}
+       done
+
+       # No slotting here, binary expects this service path
+       newinitd "${FILESDIR}"/teamviewerd14.init teamviewerd
+       systemd_dounit tv_bin/script/teamviewerd.service
+
+       insinto /usr/share/dbus-1/services
+       doins tv_bin/script/com.teamviewer.TeamViewer.service
+       doins tv_bin/script/com.teamviewer.TeamViewer.Desktop.service
+
+       insinto /usr/share/polkit-1/actions
+       doins tv_bin/script/com.teamviewer.TeamViewer.policy
+
+       for size in 16 24 32 48 256; do
+               newicon -s ${size} tv_bin/desktop/teamviewer_${size}.png TeamViewer.png
+       done
+
+       # Install documents (NOTE: using 'dodoc -r doc' instead of loop will
+       # have the undesired result of installing subdirectory 'doc' in /usr/
+       # share/doc/teamviewer-<version>)
+       for doc in $(find doc -type f); do
+               dodoc ${doc}
+       done
+
+       keepdir /etc/${MY_PN}
+       dosym ../../etc/${MY_PN} ${dst}/config
+
+       # Create directory and symlink for log files (NOTE: according to Team-
+       # Viewer devs, all paths are hard-coded in the binaries; therefore
+       # using the same path as the DEB/RPM archives, i.e. '/var/log/teamviewer
+       # <major-version>')
+       keepdir /var/log/${MY_PN}
+       dosym ../../var/log/${MY_PN} ${dst}/logfiles
+
+       dodir /opt/bin
+       dosym ${dst}/tv_bin/teamviewerd /opt/bin/teamviewerd
+       dosym ${dst}/tv_bin/script/teamviewer /opt/bin/teamviewer
+
+       make_desktop_entry teamviewer "TeamViewer ${SLOT}" TeamViewer
+}
+
+pkg_postinst() {
+       gnome2_icon_cache_update
+
+       elog "Please note that parallel installation of multiple versions of"
+       elog "TeamViewer is currently not supported at runtime. Bug #621818"
+       elog ""
+       elog "Before using TeamViewer, you need to start its daemon:"
+       elog "OpenRC:"
+       elog "# /etc/init.d/teamviewerd start"
+       elog "# rc-update add teamviewerd default"
+       elog
+       elog "Systemd:"
+       elog "# systemctl start teamviewerd.service"
+       elog "# systemctl enable teamviewerd.service"
+       elog
+       elog "To display additional command line options simply run:"
+       elog "$ teamviewer help"
+       elog
+       elog "Most likely TeamViewer will work normally only on systems with systemd"
+       elog "or elogind. See this thread for additional info:"
+       elog "https://forums.gentoo.org/viewtopic-p-8332956.html?sid=3cc21e5a27935e38975ee85bf03317ae#8332956"
+}
+
+pkg_postrm() {
+       gnome2_icon_cache_update
+}