sys-block/mbuffer: bump to v20200505
authorThomas Deutschmann <whissi@gentoo.org>
Tue, 19 May 2020 09:47:03 +0000 (11:47 +0200)
committerThomas Deutschmann <whissi@gentoo.org>
Tue, 19 May 2020 09:49:06 +0000 (11:49 +0200)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
sys-block/mbuffer/Manifest
sys-block/mbuffer/mbuffer-20200505.ebuild [new file with mode: 0644]

index dcd5a163036e26b4432fac9596a54176c0728f57..07f2b7970ba63f7940bcd1b0d0b4db4c559ce03b 100644 (file)
@@ -1 +1,2 @@
 DIST mbuffer-20191016.tgz 145508 BLAKE2B d69600544fc0ed9e619f07f552a5369aed24f8a93588edd2a205613bdf5ebd5c636cda24702149bf7a82605c9a956408b56555c1577eb83c8f8ca0eb49c5c14c SHA512 78142a3f1529609b12151aafe848ad768a6074f4891bedaa52cc46ffa14350a2a8c0362d02621fa227bda54e98eabc4970c00838114574540873b426fbfe97a5
+DIST mbuffer-20200505.tgz 146020 BLAKE2B b85742f710405e29775c7d25e9c1be733fd94d7157018017b7c8fb5b5cdeab7fa8819b024d297d96af960a73a8982fdeaefe50627c605f797df4d75b0c15435f SHA512 8a1e5721869fd705d02486cf93467bfe0a59b58789826ca337c18a023e9fbb18c1651211bfebdea4cdd45772ad23d0715bb3892bed04ce66f5fbe72406cde9f7
diff --git a/sys-block/mbuffer/mbuffer-20200505.ebuild b/sys-block/mbuffer/mbuffer-20200505.ebuild
new file mode 100644 (file)
index 0000000..5dd75f3
--- /dev/null
@@ -0,0 +1,67 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="M(easuring)buffer is a replacement for buffer with additional functionality"
+HOMEPAGE="https://www.maier-komor.de/mbuffer.html"
+SRC_URI="https://www.maier-komor.de/software/mbuffer/${P}.tgz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
+IUSE="debug ssl test"
+
+REQUIRED_USE="test? ( ssl )"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="ssl? ( dev-libs/openssl:0= )"
+DEPEND="${RDEPEND}
+       test? ( dev-libs/openssl:0 )"
+
+PATCHES=(
+       "${FILESDIR}/${PN}-20180410-sysconfdir.patch"
+)
+
+src_prepare() {
+       ln -s "${DISTDIR}"/${P}.tgz test.tar #258881
+
+       # Enforce MAKEOPTS=-j1 because src_test() spawns multiple listener
+       # using same port and src_install may have problems (with /etc folder)
+       export MAKEOPTS=-j1
+
+       default
+
+       mv configure.in configure.ac || die
+
+       eautoreconf
+}
+
+src_configure() {
+       local myeconfargs=(
+               $(use_enable ssl md5)
+               $(use_enable debug)
+       )
+       econf "${myeconfargs[@]}"
+}
+
+src_test() {
+       if has usersandbox ${FEATURES} || has network-sandbox ${FEATURES}; then
+               ewarn "Some tests may fail with FEATURES=usersandbox or"
+               ewarn "FEATURES=network-sandbox; Skipping tests because"
+               ewarn "test suite would hang forever in such environments!"
+               return 0;
+       fi
+
+       default
+}
+
+pkg_postinst() {
+       if ! has_version "app-arch/mt-st"; then
+               elog ""
+               elog "If you want autoloader support you need to install \"app-arch/mt-st\" in addition!"
+       fi
+}