Revbump, generate emacs autoloads.
authorUlrich Müller <ulm@gentoo.org>
Mon, 16 Apr 2007 18:36:09 +0000 (18:36 +0000)
committerUlrich Müller <ulm@gentoo.org>
Mon, 16 Apr 2007 18:36:09 +0000 (18:36 +0000)
Package-Manager: portage-2.1.2.4

app-emacs/table/ChangeLog
app-emacs/table/files/51table-gentoo.el [new file with mode: 0644]
app-emacs/table/files/digest-table-1.5.54-r1 [new file with mode: 0644]
app-emacs/table/table-1.5.54-r1.ebuild [new file with mode: 0644]

index 1918f7e7d1f8f9c951ed6081d6f736696907ac3a..f8059ca17ea21a78eb9e9b7c875e371739ed8460 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for app-emacs/table
 # Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/table/ChangeLog,v 1.12 2007/03/08 09:45:41 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/table/ChangeLog,v 1.13 2007/04/16 18:36:09 ulm Exp $
+
+*table-1.5.54-r1 (16 Apr 2007)
+
+  16 Apr 2007; Ulrich Mueller <ulm@gentoo.org> +files/51table-gentoo.el,
+  +table-1.5.54-r1.ebuild:
+  Generate autoload file for package initialisation.
 
   08 Mar 2007; Christian Faulhammer <opfer@gentoo.org>
   files/50table-gentoo.el:
diff --git a/app-emacs/table/files/51table-gentoo.el b/app-emacs/table/files/51table-gentoo.el
new file mode 100644 (file)
index 0000000..7eeb2fc
--- /dev/null
@@ -0,0 +1,6 @@
+
+;;; table site-lisp configuration
+
+(add-to-list 'load-path "@SITELISP@")
+(load "table-autoloads" nil t)
+(add-hook 'text-mode-hook 'table-recognize)
diff --git a/app-emacs/table/files/digest-table-1.5.54-r1 b/app-emacs/table/files/digest-table-1.5.54-r1
new file mode 100644 (file)
index 0000000..5624fb3
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 bf610808fa37ec0c6393e841d99defd9 table-1.5.54.el.gz 58136
+RMD160 da7312476e92bc298fc997f7940910a924507f8c table-1.5.54.el.gz 58136
+SHA256 af7f3337e1dc517bcb9f5683103d5e32a34dcf311f1187a02660fc3642089cba table-1.5.54.el.gz 58136
diff --git a/app-emacs/table/table-1.5.54-r1.ebuild b/app-emacs/table/table-1.5.54-r1.ebuild
new file mode 100644 (file)
index 0000000..fbf32f3
--- /dev/null
@@ -0,0 +1,22 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/table/table-1.5.54-r1.ebuild,v 1.1 2007/04/16 18:36:09 ulm Exp $
+
+inherit elisp
+
+DESCRIPTION="Table editor for Emacs"
+HOMEPAGE="http://table.sourceforge.net/"
+SRC_URI="mirror://sourceforge/table/${P}.el.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+SITEFILE=51${PN}-gentoo.el
+SIMPLE_ELISP=t
+
+src_compile() {
+       elisp-compile *.el || die "elisp-compile failed"
+       elisp-make-autoload-file || die "elisp-make-autoload-file failed"
+}