dev-java/eclipse.ecj: 4.13 changed to have source/target 1.8
authorMiroslav Šulc <fordfrog@gentoo.org>
Thu, 27 Feb 2020 20:00:30 +0000 (21:00 +0100)
committerMiroslav Šulc <fordfrog@gentoo.org>
Thu, 27 Feb 2020 20:01:23 +0000 (21:01 +0100)
it still needs jdk 11 to compile but the source and target used
is 1.8 now so it can be used even with packages that still need
to compile using jdk 1.8

Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
dev-java/eclipse-ecj/eclipse-ecj-4.13-r1.ebuild [moved from dev-java/eclipse-ecj/eclipse-ecj-4.13.ebuild with 93% similarity]

similarity index 93%
rename from dev-java/eclipse-ecj/eclipse-ecj-4.13.ebuild
rename to dev-java/eclipse-ecj/eclipse-ecj-4.13-r1.ebuild
index 395198f56fedb641163d8748c634fb1441563f3f..2915e3077405443673aadd0308e7770e5a67781b 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
@@ -23,13 +23,15 @@ COMMON_DEP="
        app-eselect/eselect-java
        dev-java/ant-core:0"
 RDEPEND="${COMMON_DEP}
-       >=virtual/jre-11"
+       >=virtual/jre-8"
 DEPEND="${COMMON_DEP}
        >=virtual/jdk-11
        app-arch/unzip"
 PDEPEND="
        ant? ( ~dev-java/ant-eclipse-ecj-${PV} )"
 
+JAVA_PKG_WANT_SOURCE="1.8"
+JAVA_PKG_WANT_TARGET="1.8"
 JAVA_JAR_FILENAME="${MY_PN}.jar"
 JAVA_GENTOO_CLASSPATH="ant-core"