app-portage/unsymlink-lib: Bump to v2
authorMichał Górny <mgorny@gentoo.org>
Fri, 8 Dec 2017 18:00:17 +0000 (19:00 +0100)
committerMichał Górny <mgorny@gentoo.org>
Fri, 8 Dec 2017 18:04:21 +0000 (19:04 +0100)
app-portage/unsymlink-lib/Manifest
app-portage/unsymlink-lib/unsymlink-lib-2.ebuild [new file with mode: 0644]

index 61d6c0ffe81025465fa7d71c7376662a782076eb..c3c82ae261f2e8d18db9d1bae40bbb5d62d67d99 100644 (file)
@@ -1 +1,2 @@
 DIST unsymlink-lib-1.tar.gz 6000 BLAKE2B d9263d973ab70ffb77aa8c90f0b4562a8214ae4c9d111cf7a19172b2e62427cbce4a5ffa0a3c020b4a599274d664eaf60967922315f414eed3f9321f3863a736 SHA512 f27640cbcc67ef1ff5a24c8e8d17955eb0cc745465b3ee831d9a06da37c058279311f230846cc350160cfcce1b80e74defedad8ebd59abd2a6d2a59af9c39500
+DIST unsymlink-lib-2.tar.gz 6145 BLAKE2B 52036321e28ee98b8d58d009031091e720c791859bdd43f4c4a5468ad3133a99fe89eeab3dfd23d9e97e928787cde430e45af7fad142cc3383ab896b3397ad56 SHA512 01dc59afd32c503d115ccf86a723bdf000a78d2d5b7b8dc9e5f89c4e0cbea4d7167186206a6e06dc52803e418370e8f7de5e783eae3790704254ab95c3adeb1f
diff --git a/app-portage/unsymlink-lib/unsymlink-lib-2.ebuild b/app-portage/unsymlink-lib/unsymlink-lib-2.ebuild
new file mode 100644 (file)
index 0000000..c5194b9
--- /dev/null
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
+inherit python-single-r1
+
+DESCRIPTION="Convert your system to SYMLINK_LIB=no"
+HOMEPAGE="https://github.com/mgorny/unsymlink-lib"
+SRC_URI="https://github.com/mgorny/unsymlink-lib/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}"
+
+src_install() {
+       python_doscript unsymlink-lib
+       dodoc README
+}