net-libs/libsoup: bump to 2.70.0
authorMart Raudsepp <leio@gentoo.org>
Sun, 5 Apr 2020 13:23:03 +0000 (16:23 +0300)
committerMart Raudsepp <leio@gentoo.org>
Sun, 5 Apr 2020 13:23:13 +0000 (16:23 +0300)
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Mart Raudsepp <leio@gentoo.org>
net-libs/libsoup/Manifest
net-libs/libsoup/libsoup-2.70.0.ebuild [new file with mode: 0644]
net-libs/libsoup/metadata.xml

index 09b9b4d21d9f1ba670d215a2b91fd84997a66694..23d404c7da8ffa6c171202fcd008511b209b245d 100644 (file)
@@ -1,2 +1,3 @@
 DIST libsoup-2.62.3.tar.xz 1851780 BLAKE2B e3a3518f485d4ab1fe133f5b382d32e4b949e720005c4fdbbe963ba68030d5fcfb11deb5103843f47f221b540e96c5d5ea0f7c52f898617dca37d8df9faec669 SHA512 88354728b1da10288472c7380f166263b64d979df3e6e70ebdbc7b61f3c8eb1dc1205d5b1ead16243c6d304940a4dd4e3a9f3b2ce3e1422a1c5032220b16c73b
 DIST libsoup-2.66.4.tar.xz 1451200 BLAKE2B 4ee37592beb9227eb5a61901e4b100b613fef2be512b7c61052a8df17184783e4b6e4e898893d6f63f1fa32b97fac935ad0f4b4d5ae1c56fedd62c0c8f41a8ea SHA512 c1d57c6c5099ac345373409dd3f384dd454e47218cc6bd8be1c6b2de967d7753bfcc3010836f7131f049b1ab9c49318d6ae5203be0bcc0ca5d4b62a0c64f27ad
+DIST libsoup-2.70.0.tar.xz 1494220 BLAKE2B f6bf30c741c7919a31598132ca65c0081d074e7c90d915f3598cb986e1f51f5354538f76dc7117a94d946bd8cd5fe8477ead689f343797757224014932061d28 SHA512 c3e2a963f4b38b2eee5d772b68a325c076fde19c26413bb3ada91824d3c7e108fbc325bfdc49a28141a641233485d3044d18142720c2aebaa7cc820f8718159b
diff --git a/net-libs/libsoup/libsoup-2.70.0.ebuild b/net-libs/libsoup/libsoup-2.70.0.ebuild
new file mode 100644 (file)
index 0000000..2583e79
--- /dev/null
@@ -0,0 +1,100 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+VALA_USE_DEPEND="vapigen"
+
+inherit gnome.org meson multilib-minimal vala xdg
+
+DESCRIPTION="HTTP client/server library for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Projects/libsoup"
+
+LICENSE="LGPL-2.1+"
+SLOT="2.4"
+
+# TODO: Default enable brotli at some point? But in 2.70.0 not advertised to servers yet - https://gitlab.gnome.org/GNOME/libsoup/issues/146
+IUSE="brotli gssapi gtk-doc +introspection samba ssl test +vala"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="vala? ( introspection )"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+
+DEPEND="
+       >=dev-libs/glib-2.58:2[${MULTILIB_USEDEP}]
+       >=dev-db/sqlite-3.8.2:3[${MULTILIB_USEDEP}]
+       >=dev-libs/libxml2-2.9.1-r4:2[${MULTILIB_USEDEP}]
+       brotli? ( >=app-arch/brotli-1.0.6-r1:=[${MULTILIB_USEDEP}] )
+       >=net-libs/libpsl-0.20[${MULTILIB_USEDEP}]
+       sys-libs/zlib
+       gssapi? ( virtual/krb5[${MULTILIB_USEDEP}] )
+       introspection? ( >=dev-libs/gobject-introspection-1.54:= )
+       samba? ( net-fs/samba )
+"
+RDEPEND="${DEPEND}
+       >=net-libs/glib-networking-2.38.2[ssl?,${MULTILIB_USEDEP}]
+"
+BDEPEND="
+       dev-util/glib-utils
+       gtk-doc? ( >=dev-util/gtk-doc-1.20
+               app-text/docbook-xml-dtd:4.1.2 )
+       >=sys-devel/gettext-0.19.8
+       >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]
+       vala? ( $(vala_depend) )
+"
+#      test? ( www-servers/apache[ssl,apache2_modules_auth_digest,apache2_modules_alias,apache2_modules_auth_basic,
+#              apache2_modules_authn_file,apache2_modules_authz_host,apache2_modules_authz_user,apache2_modules_dir,
+#              apache2_modules_mime,apache2_modules_proxy,apache2_modules_proxy_http,apache2_modules_proxy_connect]
+#              dev-lang/php[apache2,xmlrpc]
+#              net-misc/curl
+#              net-libs/glib-networking[ssl])"
+
+PATCHES=(
+       # Disable apache tests until they are usable on Gentoo, bug #326957
+       "${FILESDIR}"/disable-apache-tests.patch
+)
+
+src_prepare() {
+       use vala && vala_src_prepare
+       xdg_src_prepare
+       # https://gitlab.gnome.org/GNOME/libsoup/issues/159 - could work with libnss-myhostname
+       sed -e '/hsts/d' -i tests/meson.build || die
+}
+
+src_configure() {
+       # FIXME: we need addpredict to workaround bug #324779 until
+       # root cause (bug #249496) is solved
+       # But necessary while apache tests are disabled
+       #addpredict /usr/share/snmp/mibs/.index
+
+       multilib-minimal_src_configure
+}
+
+multilib_src_configure() {
+       local emesonargs=(
+               $(meson_feature gssapi)
+               -Dkrb5_config="${CHOST}-krb5-config"
+               $(meson_feature samba ntlm)
+               $(meson_feature brotli)
+               -Dntlm_auth="${EPREFIX}/usr/bin/ntlm_auth"
+               -Dtls_check=false # disables check, we still rdep on glib-networking
+               -Dgnome=false
+               -Dintrospection=$(multilib_native_usex introspection enabled disabled)
+               -Dvapi=$(multilib_native_usex vala enabled disabled)
+               -Dgtk_doc=$(multilib_native_usex gtk-doc true false)
+               $(meson_use test tests)
+               -Dinstalled_tests=false
+       )
+       meson_src_configure
+}
+
+multilib_src_compile() {
+       meson_src_compile
+}
+
+multilib_src_test() {
+       meson_src_test
+}
+
+multilib_src_install() {
+       meson_src_install
+}
index b01383c30263c4ffdc544bf986933dcead6bb97c..7b6e2d422042f2b2baeb988ea85c0c278e85985e 100644 (file)
@@ -6,6 +6,7 @@
                <name>Gentoo GNOME Desktop</name>
        </maintainer>
        <use>
+               <flag name="brotli">Enable brotli decompression support</flag>
                <flag name="gssapi">Enable GSSAPI support</flag>
                <flag name="samba">Use <pkg>net-fs/samba</pkg> for NTLM Single
                        Sign-On</flag>