sci-chemistry/prodecomp: Fix launcher and double Prefix
authorJustin Lecher <jlec@gentoo.org>
Mon, 17 Aug 2015 16:29:16 +0000 (18:29 +0200)
committerJustin Lecher <jlec@gentoo.org>
Mon, 17 Aug 2015 16:29:20 +0000 (18:29 +0200)
Package-Manager: portage-2.2.20.1
Signed-off-by: Justin Lecher <jlec@gentoo.org>
sci-chemistry/prodecomp/prodecomp-3.0-r1.ebuild [moved from sci-chemistry/prodecomp/prodecomp-3.0.ebuild with 83% similarity]

similarity index 83%
rename from sci-chemistry/prodecomp/prodecomp-3.0.ebuild
rename to sci-chemistry/prodecomp/prodecomp-3.0-r1.ebuild
index 28791c9108ba4725987f1b9fdd735567f592aed3..a424245d30bdbc01c61c54e3afed49e4bbb0567b 100644 (file)
@@ -24,6 +24,7 @@ DEPEND=""
 S="${WORKDIR}"/NMRProjAnalys
 
 src_install() {
+       python_export
        if use examples; then
                insinto /usr/share/${PN}
                doins -r ExampleData Results
@@ -38,9 +39,9 @@ src_install() {
 
        cat >> "${T}"/${PN} <<- EOF
        #!/bin/bash
-       ${PYTHON} -O "${EPREFIX}"/$(python_get_sitedir)/${PN}/ProjAnalys.py $@
+       ${PYTHON} -O $(python_get_sitedir)/${PN}/ProjAnalys.py \$@
        EOF
        dobin "${T}"/${PN}
 
-       dosym ../../../../share/doc/${PF}/Manual.pdf $(python_get_sitedir)/${PN}/Manual.pdf
+       dosym ../../../../share/doc/${PF}/Manual.pdf "${PYTHON_SITEDIR##${EPREFIX}}"/${PN}/Manual.pdf
 }