dev-python/onkyo-eiscp: add py38 compat
authorTim Harder <radhermit@gentoo.org>
Wed, 12 Feb 2020 00:40:51 +0000 (17:40 -0700)
committerTim Harder <radhermit@gentoo.org>
Wed, 12 Feb 2020 00:50:06 +0000 (17:50 -0700)
Signed-off-by: Tim Harder <radhermit@gentoo.org>
dev-python/onkyo-eiscp/onkyo-eiscp-1.2.7.ebuild

index de7dad5a90360288bc7da0262a788951fced9f95..629a015b6867ed0758b2bc88e526ef7a5d509565 100644 (file)
@@ -2,7 +2,8 @@
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
-PYTHON_COMPAT=( python3_{6,7} )
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
 
 inherit distutils-r1
 
@@ -15,8 +16,7 @@ SLOT="0"
 KEYWORDS="~amd64 ~x86"
 IUSE=""
 
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-RDEPEND="${DEPEND}
+RDEPEND="
        >=dev-python/docopt-0.4.1[${PYTHON_USEDEP}]
        dev-python/netifaces[${PYTHON_USEDEP}]
 "