dev-util/dmake: Port to EAPI 7
authorDavid Seifert <soap@gentoo.org>
Tue, 18 Feb 2020 19:11:28 +0000 (20:11 +0100)
committerDavid Seifert <soap@gentoo.org>
Tue, 18 Feb 2020 19:11:28 +0000 (20:11 +0100)
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: David Seifert <soap@gentoo.org>
dev-util/dmake/dmake-4.12.2.ebuild

index 9029df2aefed3dd4b924aab7692041749aaab2b9..0f81ca5ffa72359b31dd7b1bc5c5430888bff585 100644 (file)
@@ -1,9 +1,7 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=4
-
-inherit eutils
+EAPI=7
 
 DESCRIPTION="Improved make"
 HOMEPAGE="https://github.com/mohawk2/dmake"
@@ -12,24 +10,23 @@ SRC_URI="http://${PN}.apache-extras.org.codespot.com/files/${P}.tar.bz2"
 LICENSE="GPL-1"
 SLOT="0"
 KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
-IUSE=""
 
 # test failure, reported upstream at
 # https://code.google.com/a/apache-extras.org/p/dmake/issues/detail?id=1
 RESTRICT="test"
 
-DEPEND="
+BDEPEND="
        app-arch/unzip
-       sys-apps/groff
-"
-RDEPEND=""
+       sys-apps/groff"
 
 src_prepare() {
+       default
+
        # make tests executable, bug #404989
        chmod +x tests/targets-{1..12} || die
 }
 
-src_install () {
+src_install() {
        default
        newman man/dmake.tf dmake.1
 }