Fix *initd, *confd and *envd calls (#173884, #174266)
authorTorsten Veller <tove@gentoo.org>
Sat, 28 Apr 2007 22:17:40 +0000 (22:17 +0000)
committerTorsten Veller <tove@gentoo.org>
Sat, 28 Apr 2007 22:17:40 +0000 (22:17 +0000)
Package-Manager: portage-2.1.2.5

dev-db/mysql-init-scripts/mysql-init-scripts-1.2.ebuild
dev-db/pgcluster/ChangeLog
dev-db/pgcluster/pgcluster-1.3.0c.ebuild

index a5711167effcae98e8630a2a8f6df54611803705..a5cb4001779d5449141b1534307d70ca541b7601 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql-init-scripts/mysql-init-scripts-1.2.ebuild,v 1.2 2007/04/28 16:58:36 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql-init-scripts/mysql-init-scripts-1.2.ebuild,v 1.3 2007/04/28 22:14:49 tove Exp $
 
 DESCRIPTION="Gentoo MySQL init scripts."
 HOMEPAGE="http://www.gentoo.org/"
@@ -15,12 +15,11 @@ DEPEND=""
 RDEPEND=""
 
 src_install() {
-       insinto "/etc/conf.d"
-       newins "${FILESDIR}/mysql.conf.d" "mysql"
-       newins "${FILESDIR}/mysqlmanager.conf.d" "mysqlmanager"
+       newconfd "${FILESDIR}/mysql.conf.d" "mysql"
+       newconfd "${FILESDIR}/mysqlmanager.conf.d" "mysqlmanager"
 
        newinitd "${FILESDIR}/mysql.rc6" "mysql"
-       newexe "${FILESDIR}/mysqlmanager.rc6" "mysqlmanager"
+       newinitd "${FILESDIR}/mysqlmanager.rc6" "mysqlmanager"
 
        insinto /etc/logrotate.d
        newins "${FILESDIR}/logrotate.mysql" "mysql"
index 33c42f218f2eff516024c94d99f004feb4986398..77524706d3bab14b9f6875433917983a90151052 100644 (file)
@@ -1,6 +1,9 @@
 # ChangeLog for dev-db/pgcluster
 # Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/pgcluster/ChangeLog,v 1.8 2007/03/04 07:47:02 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/pgcluster/ChangeLog,v 1.9 2007/04/28 22:17:40 tove Exp $
+
+  28 Apr 2007; Torsten Veller <tove@gentoo.org> pgcluster-1.3.0c.ebuild:
+  Fix *initd, *confd and *envd calls (#173884, #174266)
 
   04 Mar 2007; Marius Mauch <genone@gentoo.org> pgcluster-1.3.0c.ebuild:
   Replacing einfo with elog
index df035f36ec1e4f961d7948668fcdb7bbdcba447d..6747f2081f839fa9f9f9db9b342be7ffb1678640 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/pgcluster/pgcluster-1.3.0c.ebuild,v 1.8 2007/03/04 07:47:02 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/pgcluster/pgcluster-1.3.0c.ebuild,v 1.9 2007/04/28 22:17:40 tove Exp $
 
 inherit eutils gnuconfig flag-o-matic multilib
 
@@ -154,18 +154,16 @@ src_install() {
        ${D}/etc/pgcluster/pglb.conf
 
        cd ${S}
-       exeinto /etc/init.d/
-       newexe ${FILESDIR}/pgcluster.init-${PV} pgcluster || die
-       newexe ${FILESDIR}/pglb.init-${PV} pglb || die
-       newexe ${FILESDIR}/pgreplicate.init-${PV} pgreplicate || die
-#      newexe ${FILESDIR}/pg_autovacuum.init-${PV} pg_autovacuum || die
+       newinitd ${FILESDIR}/pgcluster.init-${PV} pgcluster || die
+       newinitd ${FILESDIR}/pglb.init-${PV} pglb || die
+       newinitd ${FILESDIR}/pgreplicate.init-${PV} pgreplicate || die
+#      newinitd ${FILESDIR}/pg_autovacuum.init-${PV} pg_autovacuum || die
        dosed "s:___DOCDIR___:/usr/share/doc/${PF}:" /etc/init.d/pg_autovacuum
 
-       insinto /etc/conf.d/
-       newins ${FILESDIR}/pgcluster.conf-${PV} pgcluster || die
-       newins ${FILESDIR}/pglb.conf-${PV} pglb || die
-       newins ${FILESDIR}/pgreplicate.conf-${PV} pgreplicate || die
-#      newins ${FILESDIR}/pg_autovacuum.conf-${PV} pg_autovacuum || die
+       newconfd ${FILESDIR}/pgcluster.conf-${PV} pgcluster || die
+       newconfd ${FILESDIR}/pglb.conf-${PV} pglb || die
+       newconfd ${FILESDIR}/pgreplicate.conf-${PV} pgreplicate || die
+#      newconfd ${FILESDIR}/pg_autovacuum.conf-${PV} pg_autovacuum || die
 
        keepdir $PG_DIR
        keepdir /var/log/pgcluster