Removed old versions.
authorMatsuu Takuto <matsuu@gentoo.org>
Mon, 27 Feb 2006 15:17:23 +0000 (15:17 +0000)
committerMatsuu Takuto <matsuu@gentoo.org>
Mon, 27 Feb 2006 15:17:23 +0000 (15:17 +0000)
Package-Manager: portage-2.0.54

net-misc/scponly/Manifest
net-misc/scponly/files/digest-scponly-4.0 [deleted file]
net-misc/scponly/files/digest-scponly-4.1 [deleted file]
net-misc/scponly/scponly-4.0.ebuild [deleted file]
net-misc/scponly/scponly-4.1.ebuild [deleted file]

index 1f030585e2e66f4703439ad0cf17c073f5cf2669..a232b1f0423085f24a070e4df6dfde717e3893ba 100644 (file)
@@ -1,13 +1,9 @@
 MD5 430bba7e4e16c40776b9c3e015c21312 ChangeLog 3429
-MD5 a1f6bee0be7b749e155d9ec945ce31a4 files/digest-scponly-4.0 59
-MD5 43e0a1f99fd0eb893cf3608c3f1a236d files/digest-scponly-4.1 59
 MD5 18902f9bf0f2f546d7bdcf8d96174d8a files/digest-scponly-4.3 59
 MD5 4b7650a14422998944e74496850cadf1 files/digest-scponly-4.6 59
 MD5 686ea1fd09ee5c0522217845d6bc33cb files/scponly-4.1-gentoo.patch 4634
 MD5 c899ab1f389400eaa4568c416dbcd493 files/scponly-4.2-getopt.patch 625
 MD5 c6b771b0da5de88d90f4715e2fe69e85 files/scponly-4.3-getopt.patch 616
 MD5 e10a0da4fac2882942ffa8360ccdd921 metadata.xml 201
-MD5 48f3604e22751295c07e471844ade2bb scponly-4.0.ebuild 3067
-MD5 dadf22d4d802d59445e6a28a7f7fc934 scponly-4.1.ebuild 1124
 MD5 6dcab119834e16747a1d62afa6be3ced scponly-4.3.ebuild 1147
 MD5 9bf0ff80af9710e903a70988abf2508f scponly-4.6.ebuild 4031
diff --git a/net-misc/scponly/files/digest-scponly-4.0 b/net-misc/scponly/files/digest-scponly-4.0
deleted file mode 100644 (file)
index 537377f..0000000
+++ /dev/null
@@ -1 +0,0 @@
-MD5 1706732945996865ed0cccd440b64fc1 scponly-4.0.tgz 85053
diff --git a/net-misc/scponly/files/digest-scponly-4.1 b/net-misc/scponly/files/digest-scponly-4.1
deleted file mode 100644 (file)
index 83b4f15..0000000
+++ /dev/null
@@ -1 +0,0 @@
-MD5 32e4b87dc46c78573010c1146e9744f0 scponly-4.1.tgz 93138
diff --git a/net-misc/scponly/scponly-4.0.ebuild b/net-misc/scponly/scponly-4.0.ebuild
deleted file mode 100644 (file)
index deb7078..0000000
+++ /dev/null
@@ -1,107 +0,0 @@
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/scponly/scponly-4.0.ebuild,v 1.1 2004/12/02 15:30:22 matsuu Exp $
-
-inherit eutils
-
-DESCRIPTION="A tiny pseudoshell which only permits scp and sftp"
-HOMEPAGE="http://www.sublimation.org/scponly/"
-SRC_URI="http://www.sublimation.org/scponly/${P}.tgz"
-
-LICENSE="as-is"
-SLOT="0"
-KEYWORDS="x86 amd64 ~sparc ~ppc"
-IUSE=""
-
-DEPEND="virtual/libc
-       net-misc/openssh"
-
-src_compile() {
-       PATH="${PATH}:/usr/lib/misc" \
-       econf \
-               --enable-rsync-compat \
-               --enable-chrooted-binary \
-               || die "./configure failed"
-       emake || die
-}
-
-src_install() {
-       make prefix=${D}/usr \
-               mandir=${D}/usr/share/man \
-               CONFDIR=${D}/etc/scponly \
-               install || die
-
-       dodoc AUTHOR CHANGELOG CONTRIB README TODO
-}
-
-pkg_postinst() {
-       # pkg_postinst is based on ${S}/setup_chroot.sh.
-
-       local myuser="scponly"
-       local myhome="/home/${myuser}"
-
-       einfo "Updating /etc/shells"
-       { grep -v "^/usr/bin/scponly$" /etc/shells;
-       echo "/usr/bin/scponly"
-       } > ${T}/shells
-       mv -f ${T}/shells /etc/shells
-
-       { grep -v "^/usr/sbin/scponlyc$" /etc/shells;
-       echo "/usr/sbin/scponlyc"
-       } > ${T}/shells
-       mv -f ${T}/shells /etc/shells
-
-       BINARIES="/usr/lib/misc/sftp-server /bin/ls /usr/bin/scp /bin/rm /bin/ln /bin/mv /bin/chmod /bin/chown /bin/chgrp /bin/mkdir /bin/rmdir /bin/pwd /bin/groups /usr/bin/ld /bin/echo /usr/bin/rsync"
-       LIB_LIST=`/usr/bin/ldd $BINARIES 2> /dev/null | /bin/cut -f2 -d\> | /bin/cut -f1 -d\( | /bin/grep "^ " | /bin/sort -u`
-       LDSO_LIST="/lib/ld.so /libexec/ld-elf.so /libexec/ld-elf.so.1 /usr/libexec/ld.so /lib/ld-linux.so.2 /usr/libexec/ld-elf.so.1"
-       for lib in $LDSO_LIST; do
-               if [ -f $lib ]; then
-                       LIB_LIST="$LIB_LIST $lib"
-               fi
-       done
-       /bin/ls /lib/libnss_compat* > /dev/null 2>&1
-       if [ $? -eq 0 ]; then
-               LIB_LIST="$LIB_LIST /lib/libnss_compat*"
-       fi
-
-       ldconfig
-       LIB_LIST="$LIB_LIST /etc/ld.so.cache /etc/ld.so.conf"
-
-       enewgroup ${myuser}
-       enewuser ${myuser} -1 /usr/sbin/scponlyc ${myhome} ${myuser}
-       if [ ! -d ${myhome} ]; then
-               /bin/install -c -d ${myhome}
-               /bin/chmod 755 ${myhome}
-       fi
-       if [ ! -d ${myhome} ]; then
-               /bin/install -c -d ${myhome}/etc
-               /bin/chown 0:0 ${myhome}/etc
-               /bin/chmod 755 ${myhome}/etc
-       fi
-       for bin in $BINARIES; do
-               /bin/install -c -d ${myhome}/`/bin/dirname $bin`
-               /bin/install -c $bin ${myhome}/$bin
-       done
-       for lib in $LIB_LIST; do
-               /bin/install -c -d ${myhome}/`/bin/dirname $lib`
-               /bin/install -c $lib ${myhome}/$lib
-       done
-
-       /bin/chown 0:0 ${myhome}
-       if [ -d ${myhome}/.ssh ]; then
-               /bin/chown 0:0 ${myhome}/.ssh
-       fi
-
-       if [ ! -d ${myhome}/incoming ]; then
-               einfo "creating ${myhome}/incoming directory for uploading files"
-               /bin/install -c -o ${myuser} -d ${myhome}/incoming
-       fi
-       /bin/chown $myuser:$myuser ${myhome}/incoming
-
-       grep "^${myuser}" /etc/passwd > ${myhome}/etc/passwd
-
-       einfo ""
-       einfo "if you experience a warning with winscp regarding groups, please install"
-       einfo "the provided hacked out fake groups program into your chroot, like so:"
-       einfo "cp groups ${myhome}/bin/groups"
-}
diff --git a/net-misc/scponly/scponly-4.1.ebuild b/net-misc/scponly/scponly-4.1.ebuild
deleted file mode 100644 (file)
index 37b07b2..0000000
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/scponly/scponly-4.1.ebuild,v 1.1 2005/09/19 23:11:36 matsuu Exp $
-
-inherit eutils
-
-DESCRIPTION="A tiny pseudoshell which only permits scp and sftp"
-HOMEPAGE="http://www.sublimation.org/scponly/"
-SRC_URI="http://www.sublimation.org/scponly/${P}.tgz"
-
-LICENSE="as-is"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-IUSE=""
-
-DEPEND="virtual/libc
-       net-misc/openssh"
-
-src_unpack() {
-       unpack ${A}
-       cd ${S}
-
-       epatch ${FILESDIR}/${P}-gentoo.patch
-}
-
-src_compile() {
-       PATH="${PATH}:/usr/$(get_libdir)/misc" \
-       econf \
-               --enable-rsync-compat \
-               --enable-chrooted-binary \
-               || die "./configure failed"
-#              --enable-svn-compat\ # subversion SCS cli compatibility
-#              --enable-svnserv-compat\ # subversion SCS svnserve compatibility
-       emake || die
-}
-
-src_install() {
-       make DESTDIR=${D} install || die
-
-       dodoc AUTHOR BUILDING-JAILS.TXT CHANGELOG CONTRIB README TODO
-       dodoc setup_chroot.sh
-}
-
-pkg_postinst() {
-       einfo "Setting up chroot in pkg_postinst was removed. Please setup manually."
-}