sys-cluster/glusterfs: version bump
authorTiziano Müller <dev-zero@gentoo.org>
Tue, 8 Sep 2015 12:04:34 +0000 (14:04 +0200)
committerTiziano Müller <dev-zero@gentoo.org>
Tue, 8 Sep 2015 12:06:11 +0000 (14:06 +0200)
Package-Manager: portage-2.2.20.1

sys-cluster/glusterfs/Manifest
sys-cluster/glusterfs/glusterfs-3.7.4.ebuild [new file with mode: 0644]
sys-cluster/glusterfs/metadata.xml

index 3115e9bca3aad06fe379d7501c731e08d5be8d7f..a1cfb400276d0e41d6fe6664bf2866d1e17ac866 100644 (file)
@@ -1,3 +1,4 @@
 DIST glusterfs-3.1.2.tar.gz 2086469 SHA256 9a4e910431f572aa180a3ad1821f7524773ec1e8f06342c4040f26619f832838 SHA512 69b61af7c6cd9f54f615f7cd50c6ffda670800c6045604449b130eaa43c90c9adcb518c1312134890cccf3a301066a5af3e97bd7ec9775b7f70ea6d0a4a67cd6 WHIRLPOOL 0ecc86ac943f4c8d9575b8b0ae2ef72002d6510945e1a687409277165eb7688c2e4db50532ae10777828646b782561dfd4314fa766d7a3bcf4762e8be7c34c79
 DIST glusterfs-3.5.4.tar.gz 5199067 SHA256 8e8bf9ff6b3884c420653dbf7549f8240cb30aa4a55c852ebb8f293f8089ad35 SHA512 eac2e5eacf33a04c574d495ea532703222faa559e34702f5939e9300936064d0867e4de9653be64dd3fa7fc1976e32915521a0ba07dc3c16c03b598a64dc12da WHIRLPOOL b597b677d6284e0419b6d1574d24bc6677bffec120c2ff37fc83f51b0fd048ec9bae8873b530e44cad10e85c109f8a97f3e67f85a4709207d488f64d561fc068
 DIST glusterfs-3.6.5.tar.gz 6091408 SHA256 20d912ef35fb8350c50c39c15134a3558ee90d012203f049799c8eb67a61fd2a SHA512 7ca41855239818fc4c84cdb86e1f1d39502e781d5117a5ee50ea134f03f0823a8640ee9bda28f05463e8504aba9ddb12ac72e118f0ce7c3755c083033f5677ca WHIRLPOOL 9fc0592052d976d65fcc769c69d910fa6d909695162bccf80c1e799a2c54c531ab03a4afd3788951c231a214a22e5f8bb3613a83277858627425b86fd532ab5e
+DIST glusterfs-3.7.4.tar.gz 7552110 SHA256 f98f448117d1de7666ae425eddd8d7d87b02c57f6627234ce96ba60566f47173 SHA512 f9a281f3a37835f9f54679740ddb19b307babe576a8f14c9ef24d256f483789c227d7e7c5b0ed4ef5c13a257bcf00d0c17b6108fa60c5e45d0175df6e236b3a5 WHIRLPOOL 7b0320936de078234228cb691f3e381da3cc89c638d6246aba63695aa36cb114afca6e53d12d23de441b8da0b3a594ac1702b450d5d14720254af73e689c4ab8
diff --git a/sys-cluster/glusterfs/glusterfs-3.7.4.ebuild b/sys-cluster/glusterfs/glusterfs-3.7.4.ebuild
new file mode 100644 (file)
index 0000000..63405a2
--- /dev/null
@@ -0,0 +1,206 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+AUTOTOOLS_AUTORECONF=1
+
+inherit autotools-utils elisp-common eutils multilib python-single-r1 systemd versionator
+
+DESCRIPTION="GlusterFS is a powerful network/cluster filesystem"
+HOMEPAGE="http://www.gluster.org/"
+SRC_URI="http://download.gluster.org/pub/gluster/${PN}/$(get_version_component_range '1-2')/${PV}/${P}.tar.gz"
+
+LICENSE="|| ( GPL-2 LGPL-3+ )"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="bd-xlator crypt-xlator debug emacs +fuse +georeplication glupy infiniband qemu-block rsyslog static-libs +syslog systemtap test +tiering vim-syntax +xml"
+
+REQUIRED_USE="georeplication? ( ${PYTHON_REQUIRED_USE} )
+       glupy? ( ${PYTHON_REQUIRED_USE} )"
+
+# the tests must be run as root
+RESTRICT="test"
+
+# sys-apps/util-linux is required for libuuid
+RDEPEND="bd-xlator? ( sys-fs/lvm2 )
+       emacs? ( virtual/emacs )
+       fuse? ( >=sys-fs/fuse-2.7.0 )
+       georeplication? ( ${PYTHON_DEPS} )
+       infiniband? ( sys-infiniband/libibverbs:* sys-infiniband/librdmacm:* )
+       qemu-block? ( dev-libs/glib:2 )
+       systemtap? ( dev-util/systemtap )
+       tiering? ( dev-db/sqlite:3 )
+       xml? ( dev-libs/libxml2 )
+       sys-libs/readline:=
+       dev-libs/libaio
+       dev-libs/openssl:=
+       dev-libs/userspace-rcu:=
+       || ( sys-libs/glibc sys-libs/argp-standalone )
+       sys-apps/util-linux"
+DEPEND="${RDEPEND}
+       virtual/pkgconfig
+       sys-devel/bison
+       sys-devel/flex
+       test? ( >=dev-util/cmocka-1.0.1
+               app-benchmarks/dbench
+               dev-vcs/git
+               net-fs/nfs-utils
+               virtual/perl-Test-Harness
+               dev-libs/yajl
+               sys-fs/xfsprogs
+               sys-apps/attr )"
+
+SITEFILE="50${PN}-mode-gentoo.el"
+
+PATCHES=(
+       "${FILESDIR}/${PN}-3.4.0-silent_rules.patch"
+)
+
+DOCS=( AUTHORS ChangeLog NEWS README.md THANKS )
+
+# Maintainer notes:
+# * The build system will always configure & build argp-standalone but it'll never use it
+#   if the argp.h header is found in the system. Which should be the case with
+#   glibc or if argp-standalone is installed.
+
+pkg_setup() {
+       ( use georeplication || use glupy ) && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+       # build rpc-transport and xlators only once as shared libs
+       find rpc/rpc-transport xlators -name Makefile.am -print0 \
+               | xargs -0 sed -i -e 's|.*_la_LDFLAGS = .*|\0 -shared|'
+
+       autotools-utils_src_prepare
+}
+
+src_configure() {
+       local myeconfargs=(
+               --disable-dependency-tracking
+               --disable-silent-rules
+               --disable-fusermount
+               $(use_enable debug)
+               $(use_enable bd-xlator)
+               $(use_enable crypt-xlator)
+               $(use_enable fuse fuse-client)
+               $(use_enable georeplication)
+               $(use_enable glupy)
+               $(use_enable infiniband ibverbs)
+               $(use_enable qemu-block)
+               $(use_enable static-libs static)
+               $(use_enable syslog)
+               $(use_enable systemtap)
+               $(use_enable test cmocka)
+               $(use_enable tiering)
+               $(use_enable xml xml-output)
+               --docdir=/usr/share/doc/${PF}
+               --localstatedir=/var
+       )
+       autotools-utils_src_configure
+}
+
+src_compile() {
+       autotools-utils_src_compile
+
+       use emacs && elisp-compile extras/glusterfs-mode.el
+}
+
+src_install() {
+       autotools-utils_src_install
+
+       rm \
+               "${D}"/etc/glusterfs/glusterfs-{georep-,}logrotate \
+               "${D}"/etc/glusterfs/gluster-rsyslog-*.conf \
+               "${D}"/usr/share/doc/${PF}/glusterfs{-mode.el,.vim} || die "removing false files failed"
+
+       insinto /etc/logrotate.d
+       newins "${FILESDIR}"/glusterfs.logrotate glusterfs
+
+       if use rsyslog ; then
+               insinto /etc/rsyslog.d
+               newins extras/gluster-rsyslog-7.2.conf 60-gluster.conf
+       fi
+
+       if use emacs ; then
+               elisp-install ${PN} extras/glusterfs-mode.el*
+               elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+       fi
+
+       if use vim-syntax ; then
+               insinto /usr/share/vim/vimfiles/ftdetect; doins "${FILESDIR}"/${PN}.vim
+               insinto /usr/share/vim/vimfiles/syntax; doins extras/${PN}.vim
+       fi
+
+       # insert some other tools which might be useful
+       insinto /usr/share/glusterfs/scripts
+       doins \
+               extras/backend-{cleanup,xattr-sanitize}.sh \
+               extras/clear_xattrs.sh \
+               extras/migrate-unify-to-distribute.sh
+
+       # correct permissions on installed scripts
+       # fperms 0755 /usr/share/glusterfs/scripts/*.sh
+       chmod 0755 "${ED}"/usr/share/glusterfs/scripts/*.sh || die
+
+       if use georeplication ; then
+               # move the gsync-sync-gfid tool to a binary path
+               # and set a symlink to be compliant with all other distros
+               mv "${ED}"/usr/{share/glusterfs/scripts/gsync-sync-gfid,libexec/glusterfs/} || die
+               dosym ../../../libexec/glusterfs/gsync-sync-gfid /usr/share/glusterfs/scripts/gsync-sync-gfid
+       fi
+
+       newinitd "${FILESDIR}/${PN}-r1.initd" glusterfsd
+       newinitd "${FILESDIR}/glusterd-r2.initd" glusterd
+       newconfd "${FILESDIR}/${PN}.confd" glusterfsd
+
+       keepdir /var/log/${PN}
+       keepdir /var/lib/glusterd
+
+       # QA
+       rm -rf "${ED}/var/run/" || die
+       use static-libs || find "${ED}"/usr/$(get_libdir)/ -type f -name '*.la' -delete
+
+       use georeplication && python_fix_shebang "${ED}"
+
+       # upstream already has a patch ready, to be removed once available, http://review.gluster.org/#/c/9458/
+       echo "d /run/gluster 0755 root root -" > "${T}/gluster.tmpfiles" || die
+       systemd_newtmpfilesd "${T}/gluster.tmpfiles" gluster.conf
+}
+
+src_test() {
+       ./run-tests.sh || die
+}
+
+pkg_postinst() {
+       elog "Starting with ${PN}-3.1.0, you can use the glusterd daemon to configure your"
+       elog "volumes dynamically. To do so, simply use the gluster CLI after running:"
+       elog "  /etc/init.d/glusterd start"
+       echo
+       elog "For static configurations, the glusterfsd startup script can be multiplexed."
+       elog "The default startup script uses /etc/conf.d/glusterfsd to configure the"
+       elog "separate service.  To create additional instances of the glusterfsd service"
+       elog "simply create a symlink to the glusterfsd startup script."
+       echo
+       elog "Example:"
+       elog "    # ln -s glusterfsd /etc/init.d/glusterfsd2"
+       elog "    # ${EDITOR} /etc/glusterfs/glusterfsd2.vol"
+       elog "You can now treat glusterfsd2 like any other service"
+       echo
+       ewarn "You need to use a ntp client to keep the clocks synchronized across all"
+       ewarn "of your servers. Setup a NTP synchronizing service before attempting to"
+       ewarn "run GlusterFS."
+
+       elog
+       elog "If you are upgrading from a previous version of ${PN}, please read:"
+       elog "  http://www.gluster.org/community/documentation/index.php/Upgrade_to_3.5"
+
+       use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+       use emacs && elisp-site-regen
+}
index 7ca776b6ff2cff0f4ea2485d0bf3adb565fb0d92..f994b7843b5253058b81cdd7d153328090ee4fc3 100644 (file)
@@ -17,5 +17,6 @@
     <flag name="rsyslog">Install configuration snippet for <pkg>app-admin/rsyslog</pkg></flag>
     <flag name="qemu-block">Transparently create files as QCow2/QED images in the backend, including the possibility to snapshot.</flag>
     <flag name="systemtap">Enable support for <pkg>dev-util/systemtap</pkg></flag>
+    <flag name="tiering">Enable support for data classification/tiering (requires <pkg>dev-db/sqlite:3</pkg>)</flag>
   </use>
 </pkgmetadata>