sys-devel/clang-runtime: Bump to 9.0.1 final
authorMichał Górny <mgorny@gentoo.org>
Sat, 21 Dec 2019 07:29:30 +0000 (08:29 +0100)
committerMichał Górny <mgorny@gentoo.org>
Sat, 21 Dec 2019 08:30:01 +0000 (09:30 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
sys-devel/clang-runtime/clang-runtime-9.0.1.ebuild [new file with mode: 0644]

diff --git a/sys-devel/clang-runtime/clang-runtime-9.0.1.ebuild b/sys-devel/clang-runtime/clang-runtime-9.0.1.ebuild
new file mode 100644 (file)
index 0000000..6250baa
--- /dev/null
@@ -0,0 +1,24 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multilib-build
+
+DESCRIPTION="Meta-ebuild for clang runtime libraries"
+HOMEPAGE="https://clang.llvm.org/"
+SRC_URI=""
+
+LICENSE="metapackage"
+SLOT="$(ver_cut 1-3)"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="+compiler-rt libcxx openmp +sanitize"
+REQUIRED_USE="sanitize? ( compiler-rt )"
+
+RDEPEND="
+       compiler-rt? (
+               ~sys-libs/compiler-rt-${PV}:${SLOT}
+               sanitize? ( ~sys-libs/compiler-rt-sanitizers-${PV}:${SLOT} )
+       )
+       libcxx? ( >=sys-libs/libcxx-${PV}[${MULTILIB_USEDEP}] )
+       openmp? ( >=sys-libs/libomp-${PV}[${MULTILIB_USEDEP}] )"