Fix src_install and push out branding and ubuntu scripts fixes, still needs ~alpha
authorStefan Schweizer <genstef@gentoo.org>
Sat, 18 Nov 2006 11:02:08 +0000 (11:02 +0000)
committerStefan Schweizer <genstef@gentoo.org>
Sat, 18 Nov 2006 11:02:08 +0000 (11:02 +0000)
Package-Manager: portage-2.1.2_rc2

net-print/gnome-cups-manager/ChangeLog
net-print/gnome-cups-manager/files/digest-gnome-cups-manager-0.31-r2 [new file with mode: 0644]
net-print/gnome-cups-manager/gnome-cups-manager-0.31-r2.ebuild [new file with mode: 0644]

index 08e7d63b08a014cdee3c07b3cda7d2181085a936..dc49756528897c82f2ea3d43deb04f50ff8f54b1 100644 (file)
@@ -1,6 +1,10 @@
 # ChangeLog for net-print/gnome-cups-manager
 # Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/gnome-cups-manager/ChangeLog,v 1.57 2006/11/16 21:45:42 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/gnome-cups-manager/ChangeLog,v 1.58 2006/11/18 11:02:08 genstef Exp $
+
+  18 Nov 2006; Stefan Schweizer <genstef@gentoo.org>
+  -gnome-cups-manager-0.31-r1.ebuild, +gnome-cups-manager-0.31-r2.ebuild:
+  Fix src_install and push out branding and ubuntu scripts fixes
 
   16 Nov 2006; Stefan Schweizer <genstef@gentoo.org>
   gnome-cups-manager-0.31-r1.ebuild:
diff --git a/net-print/gnome-cups-manager/files/digest-gnome-cups-manager-0.31-r2 b/net-print/gnome-cups-manager/files/digest-gnome-cups-manager-0.31-r2
new file mode 100644 (file)
index 0000000..07efbc4
--- /dev/null
@@ -0,0 +1,6 @@
+MD5 4144b2cf05e381e89fed066793e3b249 gnome-cups-manager-0.31.tar.bz2 507851
+RMD160 4dfaaa301ab043e2f1806b2d339169109d56f9b5 gnome-cups-manager-0.31.tar.bz2 507851
+SHA256 8ccfd3816757fa8127cf96a530e374c81a449fbcd9391d2d3e1bac29f54ab3e6 gnome-cups-manager-0.31.tar.bz2 507851
+MD5 6aac1d7e1ce80317e90672b650ac0c0f gnome-cups-manager_0.31-1.1ubuntu14.diff.gz 387348
+RMD160 cb476338989e257f6f57daab74414a3b87627690 gnome-cups-manager_0.31-1.1ubuntu14.diff.gz 387348
+SHA256 d89dbe9b398265ea7a7c0b72f705b31aac957a822e56f80cc65baafa4b9d8993 gnome-cups-manager_0.31-1.1ubuntu14.diff.gz 387348
diff --git a/net-print/gnome-cups-manager/gnome-cups-manager-0.31-r2.ebuild b/net-print/gnome-cups-manager/gnome-cups-manager-0.31-r2.ebuild
new file mode 100644 (file)
index 0000000..60d8ccd
--- /dev/null
@@ -0,0 +1,71 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-print/gnome-cups-manager/gnome-cups-manager-0.31-r2.ebuild,v 1.1 2006/11/18 11:02:08 genstef Exp $
+
+inherit eutils gnome2 flag-o-matic
+
+DESCRIPTION="GNOME CUPS Printer Management Interface"
+HOMEPAGE="http://www.gnome.org/"
+
+#
+# Please ensure that gcc-3.4 is stable on the arch before moving this to stable.
+#
+SRC_URI="${SRC_URI}
+       http://archive.ubuntu.com/ubuntu/pool/main/g/gnome-cups-manager/gnome-cups-manager_0.31-1.1ubuntu14.diff.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~sparc ~x86"
+IUSE=""
+
+# See ChangeLog regarding libgnomeui
+RDEPEND=">=x11-libs/gtk+-2.3.1
+       >=dev-libs/glib-2.3.1
+       >=gnome-base/libgnome-2
+       >=gnome-base/libgnomeui-2.2
+       >=gnome-base/libglade-2
+       >=gnome-base/libbonobo-2
+       >=net-print/libgnomecups-0.2.0
+       gnome-base/gnome-keyring
+       x11-libs/gksu"
+
+DEPEND=">=x11-libs/gtk+-2.3.1
+       >=dev-libs/glib-2.3.1
+       >=gnome-base/libgnome-2
+       >=gnome-base/libgnomeui-2.2
+       >=gnome-base/libglade-2
+       >=gnome-base/libbonobo-2
+       >=net-print/libgnomecups-0.2.0
+       gnome-base/gnome-keyring
+       >=dev-util/pkgconfig-0.9
+       >=dev-util/intltool-0.28"
+
+DOCS="ChangeLog NEWS README"
+
+src_unpack() {
+       gnome2_src_unpack
+       # exclude ubuntu branding
+       mkdir ${WORKDIR}/ubuntu
+       cd ${WORKDIR}/ubuntu
+       cp -r ${S}/{po,ChangeLog,gnome-cups-manager} .
+       # Remove the ubuntu functions that require external
+       # scripts fixing bug 147972 (removes LAN browsing detection)
+       sed -i \
+               -e '/^---.*ui_browse_share_ctl.patch/,/^---/{/^---.*ui_browse_share_ctl.patch/!d;}' \
+               ${WORKDIR}/gnome-cups-manager_0.31-1.1ubuntu14.diff
+       epatch ${WORKDIR}/gnome-cups-manager_0.31-1.1ubuntu14.diff
+       # gksudo does not always work
+       sed -i "s:gksudo:gksu:" debian/patches/change-su-command.patch
+       cd ${S}
+       epatch ${WORKDIR}/ubuntu/debian/patches/*
+
+       # bug 141929
+       use amd64 && replace-flags -O* -O0
+}
+
+src_install() {
+       gnome2_src_install
+       cd ${WORKDIR}/ubuntu/debian
+       doman gnome-cups-icon.1 gnome-cups-manager.1 gnome-cups-add.8
+       domenu gnome-cups-icon.desktop gnome-cups-manager.desktop
+}