dev-python/django-debug-toolbar: Require sqlite, modernize
authorMichał Górny <mgorny@gentoo.org>
Tue, 19 May 2020 12:05:18 +0000 (14:05 +0200)
committerMichał Górny <mgorny@gentoo.org>
Tue, 19 May 2020 12:05:18 +0000 (14:05 +0200)
Closes: https://bugs.gentoo.org/723596
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/django-debug-toolbar/django-debug-toolbar-2.2.ebuild

index 2874326eb203038b76b73974d40993178f9ee366..ee772858946dbd9658f9121dd1ce48917376fd1c 100644 (file)
@@ -16,37 +16,34 @@ SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
 SLOT="0"
 LICENSE="BSD"
 KEYWORDS="~amd64 ~x86"
-IUSE="doc examples"
+IUSE="doc examples test"
+RESTRICT="!test? ( test )"
 
 RDEPEND="
        >=dev-python/django-1.11[${PYTHON_USEDEP}]
        >=dev-python/sqlparse-0.2.0[${PYTHON_USEDEP}]
-       doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
 "
-DEPEND="${RDEPEND}
-       dev-python/setuptools[${PYTHON_USEDEP}]
+DEPEND="
+       test? (
+               $(python_gen_impl_dep sqlite)
+               ${RDEPEND}
+       )
 "
 
-python_prepare_all() {
-       # Prevent non essential d'loading by intersphinx
-       sed -e 's:intersphinx_mapping:_&:' -i docs/conf.py || die
+distutils_enable_sphinx docs
 
+python_prepare_all() {
        # This prevents distutils from installing 'tests' package, rm magic no more needed
        sed -e "/find_packages/s:'tests':'tests.\*', 'tests':" -i setup.py || die
 
        distutils-r1_python_prepare_all
 }
 
-python_compile_all() {
-       use doc && emake -C docs html
-}
-
 python_test() {
        emake test
 }
 
 python_install_all() {
-       use doc && local HTML_DOCS=( docs/_build/html/. )
        if use examples; then
                docinto examples
                dodoc -r example/.