dev-ada/xmlada: Stabilize and remove old
authorTupone Alfredo <tupone@gentoo.org>
Wed, 7 Nov 2018 20:05:55 +0000 (21:05 +0100)
committerTupone Alfredo <tupone@gentoo.org>
Wed, 7 Nov 2018 20:05:55 +0000 (21:05 +0100)
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Package-Manager: Portage-2.3.51, Repoman-2.3.11

dev-ada/xmlada/Manifest
dev-ada/xmlada/files/xmlada-2018-gentoo.patch [moved from dev-ada/xmlada/files/xmlada-2017-gentoo.patch with 100% similarity]
dev-ada/xmlada/xmlada-2017.ebuild [deleted file]
dev-ada/xmlada/xmlada-2018.ebuild

index 90f31e2b4d07954b5b4e80bde5fe8558d65b5d5c..965ea0318176ec6be1ded0a5890ea065010c4e45 100644 (file)
@@ -1,2 +1 @@
-DIST xmlada-gpl-2017-src.tar.gz 1578393 BLAKE2B 7b4894040b6044e86c96cbd530ebda5c0cfc4ad0e2b472d46798a93f535aca0916b03385a3aef49bd4e59d508a9665c856360e9cab0a4f67b15091228b629d81 SHA512 371f6adc01550a4bb13204ec0404dc1165438db595f4346813e5a23a155de74c857c40c55adde173919c2fe35b3b91d78b235c9718ee86bc848e62ddfd7fa2b4
 DIST xmlada-gpl-2018-src.tar.gz 1582215 BLAKE2B 11012dab19f45507eeb5ce6ebec9a77ceb5dfb7749960922f0f48bb1b0409305fd43466a7af90b48ff0a0cf58612e8859274a92e0fe272b4e57a59b92a1725f1 SHA512 8970c4e68defad66625c1110554dadfc485fbbe42e832987593cf727e98f13dd87c90b84461187dbbe2b1051831e6e70f9f53d6a0cfc07451726d601b2856430
diff --git a/dev-ada/xmlada/xmlada-2017.ebuild b/dev-ada/xmlada/xmlada-2017.ebuild
deleted file mode 100644 (file)
index b3ee623..0000000
+++ /dev/null
@@ -1,92 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit multiprocessing
-
-MYP=${PN}-gpl-${PV}
-
-DESCRIPTION="Set of modules that provide a simple manipulation of XML streams"
-HOMEPAGE="http://libre.adacore.com/"
-SRC_URI="http://mirrors.cdn.adacore.com/art/591aeb88c7a4473fcbb154f8 ->
-       ${MYP}-src.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="gnat_2016 +gnat_2017 +shared static-libs static-pic"
-REQUIRED_USE="|| ( shared static-libs static-pic )
-       ^^ ( gnat_2016 gnat_2017 )"
-
-RDEPEND="gnat_2016? ( dev-lang/gnat-gpl:4.9.4 )
-       gnat_2017? ( dev-lang/gnat-gpl:6.3.0 )"
-DEPEND="${RDEPEND}
-       dev-ada/gprbuild[gnat_2016=,gnat_2017=]"
-
-S="${WORKDIR}"/${MYP}-src
-
-PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )
-
-src_configure () {
-       econf --prefix="${D}"/usr
-}
-
-src_compile () {
-       build () {
-               gprbuild -j$(makeopts_jobs) -m -p -v -XLIBRARY_TYPE=$1 \
-                       -XBUILD=Production -XPROCESSORS=$(makeopts_jobs) xmlada.gpr \
-                       -cargs ${ADAFLAGS} || die "gprbuild failed"
-       }
-       if use shared; then
-               build relocatable
-       fi
-       if use static-libs; then
-               build static
-       fi
-       if use static-pic; then
-               build static-pic
-       fi
-}
-
-src_test() {
-       emake test
-       emake run_test | grep DIFF && die
-}
-
-src_install () {
-       local includedir=/usr/include/${PN}
-
-       fix_install () {
-               mv "${D}"${includedir}/$1.$2/* "${D}"${includedir}/$1/ || die
-               for file in "${D}"${includedir}/$1/*; do
-                       dosym ../$1/$(basename ${file}) \
-                               ${includedir}/$1.$2/$(basename ${file})
-               done
-       }
-
-       if use static-libs; then
-               emake PROCESSORS=$(makeopts_jobs) install-static
-       fi
-       for kind in shared static-pic; do
-               if use ${kind}; then
-                       emake PROCESSORS=$(makeopts_jobs) install-${kind}
-               fi
-       done
-       rm "${D}"/usr/lib/libxmlada_* || die
-       for dir in xmlada_{dom,input,sax,schema,unicode}; do
-               dodir /usr/include/${PN}/${dir}
-               if use shared; then
-                       fix_install ${dir} relocatable
-               fi
-               if use static-libs; then
-                       fix_install ${dir} static
-               fi
-               if use static-pic; then
-                       fix_install ${dir} static-pic
-               fi
-       done
-       einstalldocs
-       dodoc xmlada-roadmap.txt
-       rm "${D}"/usr/share/doc/${PN}/.buildinfo || die
-}
index 434c852375c60a3fb53d924a9eefa3b54a9c2099..752a6a94d5a2bf1266ffb660e0f58603afd43ad9 100644 (file)
@@ -14,7 +14,7 @@ SRC_URI="http://mirrors.cdn.adacore.com/art/591aeb88c7a4473fcbb154f8 ->
 
 LICENSE="GPL-3"
 SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="amd64 x86"
 IUSE="gnat_2016 gnat_2017 +gnat_2018 +shared static-libs static-pic"
 REQUIRED_USE="|| ( shared static-libs static-pic )
        ^^ ( gnat_2016 gnat_2017 gnat_2018 )"
@@ -27,7 +27,7 @@ DEPEND="${RDEPEND}
 
 S="${WORKDIR}"/${MYP}-src
 
-PATCHES=( "${FILESDIR}"/${PN}-2017-gentoo.patch )
+PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )
 
 src_configure () {
        econf --prefix="${D}"/usr